summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcin Kryczek <mkay@gentoo.org>2005-10-20 23:22:27 +0000
committerMarcin Kryczek <mkay@gentoo.org>2005-10-20 23:22:27 +0000
commita0688877b6e05538050d3be16ae1bdd37c5045dd (patch)
treeee4a4c81a49854f0017698e7c64004f246070447 /net-p2p
parentKeyword kicker (diff)
downloadgentoo-2-a0688877b6e05538050d3be16ae1bdd37c5045dd.tar.gz
gentoo-2-a0688877b6e05538050d3be16ae1bdd37c5045dd.tar.bz2
gentoo-2-a0688877b6e05538050d3be16ae1bdd37c5045dd.zip
Removing mailcap entry and fixing .desktop file. This fixes bug #22264 and bug #105143
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bittorrent/ChangeLog8
-rw-r--r--net-p2p/bittorrent/Manifest2
-rw-r--r--net-p2p/bittorrent/bittorrent-4.1.6-r2.ebuild75
-rw-r--r--net-p2p/bittorrent/files/digest-bittorrent-4.1.6-r21
4 files changed, 85 insertions, 1 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 9732e3a3d9cc..a281e1cdcaef 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.64 2005/10/19 15:57:06 mkay Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.65 2005/10/20 23:22:27 mkay Exp $
+
+*bittorrent-4.1.6-r2 (20 Oct 2005)
+
+ 20 Oct 2005; <mkay@gentoo.org> +bittorrent-4.1.6-r2.ebuild:
+ Removing mailcap entry and fixing .desktop file. This fixes bug #22264 and
+ bug #105143
*bittorrent-4.1.6-r1 (19 Oct 2005)
diff --git a/net-p2p/bittorrent/Manifest b/net-p2p/bittorrent/Manifest
index 7635d3163b7f..248c64148523 100644
--- a/net-p2p/bittorrent/Manifest
+++ b/net-p2p/bittorrent/Manifest
@@ -7,6 +7,7 @@ MD5 6c942f2d89711fe775a838da6ce4b457 bittorrent-4.1.4.ebuild 2305
MD5 8aefbc0e49db723ca1ad02d0c409cd49 metadata.xml 160
MD5 4cc659a077dc3dbf02ad922c9175cb81 bittorrent-4.1.6.ebuild 2305
MD5 6ab119c930ad668919b114f90b649a94 bittorrent-4.1.6-r1.ebuild 2533
+MD5 99111529306f0cdb9871b2ea0c6574cc bittorrent-4.1.6-r2.ebuild 2006
MD5 21ec89d06de83ddcc4cf6d6616355190 files/bittorrent-4.1.0-fix-all.patch 2483
MD5 139c4a4367e37fcf7dc6bd18515456c2 files/btdownloadgui.desktop 166
MD5 a94d4e97cceef0143a1a5c8784b6f70c files/bttrack.conf 728
@@ -20,3 +21,4 @@ MD5 1f68732157a0742ec30e29327ad0baf1 files/digest-bittorrent-4.1.4 69
MD5 7779a7eaf51eb9f84da8a588050f53fa files/favicon.ico 1406
MD5 70e745b9990496effb12387c283f76d1 files/digest-bittorrent-4.1.6 69
MD5 70e745b9990496effb12387c283f76d1 files/digest-bittorrent-4.1.6-r1 69
+MD5 70e745b9990496effb12387c283f76d1 files/digest-bittorrent-4.1.6-r2 69
diff --git a/net-p2p/bittorrent/bittorrent-4.1.6-r2.ebuild b/net-p2p/bittorrent/bittorrent-4.1.6-r2.ebuild
new file mode 100644
index 000000000000..e530aba25c21
--- /dev/null
+++ b/net-p2p/bittorrent/bittorrent-4.1.6-r2.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-4.1.6-r2.ebuild,v 1.1 2005/10/20 23:22:27 mkay Exp $
+
+inherit distutils fdo-mime eutils
+
+MY_P="${P/bittorrent/BitTorrent}"
+#MY_P="${MY_P/}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="tool for distributing files via a distributed network of nodes"
+HOMEPAGE="http://www.bittorrent.com/"
+SRC_URI="http://www.bittorrent.com/dl/${MY_P}.tar.gz"
+
+LICENSE="BitTorrent"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+IUSE="gtk"
+
+RDEPEND="gtk? (
+ >=x11-libs/gtk+-2.4
+ >=dev-python/pygtk-2.4
+ )
+ >=dev-lang/python-2.3
+ >=dev-python/pycrypto-2.0
+ !virtual/bittorrent"
+DEPEND="${RDEPEND}
+ app-arch/gzip
+ >=sys-apps/sed-4.0.5
+ dev-python/dnspython"
+PROVIDE="virtual/bittorrent"
+
+DOCS="TRACKERLESS.txt LICENSE.txt"
+PYTHON_MODNAME="BitTorrent"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # path for documentation is in lowercase (see bug #109743)
+ sed -i -r "s:(dp.*appdir):\1.lower():" BitTorrent/platform.py
+}
+
+src_install() {
+ distutils_src_install
+ if ! use gtk; then
+ rm ${D}/usr/bin/bittorrent
+ fi
+ dohtml redirdonate.html
+
+ rm ${D}/usr/share/doc/${P}/redirdonate.html
+ mv ${D}/usr/share/doc/${MY_P}/* ${D}/usr/share/doc/${P}/
+ rm -fr ${D}/usr/share/doc/${MY_P}
+
+ if use gtk ; then
+ cp ${D}/usr/share/pixmaps/${MY_P}/bittorrent.ico ${D}/usr/share/pixmaps/
+ make_desktop_entry "bittorrent" "BitTorrent" \
+ /usr/share/pixmaps/bittorrent.ico "Network"
+ echo "MimeType=application/x-bittorrent" \
+ >> ${D}/usr/share/applications/bittorrent-${PN}.desktop
+ fi
+
+ insinto /etc/conf.d
+ newins ${FILESDIR}/bttrack.conf bttrack
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/bttrack.rc-4.1 bttrack
+}
+
+pkg_postinst() {
+ einfo "Remember that BitTorrent has changed file naming scheme"
+ einfo "To run BitTorrent just execute /usr/bin/bittorrent"
+ distutils_pkg_postinst
+ fdo-mime_desktop_database_update
+}
diff --git a/net-p2p/bittorrent/files/digest-bittorrent-4.1.6-r2 b/net-p2p/bittorrent/files/digest-bittorrent-4.1.6-r2
new file mode 100644
index 000000000000..80c74146097d
--- /dev/null
+++ b/net-p2p/bittorrent/files/digest-bittorrent-4.1.6-r2
@@ -0,0 +1 @@
+MD5 ba371b39ee6bce98775e6c346d5e8b58 BitTorrent-4.1.6.tar.gz 2313097