summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-17 23:27:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-17 23:27:31 +0000
commit7b685f82b14e1641871c1088623526bb45342174 (patch)
tree7ddcbe32c65d57b5c1a1d0186d64679cad30ef00 /net-p2p
parentAdded src_test() to current stable and added next rc (diff)
downloadgentoo-2-7b685f82b14e1641871c1088623526bb45342174.tar.gz
gentoo-2-7b685f82b14e1641871c1088623526bb45342174.tar.bz2
gentoo-2-7b685f82b14e1641871c1088623526bb45342174.zip
Backport src_test() to 0.5.0.4
(Portage version: 2.1.10.44/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/bitcoind/ChangeLog5
-rw-r--r--net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild11
2 files changed, 13 insertions, 3 deletions
diff --git a/net-p2p/bitcoind/ChangeLog b/net-p2p/bitcoind/ChangeLog
index 05d974e13fcf..d6d485468dd1 100644
--- a/net-p2p/bitcoind/ChangeLog
+++ b/net-p2p/bitcoind/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-p2p/bitcoind
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.16 2012/03/17 23:23:19 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/ChangeLog,v 1.17 2012/03/17 23:27:31 blueness Exp $
+
+ 17 Mar 2012; Anthony G. Basile <blueness@gentoo.org> bitcoind-0.5.0.4.ebuild:
+ Backport src_test() to 0.5.0.4
*bitcoind-0.6.0_rc4 (17 Mar 2012)
*bitcoind-0.5.3-r1 (17 Mar 2012)
diff --git a/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild b/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild
index 20ee8ef896a6..93e35b147411 100644
--- a/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild
+++ b/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild,v 1.1 2012/03/15 16:46:25 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bitcoind/bitcoind-0.5.0.4.ebuild,v 1.2 2012/03/17 23:27:31 blueness Exp $
EAPI=4
@@ -45,9 +45,10 @@ src_prepare() {
}
src_compile() {
- local OPTS=()
+ OPTS=()
local BOOST_PKG BOOST_VER BOOST_INC
+ OPTS+=("DEBUGFLAGS=")
OPTS+=("CXXFLAGS=${CXXFLAGS}")
OPTS+=("LDFLAGS=${LDFLAGS}")
@@ -72,6 +73,12 @@ src_compile() {
emake -f makefile.unix "${OPTS[@]}" ${PN}
}
+src_test() {
+ cd src || die
+ emake -f makefile.unix "${OPTS[@]}" test_bitcoin
+ ./test_bitcoin || die 'Tests failed'
+}
+
src_install() {
dobin src/${PN}