summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-07-18 09:17:18 +0000
committerHans de Graaff <graaff@gentoo.org>2011-07-18 09:17:18 +0000
commit43b15469b0f0924570a1670255b33a95dbf782d2 (patch)
tree5fca31a8a5d89c37c31eaffe45382783abcdfe72 /net-p2p
parentStable on amd64 wrt bug #375479 (diff)
downloadgentoo-2-43b15469b0f0924570a1670255b33a95dbf782d2.tar.gz
gentoo-2-43b15469b0f0924570a1670255b33a95dbf782d2.tar.bz2
gentoo-2-43b15469b0f0924570a1670255b33a95dbf782d2.zip
Version bump.
(Portage version: 2.1.10.3/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/gtk-gnutella/ChangeLog7
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-0.97.ebuild58
2 files changed, 64 insertions, 1 deletions
diff --git a/net-p2p/gtk-gnutella/ChangeLog b/net-p2p/gtk-gnutella/ChangeLog
index 22ae6de1280a..b3a32e2697e4 100644
--- a/net-p2p/gtk-gnutella/ChangeLog
+++ b/net-p2p/gtk-gnutella/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/gtk-gnutella
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.111 2011/05/22 16:57:06 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/ChangeLog,v 1.112 2011/07/18 09:17:18 graaff Exp $
+
+*gtk-gnutella-0.97 (18 Jul 2011)
+
+ 18 Jul 2011; Hans de Graaff <graaff@gentoo.org> +gtk-gnutella-0.97.ebuild:
+ Version bump.
22 May 2011; Thomas Kahle <tomka@gentoo.org> gtk-gnutella-0.96.9.ebuild:
x86 stable per bug 364505
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-0.97.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-0.97.ebuild
new file mode 100644
index 000000000000..8260d3937641
--- /dev/null
+++ b/net-p2p/gtk-gnutella/gtk-gnutella-0.97.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gtk-gnutella/gtk-gnutella-0.97.ebuild,v 1.1 2011/07/18 09:17:18 graaff Exp $
+
+EAPI="2"
+
+inherit eutils
+
+IUSE="nls dbus ssl +gtk"
+
+DESCRIPTION="A GTK+ Gnutella client"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+RDEPEND=">=dev-libs/libxml2-2.6.0
+ gtk? ( >=x11-libs/gtk+-2.2.1:2 )
+ dbus? ( >=sys-apps/dbus-0.35.2 )
+ ssl? ( >=net-libs/gnutls-1.0.16 )
+ nls? ( >=sys-devel/gettext-0.11.5 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # The build script does not support the equivalent --enable
+ # options so we must construct the configuration by hand.
+
+ local myconf
+
+ if ! use nls; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if ! use dbus; then
+ myconf="${myconf} --disable-dbus"
+ fi
+
+ if ! use ssl; then
+ myconf="${myconf} --disable-gnutls"
+ fi
+
+ if use gtk; then
+ myconf="${myconf} --gtk2"
+ else
+ myconf="${myconf} --topless"
+ fi
+
+ ./build.sh --configure-only --prefix="/usr" ${myconf}
+}
+
+src_install() {
+ dodir /usr/bin
+ emake INSTALL_PREFIX="${D}" install || die "Install failed"
+ dodoc AUTHORS ChangeLog README TODO
+}