summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-08-15 23:58:18 +0000
committerJon Hood <squinky86@gentoo.org>2006-08-15 23:58:18 +0000
commit417fb21b703d6bab5cc7ea287b667cf38d302c7c (patch)
tree50a8556130f95044aa48d8542dc1d3775622baec /net-p2p
parentStable on SPARC wrt bug #144026. (diff)
downloadgentoo-2-417fb21b703d6bab5cc7ea287b667cf38d302c7c.tar.gz
gentoo-2-417fb21b703d6bab5cc7ea287b667cf38d302c7c.tar.bz2
gentoo-2-417fb21b703d6bab5cc7ea287b667cf38d302c7c.zip
Patch to work with gtk-2.10, bug #143529.
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/transmission/ChangeLog7
-rw-r--r--net-p2p/transmission/files/0.6.1-configure.patch12
-rw-r--r--net-p2p/transmission/transmission-0.6.1.ebuild8
3 files changed, 25 insertions, 2 deletions
diff --git a/net-p2p/transmission/ChangeLog b/net-p2p/transmission/ChangeLog
index e59d1c9da3b3..559d49842674 100644
--- a/net-p2p/transmission/ChangeLog
+++ b/net-p2p/transmission/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-p2p/transmission
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.4 2006/07/01 14:37:57 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/ChangeLog,v 1.5 2006/08/15 23:58:18 squinky86 Exp $
+
+ 15 Aug 2006; Jon Hood <squinky86@gentoo.org> +files/0.6.1-configure.patch,
+ transmission-0.6.1.ebuild:
+ Patch to work with gtk-2.10, thanks to Serkan Kaba <serkan_kaba@yahoo.com>,
+ bug #143529.
*transmission-0.6.1 (01 Jul 2006)
diff --git a/net-p2p/transmission/files/0.6.1-configure.patch b/net-p2p/transmission/files/0.6.1-configure.patch
new file mode 100644
index 000000000000..5e911087f66b
--- /dev/null
+++ b/net-p2p/transmission/files/0.6.1-configure.patch
@@ -0,0 +1,12 @@
+diff -ur Transmission-0.6.1/configure Transmission-0 (copy).6.1/configure
+--- Transmission-0.6.1/configure 2006-06-26 00:34:41.000000000 +0300
++++ Transmission-0 (copy).6.1/configure 2006-08-11 08:23:25.000000000 +0300
+@@ -173,7 +173,7 @@
+ verbose gtk_test
+ if runcmd pkg-config gtk+-2.0
+ then
+- if runcmd expr `pkg-config --modversion gtk+-2.0` '>=' 2.6.0
++ if runcmd pkg-config --atleast-version=2.6.0 gtk+-2.0
+ then
+ cat > testconf.c << EOF
+ #include <gtk/gtk.h>
diff --git a/net-p2p/transmission/transmission-0.6.1.ebuild b/net-p2p/transmission/transmission-0.6.1.ebuild
index 1c137e4bc1c7..97ae289062c6 100644
--- a/net-p2p/transmission/transmission-0.6.1.ebuild
+++ b/net-p2p/transmission/transmission-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.6.1.ebuild,v 1.1 2006/07/01 14:37:57 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.6.1.ebuild,v 1.2 2006/08/15 23:58:18 squinky86 Exp $
inherit eutils
@@ -22,6 +22,12 @@ DEPEND="sys-devel/gettext
S="${WORKDIR}/${MY_P}"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-configure.patch
+}
+
src_compile() {
econf $(use_enable ssl openssl) \
$(use_enable gtk) || die "configure failed"