summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRainer Groesslinger <scandium@gentoo.org>2003-09-20 18:59:24 +0000
committerRainer Groesslinger <scandium@gentoo.org>2003-09-20 18:59:24 +0000
commitbaec04f68c683c1d1e726838d883ec87810fc069 (patch)
treee9d7be6dc900be52abb5af7cb99bc16f7b40ba2b /net-p2p/xmule
parentrehash.patch (diff)
downloadgentoo-2-baec04f68c683c1d1e726838d883ec87810fc069.tar.gz
gentoo-2-baec04f68c683c1d1e726838d883ec87810fc069.tar.bz2
gentoo-2-baec04f68c683c1d1e726838d883ec87810fc069.zip
rehash.patch
Diffstat (limited to 'net-p2p/xmule')
-rw-r--r--net-p2p/xmule/ChangeLog8
-rw-r--r--net-p2p/xmule/Manifest4
-rw-r--r--net-p2p/xmule/files/digest-xmule-1.6.0a-r11
-rw-r--r--net-p2p/xmule/files/rehash.patch11
-rw-r--r--net-p2p/xmule/xmule-1.6.0a-r1.ebuild38
5 files changed, 59 insertions, 3 deletions
diff --git a/net-p2p/xmule/ChangeLog b/net-p2p/xmule/ChangeLog
index e3b2664e8ad5..021fe1916fed 100644
--- a/net-p2p/xmule/ChangeLog
+++ b/net-p2p/xmule/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/xmule
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.14 2003/08/28 13:09:47 scandium Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/ChangeLog,v 1.15 2003/09/20 18:59:18 scandium Exp $
+
+*xmule-1.6.0a-r1 (20 Sep 2003)
+
+ 20 Sep 2003; Rainer Groesslinger <scandium@gentoo.org>
+ xmule-1.6.0a-r1.ebuild, files/rehash.patch:
+ fix a rehashing problem, see bug #28733
*xmule-1.6.0a (28 Aug 2003)
diff --git a/net-p2p/xmule/Manifest b/net-p2p/xmule/Manifest
index eab1c17a0da6..8a185df3a873 100644
--- a/net-p2p/xmule/Manifest
+++ b/net-p2p/xmule/Manifest
@@ -1,7 +1,7 @@
-MD5 0d899cbf50aa54cddc757ed286c8cfbf ChangeLog 1932
+MD5 1eff88af739ff306025446c2931ac612 ChangeLog 1932
MD5 ecb966d540f971284d69fff13304c649 metadata.xml 283
MD5 43584606d007a36130831183f59d267c xmule-1.6.0a.ebuild 630
-MD5 839211272471d74deb5b1314d3ead452 xmule-1.6.0a-r1.ebuild 771
+MD5 0254c2758667cef896d6b4a7851dd4a9 xmule-1.6.0a-r1.ebuild 774
MD5 d4e66918eaa0f6b42f988409ae3c218f files/rehash.patch 348
MD5 ae3ef316b6a6a3cc8b670289ed08ee79 files/digest-xmule-1.6.0a 65
MD5 ae3ef316b6a6a3cc8b670289ed08ee79 files/digest-xmule-1.6.0a-r1 65
diff --git a/net-p2p/xmule/files/digest-xmule-1.6.0a-r1 b/net-p2p/xmule/files/digest-xmule-1.6.0a-r1
new file mode 100644
index 000000000000..938b04b0f6f9
--- /dev/null
+++ b/net-p2p/xmule/files/digest-xmule-1.6.0a-r1
@@ -0,0 +1 @@
+MD5 513aee4826007d2e9c5bade5ca48b144 xmule-1.6.0.tar.bz2 1250341
diff --git a/net-p2p/xmule/files/rehash.patch b/net-p2p/xmule/files/rehash.patch
new file mode 100644
index 000000000000..b4350ab645c5
--- /dev/null
+++ b/net-p2p/xmule/files/rehash.patch
@@ -0,0 +1,11 @@
+--- src/PartFile.cpp 2003-08-26 19:33:22.000000000 +0200
++++ src/PartFile.cpp 2003-09-14 23:26:48.000000000 +0200
+@@ -464,7 +464,7 @@
+ // rehash
+ SetPartFileStatus(PS_WAITINGFORHASH);
+
+- CAddFileThread::AddFile(directory, searchpath, this);
++ CAddFileThread::AddFile(directory, basename(searchpath), this);
+ }
+ delete[] searchpath;
+
diff --git a/net-p2p/xmule/xmule-1.6.0a-r1.ebuild b/net-p2p/xmule/xmule-1.6.0a-r1.ebuild
new file mode 100644
index 000000000000..e118f6a47b7c
--- /dev/null
+++ b/net-p2p/xmule/xmule-1.6.0a-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/xmule/xmule-1.6.0a-r1.ebuild,v 1.1 2003/09/20 18:59:18 scandium Exp $
+
+inherit eutils
+
+MY_P=${P//a}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="wxWindows based client for the eDonkey/eMule/lMule network"
+HOMEPAGE="http://www.xmule.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="x86"
+
+DEPEND=">=x11-libs/wxGTK-2.4
+ >=sys-libs/zlib-1.1.4"
+
+src_unpack() {
+# Small patch to fix rehashing of unfinished files
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/rehash.patch
+}
+
+src_compile () {
+ econf || die
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die
+}
+
+src_install () {
+ einstall || die
+}