summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2004-06-23 22:08:53 +0000
committerJon Hood <squinky86@gentoo.org>2004-06-23 22:08:53 +0000
commit06b4e95571945b9e778613a8338fd02eb5bd8750 (patch)
tree9253762d9574e8aace9b587af0713046614bbd75 /net-p2p/teknap/teknap-1.4.1-r1.ebuild
parentfix use invocation (diff)
downloadgentoo-2-06b4e95571945b9e778613a8338fd02eb5bd8750.tar.gz
gentoo-2-06b4e95571945b9e778613a8338fd02eb5bd8750.tar.bz2
gentoo-2-06b4e95571945b9e778613a8338fd02eb5bd8750.zip
version bump, closes #38456
Diffstat (limited to 'net-p2p/teknap/teknap-1.4.1-r1.ebuild')
-rw-r--r--net-p2p/teknap/teknap-1.4.1-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-p2p/teknap/teknap-1.4.1-r1.ebuild b/net-p2p/teknap/teknap-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..627418cf9d46
--- /dev/null
+++ b/net-p2p/teknap/teknap-1.4.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/teknap/teknap-1.4.1-r1.ebuild,v 1.1 2004/06/23 22:08:53 squinky86 Exp $
+
+inherit eutils
+
+IUSE="xmms gtk ipv6 tcpd"
+
+DESCRIPTION="TekNap is a console Napster/OpenNap client"
+SRC_URI="http://www.cactuz.org/jnbek/teknap/TekNap-1.4.orig.tar.gz
+ http://www.cactuz.org/jnbek/teknap/TekNap-1.4-1.diff.gz"
+HOMEPAGE="http://www.cactuz.org/jnbek/teknap"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+LICENSE="as-is"
+
+DEPEND="virtual/glibc >=sys-libs/ncurses-5.2
+ gtk? ( =x11-libs/gtk+-1.2* )
+ tcpd? ( sys-apps/tcp-wrappers )
+ xmms? ( media-sound/xmms )"
+
+S=${WORKDIR}/${PN}-1.4
+
+src_unpack() {
+ unpack TekNap-1.4.orig.tar.gz
+ epatch ${DISTDIR}/TekNap-1.4-1.diff.gz
+ epatch ${FILESDIR}/teknap-1.4-gcc3.3.patch
+ epatch ${FILESDIR}/teknap-1.4-gcc3.4.patch
+}
+
+src_compile() {
+ econf `use_enable tcpd wrap` \
+ `use_enable xmms` \
+ `use_enable ipv6` \
+ `use_enable gtk` \
+ --enable-cdrom || die
+ make || die
+}
+
+src_install () {
+ einstall datadir=${D}/usr/share/TekNap install || die
+ rm ${D}/usr/bin/TekNap
+ dosym TekNap-1.4 /usr/bin/TekNap
+ dodoc COPYRIGHT README TODO Changelog doc/*.txt doc/TekNap.faq doc/bugs doc/link-guidelines doc/macosx.notes
+ doman TekNap.1
+}