summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-08-01 21:16:54 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-08-01 21:16:54 +0000
commit8e03a022b1b28e17cffb6632ddd76b286dce6765 (patch)
tree96783223fa0b0363a5d5fd0c1b338095e138630c /net-p2p/rtorrent
parentVersion bump per necoro's request (diff)
downloadgentoo-2-8e03a022b1b28e17cffb6632ddd76b286dce6765.tar.gz
gentoo-2-8e03a022b1b28e17cffb6632ddd76b286dce6765.tar.bz2
gentoo-2-8e03a022b1b28e17cffb6632ddd76b286dce6765.zip
Add patch for gcc-3.4, bug #224031. Thanks goes to Herbie Hopkins <herbie@hopkins.net>. Upstream http://libtorrent.rakshasa.no/ticket/1271 . Verified with Josef Drexler via IRC that this is the correct solution.
(Portage version: 2.2_rc5/cvs/Linux 2.6.25.8 i686)
Diffstat (limited to 'net-p2p/rtorrent')
-rw-r--r--net-p2p/rtorrent/ChangeLog8
-rw-r--r--net-p2p/rtorrent/files/rtorrent-0.8.2-gcc34.patch15
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.2-r3.ebuild3
3 files changed, 24 insertions, 2 deletions
diff --git a/net-p2p/rtorrent/ChangeLog b/net-p2p/rtorrent/ChangeLog
index abb456a5ab1f..8eace160f713 100644
--- a/net-p2p/rtorrent/ChangeLog
+++ b/net-p2p/rtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/rtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.113 2008/08/01 18:42:09 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/ChangeLog,v 1.114 2008/08/01 21:16:53 loki_val Exp $
+
+ 01 Aug 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/rtorrent-0.8.2-gcc34.patch, rtorrent-0.8.2-r3.ebuild:
+ Add patch for gcc-3.4, bug #224031. Thanks goes to Herbie Hopkins
+ <herbie@hopkins.net>. Upstream http://libtorrent.rakshasa.no/ticket/1271 .
+ Verified with Josef Drexler via IRC that this is the correct solution.
01 Aug 2008; nixnut <nixnut@gentoo.org> rtorrent-0.8.2-r3.ebuild:
Stable on ppc wrt bug 233122
diff --git a/net-p2p/rtorrent/files/rtorrent-0.8.2-gcc34.patch b/net-p2p/rtorrent/files/rtorrent-0.8.2-gcc34.patch
new file mode 100644
index 000000000000..1e761b2a6272
--- /dev/null
+++ b/net-p2p/rtorrent/files/rtorrent-0.8.2-gcc34.patch
@@ -0,0 +1,15 @@
+diff -rwud rtorrent-0.8.2/src/rpc/command.h rtorrent-0.8.2-my/src/rpc/command.h
+--- rtorrent-0.8.2/src/rpc/command.h 2008-05-07 14:19:10.000000000 +0200
++++ rtorrent-0.8.2-my/src/rpc/command.h 2008-06-09 02:23:34.000000000 +0200
+@@ -73,10 +73,8 @@
+ rt_triple(const T1& a, const T2& b, const T3& c) :
+ base_type(a, b), third(c) {}
+
+- template <typename U1, typename U2>
+- rt_triple(const std::pair<U1, U2>& b) : base_type(b), third() {}
++ rt_triple(const base_type& b) : base_type(b), third() {}
+
+- template <typename U1, typename U2, typename U3>
+ rt_triple(const rt_triple& src) :
+ base_type(src.first, src.second), third(src.third) {}
+ };
diff --git a/net-p2p/rtorrent/rtorrent-0.8.2-r3.ebuild b/net-p2p/rtorrent/rtorrent-0.8.2-r3.ebuild
index 4d6d3a76a276..74be5a816602 100644
--- a/net-p2p/rtorrent/rtorrent-0.8.2-r3.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.8.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.2-r3.ebuild,v 1.4 2008/08/01 18:42:09 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.2-r3.ebuild,v 1.5 2008/08/01 21:16:53 loki_val Exp $
inherit eutils toolchain-funcs flag-o-matic
@@ -26,6 +26,7 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-fix_start_stop_filter.patch
epatch "${FILESDIR}"/${P}-fix_conn_type_seed.patch
epatch "${FILESDIR}"/${P}-fix_load_cache.patch
+ epatch "${FILESDIR}"/${P}-gcc34.patch
}
src_compile() {