summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-23 19:02:58 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-23 19:02:58 +0000
commite88eab8c09518ac62475c266e1ecd21ab1d6d83e (patch)
treeb415ea4d3a0c9a60ba3df4bd488c0492f0de61a7 /net-p2p/qbittorrent
parentAdd app-text/hunspell DEPEND to leechcraft-azoth-9999 (diff)
downloadgentoo-2-e88eab8c09518ac62475c266e1ecd21ab1d6d83e.tar.gz
gentoo-2-e88eab8c09518ac62475c266e1ecd21ab1d6d83e.tar.bz2
gentoo-2-e88eab8c09518ac62475c266e1ecd21ab1d6d83e.zip
Version bump
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/qbittorrent')
-rw-r--r--net-p2p/qbittorrent/ChangeLog9
-rw-r--r--net-p2p/qbittorrent/qbittorrent-2.9.9.ebuild62
-rw-r--r--net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild62
3 files changed, 132 insertions, 1 deletions
diff --git a/net-p2p/qbittorrent/ChangeLog b/net-p2p/qbittorrent/ChangeLog
index 81f838993daf..42612915fd83 100644
--- a/net-p2p/qbittorrent/ChangeLog
+++ b/net-p2p/qbittorrent/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-p2p/qbittorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.187 2012/05/05 10:19:39 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/ChangeLog,v 1.188 2012/05/23 19:02:58 hwoarang Exp $
+
+*qbittorrent-3.0.0_beta2 (23 May 2012)
+*qbittorrent-2.9.9 (23 May 2012)
+
+ 23 May 2012; Markos Chandras <hwoarang@gentoo.org> +qbittorrent-2.9.9.ebuild,
+ +qbittorrent-3.0.0_beta2.ebuild:
+ Version bump
*qbittorrent-2.9.8 (05 May 2012)
diff --git a/net-p2p/qbittorrent/qbittorrent-2.9.9.ebuild b/net-p2p/qbittorrent/qbittorrent-2.9.9.ebuild
new file mode 100644
index 000000000000..8694d9f1d2c8
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-2.9.9.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-2.9.9.ebuild,v 1.1 2012/05/23 19:02:58 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +X geoip"
+
+QT_MIN="4.6.1"
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ >=x11-libs/qt-core-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}
diff --git a/net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild b/net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild
new file mode 100644
index 000000000000..4ed523975834
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qbittorrent/qbittorrent-3.0.0_beta2.ebuild,v 1.1 2012/05/23 19:02:58 hwoarang Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2"
+
+inherit python qt4-r2 versionator
+
+MY_P="${P/_/}"
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="http://www.qbittorrent.org/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus +X geoip"
+
+QT_MIN="4.6.1"
+# boost version so that we always have thread support
+CDEPEND="net-libs/rb_libtorrent
+ >=x11-libs/qt-core-${QT_MIN}:4
+ X? ( >=x11-libs/qt-gui-${QT_MIN}:4 )
+ dbus? ( >=x11-libs/qt-dbus-${QT_MIN}:4 )
+ dev-libs/boost"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+RDEPEND="${CDEPEND}
+ geoip? ( dev-libs/geoip )"
+
+DOCS="AUTHORS Changelog NEWS README TODO"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Respect LDFLAGS
+ sed -i -e 's/-Wl,--as-needed/$(LDFLAGS)/g' src/src.pro
+ qt4-r2_src_prepare
+}
+
+src_configure() {
+ local myconf
+ use X || myconf+=" --disable-gui"
+ use geoip || myconf+=" --disable-geoip-database"
+ use dbus || myconf+=" --disable-qt-dbus"
+
+ # slotted boost detection, bug #309415
+ BOOST_PKG="$(best_version ">=dev-libs/boost-1.34.1")"
+ BOOST_VER="$(get_version_component_range 1-2 "${BOOST_PKG/*boost-/}")"
+ BOOST_VER="$(replace_all_version_separators _ "${BOOST_VER}")"
+ myconf+=" --with-libboost-inc=/usr/include/boost-${BOOST_VER}"
+
+ # econf fails, since this uses qconf
+ ./configure --prefix=/usr --qtdir=/usr ${myconf} || die "configure failed"
+ eqmake4
+}