summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-25 10:26:11 +0000
commit840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8 (patch)
treeb7fb21135562109c7d3faef78deeeb62db5981c3 /net-p2p/lopster
parentnew version, compiles with gcc 3.1 (diff)
downloadgentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.tar.gz
gentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.tar.bz2
gentoo-2-840602eb5015b8b82ebb0c90ae7b9a2cc3c52cd8.zip
initial commit for net-p2p - these are all the p2p ebuilds listed in my mail. Note: they have not yet been removed from net-misc or media-sound
Diffstat (limited to 'net-p2p/lopster')
-rw-r--r--net-p2p/lopster/ChangeLog25
-rw-r--r--net-p2p/lopster/files/digest-lopster-1.0.1-r21
-rw-r--r--net-p2p/lopster/lopster-1.0.1-r2.ebuild34
3 files changed, 60 insertions, 0 deletions
diff --git a/net-p2p/lopster/ChangeLog b/net-p2p/lopster/ChangeLog
new file mode 100644
index 000000000000..63c0901fb71b
--- /dev/null
+++ b/net-p2p/lopster/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for net-p2p/lopster
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lopster/ChangeLog,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+*lopster-1.0.1-r2 (30 Apr 2002)
+
+ 30 Apr 2002; Ryan Phillips <rphillips@gentoo.org> lopster-1.0.1-r2.ebuild :
+
+ Fixed ebuild to install localization files into the correct place.
+
+*lopster-1.0.1-r1 (18 Apr 2002)
+
+ 18 Apr 2002; Ryan Phillips <rphillips@gentoo.org> lopster-1.0.1-r1.ebuild :
+
+ Copied lopster-0.9.9-r1.ebuild to newer stable version. Bug (#1717)
+
+*lopster-0.9.9-r1 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/net-p2p/lopster/files/digest-lopster-1.0.1-r2 b/net-p2p/lopster/files/digest-lopster-1.0.1-r2
new file mode 100644
index 000000000000..48523545d52a
--- /dev/null
+++ b/net-p2p/lopster/files/digest-lopster-1.0.1-r2
@@ -0,0 +1 @@
+MD5 536e31b0864e0f5af2fe50807225e797 lopster-1.0.1.tar.gz 554722
diff --git a/net-p2p/lopster/lopster-1.0.1-r2.ebuild b/net-p2p/lopster/lopster-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..66c2645e9693
--- /dev/null
+++ b/net-p2p/lopster/lopster-1.0.1-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/lopster/lopster-1.0.1-r2.ebuild,v 1.1 2002/06/25 10:26:11 bangert Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A Napster Client using GTK"
+SRC_URI="http://download.sourceforge.net/lopster/${A}"
+HOMEPAGE="http://lopster.sourceforge.net"
+
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
+ =x11-libs/gtk+-1.2*
+ virtual/x11"
+
+RDEPEND="virtual/glibc
+ =x11-libs/gtk+-1.2*
+ virtual/x11"
+
+src_compile() {
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --host=${CHOST} $myconf
+ try make
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} gnulocaledir=/usr/share/locale install
+ dodoc AUTHORS BUGS COPYING README ChangeLog NEWS
+}
+