summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-08-12 23:34:17 +0000
committerAlex Alexander <wired@gentoo.org>2009-08-12 23:34:17 +0000
commit628a6cf39cc234078d34dbdbf3f2cf5a1b696879 (patch)
treeae92ec4cf71f77965eaed060fb6d1d54731c33b9 /net-p2p/ktorrent
parentmasked ktorrent beta versions (diff)
downloadgentoo-2-628a6cf39cc234078d34dbdbf3f2cf5a1b696879.tar.gz
gentoo-2-628a6cf39cc234078d34dbdbf3f2cf5a1b696879.tar.bz2
gentoo-2-628a6cf39cc234078d34dbdbf3f2cf5a1b696879.zip
added ktorrent-3.3_beta1
(Portage version: 2.2_rc38/cvs/Linux x86_64)
Diffstat (limited to 'net-p2p/ktorrent')
-rw-r--r--net-p2p/ktorrent/ChangeLog8
-rw-r--r--net-p2p/ktorrent/ktorrent-3.3_beta1.ebuild87
-rw-r--r--net-p2p/ktorrent/metadata.xml1
3 files changed, 95 insertions, 1 deletions
diff --git a/net-p2p/ktorrent/ChangeLog b/net-p2p/ktorrent/ChangeLog
index 651627385ec8..adcfad978c24 100644
--- a/net-p2p/ktorrent/ChangeLog
+++ b/net-p2p/ktorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/ktorrent
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.126 2009/08/12 08:20:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ChangeLog,v 1.127 2009/08/12 23:34:17 wired Exp $
+
+*ktorrent-3.3_beta1 (12 Aug 2009)
+
+ 12 Aug 2009; Alex Alexander <wired@gentoo.org> +ktorrent-3.3_beta1.ebuild,
+ metadata.xml:
+ added 3.3 beta1
*ktorrent-3.2.3 (12 Aug 2009)
diff --git a/net-p2p/ktorrent/ktorrent-3.3_beta1.ebuild b/net-p2p/ktorrent/ktorrent-3.3_beta1.ebuild
new file mode 100644
index 000000000000..98185ef52adb
--- /dev/null
+++ b/net-p2p/ktorrent/ktorrent-3.3_beta1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/ktorrent/ktorrent-3.3_beta1.ebuild,v 1.1 2009/08/12 23:34:17 wired Exp $
+
+EAPI="2"
+
+if [[ ${PV} == "9999" ]] ; then
+ KEYWORDS=""
+ KMNAME="extragear/network"
+else
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ MY_P="${PN}-${MY_PV}"
+ KDE_LINGUAS="ar be bg ca cs da de el en_GB es et fr ga gl hi it ja
+ km lt lv nb nds nl nn oc pl pt pt_BR ro ru se sk sl sr sv
+ tr uk zh_CN zh_TW"
+ KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86"
+ SRC_URI="http://ktorrent.org/downloads/${MY_PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+fi
+
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent program for KDE."
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="+bwscheduler debug +downloadorder +infowidget +ipfilter +kross +logviewer
++mediaplayer plasma rss +scanfolder +search +shutdown +stats +upnp webinterface +zeroconf"
+
+COMMONDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+ mediaplayer? ( >=media-libs/taglib-1.5 )
+ plasma? ( >=kde-base/libtaskmanager-${KDE_MINIMAL} )
+ rss? (
+ dev-libs/boost
+ >=kde-base/kdepimlibs-${KDE_MINIMAL}
+ )
+"
+DEPEND="${COMMONDEPEND}
+ sys-devel/gettext
+"
+RDEPEND="${COMMONDEPEND}
+ !kdeprefix? ( !net-p2p/ktorrent:0 )
+ infowidget? ( >=dev-libs/geoip-1.4.4 )
+ ipfilter? (
+ app-arch/bzip2
+ app-arch/unzip
+ >=kde-base/kdebase-kioslaves-${KDE_MINIMAL}
+ )
+ kross? ( >=kde-base/krosspython-${KDE_MINIMAL} )
+"
+
+src_prepare() {
+ if ! use plasma; then
+ sed -i \
+ -e "s:add_subdirectory(plasma):#nada:g" \
+ CMakeLists.txt || die "Failed to make plasmoid optional"
+ fi
+
+ kde4-base_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_DHT_SUPPORT=ON
+ -DWITH_SYSTEM_GEOIP=ON
+ $(cmake-utils_use_enable bwscheduler BWSCHEDULER_PLUGIN)
+ $(cmake-utils_use_enable downloadorder DOWNLOADORDER_PLUGIN)
+ $(cmake-utils_use_enable infowidget INFOWIDGET_PLUGIN)
+ $(cmake-utils_use_with infowidget SYSTEM_GEOIP)
+ $(cmake-utils_use_enable ipfilter IPFILTER_PLUGIN)
+ $(cmake-utils_use_enable kross SCRIPTING_PLUGIN)
+ $(cmake-utils_use_enable logviewer LOGVIEWER_PLUGIN)
+ $(cmake-utils_use_enable mediaplayer MEDIAPLAYER_PLUGIN)
+ $(cmake-utils_use_enable rss SYNDICATION_PLUGIN)
+ $(cmake-utils_use_enable scanfolder SCANFOLDER_PLUGIN)
+ $(cmake-utils_use_enable search SEARCH_PLUGIN)
+ $(cmake-utils_use_enable shutdown SHUTDOWN_PLUGIN)
+ $(cmake-utils_use_enable stats STATS_PLUGIN)
+ $(cmake-utils_use_enable upnp UPNP_PLUGIN)
+ $(cmake-utils_use_enable webinterface WEBINTERFACE_PLUGIN)
+ $(cmake-utils_use_enable zeroconf ZEROCONF_PLUGIN)"
+ kde4-base_src_configure
+}
diff --git a/net-p2p/ktorrent/metadata.xml b/net-p2p/ktorrent/metadata.xml
index 02a4e7081d33..8393ba1b2b34 100644
--- a/net-p2p/ktorrent/metadata.xml
+++ b/net-p2p/ktorrent/metadata.xml
@@ -17,6 +17,7 @@
<flag name="mediaplayer">Enable the mediaplayer plugin</flag>
<flag name="scanfolder">Enable the scanfolder plugin</flag>
<flag name="search">Enable the search plugin</flag>
+ <flag name="shutdown">Shutdown when done</flag>
<flag name="stats">Enable the statistics plugin</flag>
<flag name="upnp">Enable the uphp plugin</flag>
<flag name="webinterface">Enable the webinterface plugin</flag>