summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-17 19:47:02 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-17 19:47:02 +0000
commiteb844a6f384418cbe09a03a6dd4acc7d5e8e1d50 (patch)
tree9cc15f409925a0554d90a21ca22d3772a2a69636 /net-p2p/gnunet
parentVersion bump, remove old (diff)
downloadgentoo-2-eb844a6f384418cbe09a03a6dd4acc7d5e8e1d50.tar.gz
gentoo-2-eb844a6f384418cbe09a03a6dd4acc7d5e8e1d50.tar.bz2
gentoo-2-eb844a6f384418cbe09a03a6dd4acc7d5e8e1d50.zip
Version bump wrt #199891
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'net-p2p/gnunet')
-rw-r--r--net-p2p/gnunet/ChangeLog8
-rw-r--r--net-p2p/gnunet/files/digest-gnunet-0.7.2c3
-rw-r--r--net-p2p/gnunet/files/gnunet-29
-rw-r--r--net-p2p/gnunet/gnunet-0.7.2c.ebuild114
4 files changed, 129 insertions, 5 deletions
diff --git a/net-p2p/gnunet/ChangeLog b/net-p2p/gnunet/ChangeLog
index ad2e13874d54..57a793197751 100644
--- a/net-p2p/gnunet/ChangeLog
+++ b/net-p2p/gnunet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-p2p/gnunet
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.57 2007/04/28 17:36:22 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/ChangeLog,v 1.58 2007/12/17 19:47:01 armin76 Exp $
+
+*gnunet-0.7.2c (17 Dec 2007)
+
+ 17 Dec 2007; Raúl Porcel <armin76@gentoo.org> files/gnunet-2,
+ +gnunet-0.7.2c.ebuild:
+ Version bump wrt #199891
28 Apr 2007; Sven Wegener <swegener@gentoo.org> gnunet-0.7.0e.ebuild,
gnunet-0.7.1b.ebuild:
diff --git a/net-p2p/gnunet/files/digest-gnunet-0.7.2c b/net-p2p/gnunet/files/digest-gnunet-0.7.2c
new file mode 100644
index 000000000000..7d5154c279c9
--- /dev/null
+++ b/net-p2p/gnunet/files/digest-gnunet-0.7.2c
@@ -0,0 +1,3 @@
+MD5 46bed9fee10a241963455a013a62d61c GNUnet-0.7.2c.tar.bz2 1438415
+RMD160 07de80c337fe347dc7ffaae35042eb7fb8e5c5da GNUnet-0.7.2c.tar.bz2 1438415
+SHA256 d8bca30c01f3b105b2738fae7f64b4728ca0eddbea24117a3f3d7022f77e70aa GNUnet-0.7.2c.tar.bz2 1438415
diff --git a/net-p2p/gnunet/files/gnunet-2 b/net-p2p/gnunet/files/gnunet-2
index 24b3a77afbeb..54e73a4c4d06 100644
--- a/net-p2p/gnunet/files/gnunet-2
+++ b/net-p2p/gnunet/files/gnunet-2
@@ -1,16 +1,17 @@
#!/sbin/runscript
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License, v2
-# description: Gnunet is an anonymous distributed secure network
-# this server is required to connect to the network,
-# it will open a TCP port to communicate with the
-# GUI and an UDP port to communicate with the world.
depend() {
need net
}
start() {
+ if ! test -f "/etc/gnunetd.conf"; then
+ eerror "You must create /etc/gnunetd.conf file first"
+ return 1
+ fi
+
ebegin "Starting GNUnet"
# -u username, -c path to gnunet.conf file
start-stop-daemon --start --quiet --background --exec /usr/bin/gnunetd \
diff --git a/net-p2p/gnunet/gnunet-0.7.2c.ebuild b/net-p2p/gnunet/gnunet-0.7.2c.ebuild
new file mode 100644
index 000000000000..9279bf2eeb99
--- /dev/null
+++ b/net-p2p/gnunet/gnunet-0.7.2c.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/gnunet/gnunet-0.7.2c.ebuild,v 1.1 2007/12/17 19:47:01 armin76 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils autotools
+
+S="${WORKDIR}/GNUnet-${PV}"
+DESCRIPTION="GNUnet is an anonymous, distributed, reputation based network."
+HOMEPAGE="http://gnunet.org/"
+SRC_URI="http://gnunet.org/download/GNUnet-${PV}.tar.bz2"
+#tests don't work
+RESTRICT="test"
+
+IUSE="ipv6 mysql sqlite ncurses nls gtk"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND=">=dev-libs/libgcrypt-1.2.0
+ >=media-libs/libextractor-0.5.18a
+ >=dev-libs/gmp-4.0.0
+ sys-libs/zlib
+ net-misc/curl
+ gtk? ( >=x11-libs/gtk+-2.6.10 )
+ sys-apps/sed
+ >=dev-scheme/guile-1.8.0
+ ncurses? ( sys-libs/ncurses )
+ mysql? ( >=virtual/mysql-4.0 )
+ sqlite? ( >=dev-db/sqlite-3.0.8 )
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ if ! use mysql && ! use sqlite; then
+ einfo
+ einfo "You need to specify at least one of 'mysql' or 'sqlite'"
+ einfo "USE flag in order to have properly installed gnunet"
+ einfo
+ die "Invalid USE flag set"
+ fi
+}
+
+pkg_preinst() {
+ enewgroup gnunetd || die "Problem adding gnunetd group"
+ enewuser gnunetd -1 -1 /dev/null gnunetd || die "Problem adding gnunetd user"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # make mysql default sqstore if we do not compile sql support
+ # (bug #107330)
+ ! use sqlite && \
+ sed -i 's:default "sqstore_sqlite":default "sqstore_mysql":' \
+ contrib/config-daemon.in
+
+ # we do not want to built gtk support with USE=-gtk
+ if ! use gtk ; then
+ sed -i "s:AC_DEFINE_UNQUOTED..HAVE_GTK.*:true:" configure.ac
+ fi
+
+ AT_M4DIR="${S}/m4" eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ if use ipv6; then
+ if use amd64; then
+ ewarn "ipv6 in GNUnet does not currently work with amd64 and has been disabled"
+ else
+ myconf="${myconf} --enable-ipv6"
+ fi
+ fi
+
+ use mysql || myconf="${myconf} --without-mysql"
+
+ econf \
+ $(use_with sqlite) \
+ $(use_enable nls) \
+ $(use_enable ncurses) \
+ $(use_enable guile) \
+ ${myconf} || die "econf failed"
+
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc ABOUT-NLS AUTHORS ChangeLog COPYING INSTALL NEWS PLATFORMS README README.fr UPDATING
+ insinto /etc
+ newins contrib/gnunet.root gnunet.conf
+ docinto contrib
+ dodoc contrib/*
+ newinitd ${FILESDIR}/${PN}-2 gnunet
+ dodir /var/lib/gnunet
+ chown gnunetd:gnunetd ${D}/var/lib/gnunet
+}
+
+pkg_postinst() {
+ # make sure permissions are ok
+ chown -R gnunetd:gnunetd /var/lib/gnunet
+
+ use ipv6 && ewarn "ipv6 support is -very- experimental and prone to bugs"
+ einfo
+ einfo "To configure"
+ einfo " 1) Add user(s) to the gnunetd group"
+ einfo " 2) Run 'gnunet-setup' to generate your client config file"
+ einfo " 3) Run gnunet-setup -d as root to generate a server config file"
+ einfo
+}