summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-07-10 14:09:55 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-07-10 14:09:55 +0000
commitaf2fd49c1674901e99970df7ca204a33b310bd6f (patch)
treeffc69e4f0edcee7db7fe8055f9bee34d2171348a /net-p2p/bittorrent
parentstable ppc64, bug 230956 (diff)
downloadgentoo-2-af2fd49c1674901e99970df7ca204a33b310bd6f.tar.gz
gentoo-2-af2fd49c1674901e99970df7ca204a33b310bd6f.tar.bz2
gentoo-2-af2fd49c1674901e99970df7ca204a33b310bd6f.zip
Add dev-lang/python built with threads check, bug #230921
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-p2p/bittorrent')
-rw-r--r--net-p2p/bittorrent/ChangeLog6
-rw-r--r--net-p2p/bittorrent/bittorrent-5.0.9-r1.ebuild6
-rw-r--r--net-p2p/bittorrent/bittorrent-5.2.0.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/net-p2p/bittorrent/ChangeLog b/net-p2p/bittorrent/ChangeLog
index 1ca14597025f..d71ddd577f14 100644
--- a/net-p2p/bittorrent/ChangeLog
+++ b/net-p2p/bittorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-p2p/bittorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.130 2008/03/01 19:57:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/ChangeLog,v 1.131 2008/07/10 14:09:55 armin76 Exp $
+
+ 10 Jul 2008; Raúl Porcel <armin76@gentoo.org> bittorrent-5.0.9-r1.ebuild,
+ bittorrent-5.2.0.ebuild:
+ Add dev-lang/python built with threads check, bug #230921
*bittorrent-5.2.0 (01 Mar 2008)
diff --git a/net-p2p/bittorrent/bittorrent-5.0.9-r1.ebuild b/net-p2p/bittorrent/bittorrent-5.0.9-r1.ebuild
index c88f726d23f0..e741d0e937fa 100644
--- a/net-p2p/bittorrent/bittorrent-5.0.9-r1.ebuild
+++ b/net-p2p/bittorrent/bittorrent-5.0.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.0.9-r1.ebuild,v 1.3 2008/02/29 20:28:34 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.0.9-r1.ebuild,v 1.4 2008/07/10 14:09:55 armin76 Exp $
WX_GTK_VER="2.6"
inherit distutils fdo-mime eutils wxwidgets
@@ -41,6 +41,10 @@ pkg_setup() {
die "You must build wxGTK and wxpython with unicode support"
fi
fi
+
+ if ! built_with_use dev-lang/python threads; then
+ die "${PN} needs dev-lang/python with USE=\"threads\""
+ fi
}
src_unpack() {
diff --git a/net-p2p/bittorrent/bittorrent-5.2.0.ebuild b/net-p2p/bittorrent/bittorrent-5.2.0.ebuild
index ad15104e0e4f..069c5318d536 100644
--- a/net-p2p/bittorrent/bittorrent-5.2.0.ebuild
+++ b/net-p2p/bittorrent/bittorrent-5.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.2.0.ebuild,v 1.1 2008/03/01 19:57:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittorrent/bittorrent-5.2.0.ebuild,v 1.2 2008/07/10 14:09:55 armin76 Exp $
WX_GTK_VER="2.6"
inherit distutils fdo-mime eutils wxwidgets
@@ -41,6 +41,10 @@ pkg_setup() {
die "You must build wxGTK and wxpython with unicode support"
fi
fi
+
+ if ! built_with_use dev-lang/python threads; then
+ die "${PN} needs dev-lang/python with USE=\"threads\""
+ fi
}
src_unpack() {