summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-04 19:11:55 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-04 19:11:55 +0000
commit5d8fa5222b72d279914434143cc75f4e090169e8 (patch)
treea282609463d2ab26613a0f3973de65217311c1d1 /net-p2p/bittornado
parentRevision bump to raise rb_libtorrent dependency (diff)
downloadgentoo-2-5d8fa5222b72d279914434143cc75f4e090169e8.tar.gz
gentoo-2-5d8fa5222b72d279914434143cc75f4e090169e8.tar.bz2
gentoo-2-5d8fa5222b72d279914434143cc75f4e090169e8.zip
Add patch to use wxPython-2.6, by Ryan Hill <dirtyepic at gentoo dot org>, bug #201247 and remove ancient patch
(Portage version: 2.1.3.19, RepoMan options: --force)
Diffstat (limited to 'net-p2p/bittornado')
-rw-r--r--net-p2p/bittornado/ChangeLog11
-rw-r--r--net-p2p/bittornado/bittornado-0.3.18-r1.ebuild (renamed from net-p2p/bittornado/bittornado-0.3.18.ebuild)6
-rw-r--r--net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch90
-rw-r--r--net-p2p/bittornado/files/bittornado-wxpython-pre2.5-fix.patch10
-rw-r--r--net-p2p/bittornado/files/digest-bittornado-0.3.18-r1 (renamed from net-p2p/bittornado/files/digest-bittornado-0.3.18)1
5 files changed, 103 insertions, 15 deletions
diff --git a/net-p2p/bittornado/ChangeLog b/net-p2p/bittornado/ChangeLog
index c08a90a35646..8d4e1231a93d 100644
--- a/net-p2p/bittornado/ChangeLog
+++ b/net-p2p/bittornado/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-p2p/bittornado
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.66 2007/11/21 15:54:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/ChangeLog,v 1.67 2007/12/04 19:11:55 armin76 Exp $
+
+*bittornado-0.3.18-r1 (04 Dec 2007)
+
+ 04 Dec 2007; Raúl Porcel <armin76@gentoo.org>
+ +files/bittornado-0.3.18-wxversion.patch,
+ -files/bittornado-wxpython-pre2.5-fix.patch, -bittornado-0.3.18.ebuild,
+ +bittornado-0.3.18-r1.ebuild:
+ Add patch to use wxPython-2.6, by Ryan Hill <dirtyepic at gentoo dot org>,
+ bug #201247 and remove ancient patch
21 Nov 2007; Raúl Porcel <armin76@gentoo.org> bittornado-0.3.18.ebuild:
Add missing DEPEND, bug #197089
diff --git a/net-p2p/bittornado/bittornado-0.3.18.ebuild b/net-p2p/bittornado/bittornado-0.3.18-r1.ebuild
index 374766ab4917..2da19c1d6aa1 100644
--- a/net-p2p/bittornado/bittornado-0.3.18.ebuild
+++ b/net-p2p/bittornado/bittornado-0.3.18-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.18.ebuild,v 1.13 2007/11/21 15:54:50 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/bittornado/bittornado-0.3.18-r1.ebuild,v 1.1 2007/12/04 19:11:55 armin76 Exp $
inherit distutils eutils
@@ -34,8 +34,8 @@ src_unpack() {
# fixes wrong icons path
sed -i "s:os.path.abspath(os.path.dirname(os.path.realpath(sys.argv\[0\]))):\"${PIXMAPLOC}/\":" btdownloadgui.py
- # fixes a bug with < wxpython-2.5 which is not yet available in portage
- epatch "${FILESDIR}"/${PN}-wxpython-pre2.5-fix.patch
+ # Needs wxpython-2.6 only, bug #201247
+ epatch "${FILESDIR}"/${P}-wxversion.patch
}
src_install() {
diff --git a/net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch b/net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch
new file mode 100644
index 000000000000..357396303484
--- /dev/null
+++ b/net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch
@@ -0,0 +1,90 @@
+diff -Naur BitTornado-CVS-orig/btcompletedirgui.py BitTornado-CVS/btcompletedirgui.py
+--- BitTornado-CVS-orig/btcompletedirgui.py 2006-12-23 12:20:52.000000000 -0600
++++ BitTornado-CVS/btcompletedirgui.py 2007-12-04 11:09:36.000000000 -0600
+@@ -19,12 +19,16 @@
+ import sys
+ from os import getcwd
+ from os.path import join
++
+ try:
+- from wxPython.wx import *
+-except:
+- print 'wxPython is either not installed or has not been installed properly.'
++ import wxversion
++ wxversion.select("2.6")
++except Exception, e:
++ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
+ sys.exit(1)
+
++from wxPython.wx import *
++
+ try:
+ True
+ except:
+diff -Naur BitTornado-CVS-orig/btdownloadgui.py BitTornado-CVS/btdownloadgui.py
+--- BitTornado-CVS-orig/btdownloadgui.py 2007-12-04 11:06:58.000000000 -0600
++++ BitTornado-CVS/btdownloadgui.py 2007-12-04 11:10:36.000000000 -0600
+@@ -18,10 +18,13 @@
+ assert version >= '2', "Install Python 2.0 or greater"
+
+ try:
+- from wxPython.wx import *
+-except:
+- print 'wxPython is either not installed or has not been installed properly.'
+- exit(1)
++ import wxversion
++ wxversion.select("2.6")
++except Exception, e:
++ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
++ sys.exit(1)
++
++from wxPython.wx import *
+ from BitTornado.download_bt1 import BT1Download, defaults, parse_params, get_usage, get_response
+ from BitTornado.RawServer import RawServer, UPnP_ERROR
+ from random import seed
+diff -Naur BitTornado-CVS-orig/btmaketorrentgui.py BitTornado-CVS/btmaketorrentgui.py
+--- BitTornado-CVS-orig/btmaketorrentgui.py 2006-12-23 12:20:56.000000000 -0600
++++ BitTornado-CVS/btmaketorrentgui.py 2007-12-04 11:11:30.000000000 -0600
+@@ -21,12 +21,16 @@
+ import sys
+ from os import getcwd
+ from os.path import join, isdir
++
+ try:
+- from wxPython.wx import *
+-except:
+- print 'wxPython is either not installed or has not been installed properly.'
++ import wxversion
++ wxversion.select("2.6")
++except Exception, e:
++ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
+ sys.exit(1)
+
++from wxPython.wx import *
++
+ try:
+ True
+ except:
+diff -Naur BitTornado-CVS-orig/bt-t-make.py BitTornado-CVS/bt-t-make.py
+--- BitTornado-CVS-orig/bt-t-make.py 2006-12-23 12:20:52.000000000 -0600
++++ BitTornado-CVS/bt-t-make.py 2007-12-04 11:14:35.000000000 -0600
+@@ -22,12 +22,16 @@
+ from os import getcwd, listdir
+ from os.path import join, isdir
+ from traceback import print_exc
++
+ try:
+- from wxPython.wx import *
+-except:
+- print 'wxPython is either not installed or has not been installed properly.'
++ import wxversion
++ wxversion.select("2.6")
++except Exception, e:
++ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
+ sys.exit(1)
+
++from wxPython.wx import *
++
+ try:
+ True
+ except:
diff --git a/net-p2p/bittornado/files/bittornado-wxpython-pre2.5-fix.patch b/net-p2p/bittornado/files/bittornado-wxpython-pre2.5-fix.patch
deleted file mode 100644
index 0bde2f1c3ad9..000000000000
--- a/net-p2p/bittornado/files/bittornado-wxpython-pre2.5-fix.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- btdownloadgui.py 2004-07-06 01:28:16.384832080 +0200
-+++ btdownloadgui.py 2004-07-06 01:27:43.043900672 +0200
-@@ -4,6 +4,7 @@
- # Modifications by various people
- # see LICENSE.txt for license information
-
-+wxFULL_REPAINT_ON_RESIZE = 0
- from BitTornado import PSYCO
- if PSYCO.psyco:
- try:
diff --git a/net-p2p/bittornado/files/digest-bittornado-0.3.18 b/net-p2p/bittornado/files/digest-bittornado-0.3.18-r1
index 15d579a224bb..4b62983d46e7 100644
--- a/net-p2p/bittornado/files/digest-bittornado-0.3.18
+++ b/net-p2p/bittornado/files/digest-bittornado-0.3.18-r1
@@ -1,3 +1,2 @@
-MD5 faeb137036cfaaeab91afc7f62c7dc30 BitTornado-0.3.18.tar.gz 189227
RMD160 77e61f01101c2878d4e993e0581365a71c375892 BitTornado-0.3.18.tar.gz 189227
SHA256 d9e6ad0bf5b2e9820bab809c5a4fcd94e844a57f396ac51547fe47dbe255d9e0 BitTornado-0.3.18.tar.gz 189227