summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-04-16 11:33:49 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-04-16 11:33:49 +0000
commitf2023e50c51b62bcfa32ec2a5c76ab715d6d8b01 (patch)
tree73ad80deddd7fbb0203019374109c56f5b3d5a59 /net-misc
parentrespect CFLAGS in linking command wrt #506956 (diff)
downloadgentoo-2-f2023e50c51b62bcfa32ec2a5c76ab715d6d8b01.tar.gz
gentoo-2-f2023e50c51b62bcfa32ec2a5c76ab715d6d8b01.tar.bz2
gentoo-2-f2023e50c51b62bcfa32ec2a5c76ab715d6d8b01.zip
Fix man pages installation path, thanks Ian Abbott <ian@abbott.org> in bug #507058. Also drop asciidoc dependency, sphinx is the only generator now
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/owncloud-client/ChangeLog10
-rw-r--r--net-misc/owncloud-client/files/owncloud-client-1.5.3-man-page-location-fix.patch12
-rw-r--r--net-misc/owncloud-client/owncloud-client-1.5.3-r1.ebuild65
3 files changed, 86 insertions, 1 deletions
diff --git a/net-misc/owncloud-client/ChangeLog b/net-misc/owncloud-client/ChangeLog
index bec875cc3f23..081558e9b2a4 100644
--- a/net-misc/owncloud-client/ChangeLog
+++ b/net-misc/owncloud-client/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/owncloud-client
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/owncloud-client/ChangeLog,v 1.7 2014/03/17 11:01:02 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/owncloud-client/ChangeLog,v 1.8 2014/04/16 11:33:49 voyageur Exp $
+
+*owncloud-client-1.5.3-r1 (16 Apr 2014)
+
+ 16 Apr 2014; Bernard Cafarelli <voyageur@gentoo.org>
+ +owncloud-client-1.5.3-r1.ebuild,
+ +files/owncloud-client-1.5.3-man-page-location-fix.patch:
+ Fix man pages installation path, thanks Ian Abbott <ian@abbott.org> in bug
+ #507058. Also drop asciidoc dependency, sphinx is the only generator now
17 Mar 2014; Bernard Cafarelli <voyageur@gentoo.org>
owncloud-client-1.5.1.ebuild, owncloud-client-1.5.2.ebuild,
diff --git a/net-misc/owncloud-client/files/owncloud-client-1.5.3-man-page-location-fix.patch b/net-misc/owncloud-client/files/owncloud-client-1.5.3-man-page-location-fix.patch
new file mode 100644
index 000000000000..297e579c67b3
--- /dev/null
+++ b/net-misc/owncloud-client/files/owncloud-client-1.5.3-man-page-location-fix.patch
@@ -0,0 +1,12 @@
+diff -ur mirall-1.5.3/doc/CMakeLists.txt mirall-1.5.3-new/doc/CMakeLists.txt
+--- mirall-1.5.3/doc/CMakeLists.txt 2014-03-10 11:22:06.000000000 +0000
++++ mirall-1.5.3-new/doc/CMakeLists.txt 2014-04-07 19:17:56.000000000 +0100
+@@ -4,7 +4,7 @@
+ set(SPHINX_CACHE_DIR "${CMAKE_CURRENT_BINARY_DIR}/_doctrees")
+ # HTML output directory
+ set(SPHINX_HTML_DIR "${CMAKE_CURRENT_BINARY_DIR}/html")
+- set(SPHINX_MAN_DIR "${CMAKE_CURRENT_BINARY_DIR}/man")
++ set(SPHINX_MAN_DIR "${CMAKE_CURRENT_BINARY_DIR}/man1")
+ set(SPHINX_PDF_DIR "${CMAKE_CURRENT_BINARY_DIR}/latex")
+ set(SPHINX_QCH_DIR "${CMAKE_CURRENT_BINARY_DIR}/qthelp")
+ set(SPHINX_HTMLHELP_DIR "${CMAKE_CURRENT_BINARY_DIR}/htmlhelp")
diff --git a/net-misc/owncloud-client/owncloud-client-1.5.3-r1.ebuild b/net-misc/owncloud-client/owncloud-client-1.5.3-r1.ebuild
new file mode 100644
index 000000000000..b7ef42134b3d
--- /dev/null
+++ b/net-misc/owncloud-client/owncloud-client-1.5.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/owncloud-client/owncloud-client-1.5.3-r1.ebuild,v 1.1 2014/04/16 11:33:49 voyageur Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+MY_P="mirall-${PV/_/}"
+
+DESCRIPTION="Synchronize files from ownCloud Server with your computer"
+HOMEPAGE="http://owncloud.org/"
+SRC_URI="http://download.owncloud.com/desktop/stable/${MY_P}.tar.bz2"
+
+LICENSE="CC-BY-3.0 GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc samba +sftp test"
+
+RDEPEND=">=dev-db/sqlite-3.4:3
+ dev-libs/qtkeychain
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsql:4
+ dev-qt/qttest:4
+ dev-qt/qtwebkit:4
+ net-libs/neon[ssl]
+ sys-fs/inotify-tools
+ virtual/libiconv
+ samba? ( >=net-fs/samba-3.5 )
+ sftp? ( >=net-libs/libssh-0.5 )
+ !net-misc/ocsync"
+DEPEND="${RDEPEND}
+ doc? (
+ dev-python/sphinx
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )
+ test? ( dev-util/cmocka )"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${P}-man-page-location-fix.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ -DCMAKE_INSTALL_DOCDIR=/usr/share/doc/${PF}
+ -DWITH_ICONV=ON
+ $(cmake-utils_use_with doc DOC)
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_find_package samba Libsmbclient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ # 1 test needs an existing ${HOME}/.config directory
+ mkdir "${T}"/.config
+ export HOME="${T}"
+ cmake-utils_src_test
+}