summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2004-05-01 03:27:51 +0000
committerNed Ludd <solar@gentoo.org>2004-05-01 03:27:51 +0000
commitbf4154e849a9f7d310da838d0b21fc406996c91f (patch)
treeb644cc2cb4449b01fd0bdc39c0fb4c0839a41b9c /net-misc
parentchop out emacs (diff)
downloadgentoo-2-bf4154e849a9f7d310da838d0b21fc406996c91f.tar.gz
gentoo-2-bf4154e849a9f7d310da838d0b21fc406996c91f.tar.bz2
gentoo-2-bf4154e849a9f7d310da838d0b21fc406996c91f.zip
version bump for security update CAN-2004-0426, bug 49534 this version also seems to have the proxy-auth patch merged upstream, USE=acl disabled for now due to patching conflicts
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/rsync/ChangeLog9
-rw-r--r--net-misc/rsync/Manifest6
-rw-r--r--net-misc/rsync/files/digest-rsync-2.6.21
-rw-r--r--net-misc/rsync/rsync-2.6.2.ebuild73
4 files changed, 86 insertions, 3 deletions
diff --git a/net-misc/rsync/ChangeLog b/net-misc/rsync/ChangeLog
index 48b401acdf40..7f766e8b7b9a 100644
--- a/net-misc/rsync/ChangeLog
+++ b/net-misc/rsync/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/rsync
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.40 2004/04/27 14:04:41 randy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/ChangeLog,v 1.41 2004/05/01 03:27:51 solar Exp $
+
+*rsync-2.6.2 (30 Apr 2004)
+
+ 30 Apr 2004; <solar@gentoo.org> rsync-2.6.2.ebuild:
+ version bump for security update CAN-2004-0426, bug 49534 this version also
+ seems to have the proxy-auth patch merged upstream, USE=acl disabled for now
+ due to patching conflicts
27 Apr 2004; Michael McCabe <randy@gentoo.org> rsync-2.6.0-r1.ebuild:
Marked stable on s390
diff --git a/net-misc/rsync/Manifest b/net-misc/rsync/Manifest
index fc0680371390..910cf986181e 100644
--- a/net-misc/rsync/Manifest
+++ b/net-misc/rsync/Manifest
@@ -1,8 +1,10 @@
-MD5 2895d2d254ed560ef66cfc9ccc55a440 ChangeLog 5712
+MD5 ca539ff2aaf6c661a2b827987ee34c75 ChangeLog 5980
MD5 2b4231199efd5dc8f43008d49ab84680 rsync-2.6.0.ebuild 2262
MD5 19e16a3ea8316221168e159b407dc53b rsync-2.6.0-r1.ebuild 2430
+MD5 9e709947cf82df8567dff86913da57b2 rsync-2.6.2.ebuild 2336
MD5 2b5cd2c75632c28fb6d8a311e8548fa9 files/digest-rsync-2.6.0 136
+MD5 e04533ca371c57d742250cc0622c005e files/digest-rsync-2.6.0-r1 204
MD5 20418c507f2e4a8ab2dae4acb26053ec files/rsyncd.conf 188
MD5 38f45eaed761df27cfa731ce65763e98 files/rsyncd.conf.d 355
MD5 b87d68fcfff9eb9ae5cdbea3796693c5 files/rsyncd.init.d 423
-MD5 e04533ca371c57d742250cc0622c005e files/digest-rsync-2.6.0-r1 204
+MD5 d12329ba4505253f35b46e3446aaaebc files/digest-rsync-2.6.2 63
diff --git a/net-misc/rsync/files/digest-rsync-2.6.2 b/net-misc/rsync/files/digest-rsync-2.6.2
new file mode 100644
index 000000000000..317f5a74ef7a
--- /dev/null
+++ b/net-misc/rsync/files/digest-rsync-2.6.2
@@ -0,0 +1 @@
+MD5 bcacd9a9108a9e4760832212ec3d658d rsync-2.6.2.tar.gz 515402
diff --git a/net-misc/rsync/rsync-2.6.2.ebuild b/net-misc/rsync/rsync-2.6.2.ebuild
new file mode 100644
index 000000000000..81f2641006a3
--- /dev/null
+++ b/net-misc/rsync/rsync-2.6.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/rsync/rsync-2.6.2.ebuild,v 1.1 2004/05/01 03:27:51 solar Exp $
+
+inherit eutils flag-o-matic gcc
+
+DESCRIPTION="File transfer program to keep remote files into sync"
+HOMEPAGE="http://rsync.samba.org/"
+SRC_URI="http://rsync.samba.org/ftp/rsync/${P}.tar.gz"
+# ACL patches need to be forward ported again.
+# acl? ( http://www.saout.de/misc/${PN}-2.6.0-acl.diff.bz2 )"
+# http://www.imada.sdu.dk/~bardur/personal/patches/${PN}-proxy-auth/${PN}-2.5.6-proxy-auth-1.patch
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha ~hppa ~amd64 ~ia64 ~ppc64 ~s390"
+# IUSE="build static acl"
+IUSE="build static"
+
+RDEPEND="virtual/glibc
+ !build? ( >=dev-libs/popt-1.5 )"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ acl? ( sys-apps/acl )"
+
+src_unpack() {
+ unpack "${P}.tar.gz"
+ cd ${S}
+ # proxy patch seems to be merged in now 2.6.2
+ # epatch "${DISTDIR}/${PN}-2.5.6-proxy-auth-1.patch"
+ #use acl && epatch ${DISTDIR}/${PN}-2.6.0-acl.diff.bz2
+
+ # change confdir to /etc/rsync rather than just /etc (the --sysconfdir
+ # configure option doesn't work
+ sed -i \
+ -e 's|/etc/rsyncd.conf|/etc/rsync/rsyncd.conf|g' rsync.h \
+ || die "sed rsync.h failed"
+ # yes, updating the man page is very important.
+ sed -i \
+ -e 's|/etc/rsyncd|/etc/rsync/rsyncd|g' rsyncd.conf.5 \
+ || die "sed rsyncd.conf.5 failed"
+}
+
+src_compile() {
+ [ "`gcc-version`" == "2.95" ] && append-ldflags -lpthread
+ use static && append-ldflags -static
+ export LDFLAGS
+ econf $(use_with build included-popt) \
+ $(use_with acl acl-support) || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ insinto /etc/conf.d && newins "${FILESDIR}/rsyncd.conf.d" rsyncd
+ exeinto /etc/init.d && newexe "${FILESDIR}/rsyncd.init.d" rsyncd
+ if ! use build ; then
+ dodir /etc/rsync
+ dodoc NEWS OLDNEWS README TODO tech_report.tex
+ if [ ! -e /etc/rsync/rsyncd.conf ] ; then
+ insinto /etc/rsync
+ doins "${FILESDIR}/rsyncd.conf"
+ fi
+ else
+ rm -rf "${D}/usr/share"
+ fi
+}
+
+pkg_postinst() {
+ ewarn "Please make sure you do NOT disable the rsync server running"
+ ewarn "in a chroot. Please check /etc/rsync/rsyncd.conf and make sure"
+ ewarn "it says: use chroot = yes"
+}