summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-08-06 21:24:01 +0000
committerAchim Gottinger <achim@gentoo.org>2001-08-06 21:24:01 +0000
commit9e972a5776ec8462f8077719dd72ebbf31436c77 (patch)
treecab5fc101539fe8670efc605de5fedc2373ac8da /net-misc
parentadded miscfiles. this contains stuff like /usr/share/dict/words, other (diff)
downloadgentoo-2-9e972a5776ec8462f8077719dd72ebbf31436c77.tar.gz
gentoo-2-9e972a5776ec8462f8077719dd72ebbf31436c77.tar.bz2
gentoo-2-9e972a5776ec8462f8077719dd72ebbf31436c77.zip
*** empty log message ***
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/fwbuilder/fwbuilder-0.9.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-misc/fwbuilder/fwbuilder-0.9.5.ebuild b/net-misc/fwbuilder/fwbuilder-0.9.5.ebuild
new file mode 100644
index 000000000000..7a33a6067758
--- /dev/null
+++ b/net-misc/fwbuilder/fwbuilder-0.9.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Your Name <your email>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fwbuilder/fwbuilder-0.9.5.ebuild,v 1.1 2001/08/06 21:24:01 achim Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A firewall GUI"
+SRC_URI="http://prdownloads.sourceforge.net/fwbuilder/$A"
+HOMEPAGE="http://fwbuilder.sourceforge.net"
+
+DEPEND=">=x11-libs/gtkmm-1.2.3
+ >=gnome-libs/libxslt-1.0.1
+ gnome-base/gnome-core"
+
+src_compile() {
+
+ try ./configure --prefix=/opt/gnome --host=${CHOST}
+ cp config.h config.h.orig
+ sed -e "s:#define HAVE_XMLSAVEFORMATFILE 1://:" config.h.orig > config.h
+ if [ "`use static`" ] ; then
+ try make LDFLAGS="-static"
+ else
+ try make
+ fi
+
+}
+
+src_install () {
+
+ try make DESTDIR=${D} install
+
+}
+