summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-02-03 12:22:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-02-03 12:22:57 +0000
commit8891612e3e37b575c6837128d8f5b6a1d8d589f7 (patch)
tree8b7702181a7b4df400b812a19e18da2847a675c8 /net-misc
parentUnmask Qt5. (diff)
downloadgentoo-2-8891612e3e37b575c6837128d8f5b6a1d8d589f7.tar.gz
gentoo-2-8891612e3e37b575c6837128d8f5b6a1d8d589f7.tar.bz2
gentoo-2-8891612e3e37b575c6837128d8f5b6a1d8d589f7.zip
Version bump
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/cgminer/ChangeLog9
-rw-r--r--net-misc/cgminer/cgminer-4.9.1.ebuild102
2 files changed, 109 insertions, 2 deletions
diff --git a/net-misc/cgminer/ChangeLog b/net-misc/cgminer/ChangeLog
index cfe83c95719e..96141134dcbc 100644
--- a/net-misc/cgminer/ChangeLog
+++ b/net-misc/cgminer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/cgminer
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.85 2014/12/16 17:43:02 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/ChangeLog,v 1.86 2015/02/03 12:22:57 blueness Exp $
+
+*cgminer-4.9.1 (03 Feb 2015)
+
+ 03 Feb 2015; Anthony G. Basile <blueness@gentoo.org> +cgminer-4.9.1.ebuild:
+ Version bump
16 Dec 2014; Anthony G. Basile <blueness@gentoo.org> cgminer-4.9.0.ebuild,
metadata.xml:
diff --git a/net-misc/cgminer/cgminer-4.9.1.ebuild b/net-misc/cgminer/cgminer-4.9.1.ebuild
new file mode 100644
index 000000000000..151cccc8fb77
--- /dev/null
+++ b/net-misc/cgminer/cgminer-4.9.1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/cgminer/cgminer-4.9.1.ebuild,v 1.1 2015/02/03 12:22:57 blueness Exp $
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Bitcoin CPU/GPU/FPGA/ASIC miner in C"
+HOMEPAGE="http://bitcointalk.org/?topic=28402.msg357369 http://github.com/ckolivas/cgminer"
+SRC_URI="http://ck.kolivas.org/apps/cgminer/${P}.tar.bz2"
+#SRC_URI="http://ck.kolivas.org/apps/cgminer/4.5/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+HARDWARE="ants1 ants2 avalon avalon2 avalon4 bab bitmine_A1 bflsc bitforce bitfury blockerupter cointerra drillbit hashfast hashratio icarus klondike knc minion modminer spondoolies"
+IUSE="doc examples udev hardened ncurses ${HARDWARE}"
+
+REQUIRED_USE="|| ( ${HARDWARE} )"
+
+RDEPEND="net-misc/curl
+ >=dev-libs/jansson-2.6
+ ncurses? ( sys-libs/ncurses )
+ ants1? ( virtual/libusb:1[udev] )
+ ants2? ( virtual/libusb:1[udev] )
+ avalon? ( virtual/libusb:1[udev] )
+ avalon2? ( virtual/libusb:1[udev] )
+ avalon4? ( virtual/libusb:1[udev] )
+ bflsc? ( virtual/libusb:1[udev] )
+ bitforce? ( virtual/libusb:1[udev] )
+ bitfury? ( virtual/libusb:1[udev] )
+ blockerupter? ( virtual/libusb:1[udev] )
+ cointerra? ( virtual/libusb:1[udev] )
+ drillbit? ( virtual/libusb:1[udev] )
+ hashfast? ( virtual/libusb:1[udev] )
+ hashratio? ( virtual/libusb:1[udev] )
+ icarus? ( virtual/libusb:1[udev] )
+ klondike? ( virtual/libusb:1[udev] )
+ modminer? ( virtual/libusb:1[udev] )
+ spondoolies? ( virtual/libusb:1[udev] )
+ udev? ( virtual/libudev )"
+DEPEND="virtual/pkgconfig
+ ${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.4.2-system-jansson.patch
+ eautoreconf
+}
+
+src_configure() {
+ use hardened && append-cflags "-nopie"
+
+ econf $(use_with ncurses curses) \
+ $(use_enable ants1) \
+ $(use_enable ants2) \
+ $(use_enable avalon) \
+ $(use_enable avalon2) \
+ $(use_enable avalon4) \
+ $(use_enable bab) \
+ $(use_enable bitmine_A1) \
+ $(use_enable bflsc) \
+ $(use_enable bitforce) \
+ $(use_enable bitfury) \
+ $(use_enable blockerupter) \
+ $(use_enable cointerra) \
+ $(use_enable drillbit) \
+ $(use_enable hashfast) \
+ $(use_enable hashratio) \
+ $(use_enable icarus) \
+ $(use_enable klondike) \
+ $(use_enable knc) \
+ $(use_enable minion) \
+ $(use_enable modminer) \
+ $(use_enable spondoolies) \
+ $(use_enable udev) \
+ --disable-forcecombo \
+ --with-system-libusb
+ # sanitize directories (is this still needed?)
+ sed -i 's~^\(\#define CGMINER_PREFIX \).*$~\1"'"${EPREFIX}/usr/lib/cgminer"'"~' config.h
+}
+
+src_install() { # How about using some make install?
+ dobin cgminer
+
+ if use udev; then
+ insinto /lib/udev/rules.d
+ use udev && doins 01-cgminer.rules
+ fi
+
+ if use doc; then
+ dodoc AUTHORS NEWS README API-README
+ use icarus || use bitforce || use modminer && dodoc FPGA-README
+ use avalon || use bflsc && dodoc ASIC-README
+ fi
+
+ if use examples; then
+ docinto examples
+ dodoc api-example.php miner.php API.java api-example.c example.conf
+ fi
+}