summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-06-28 22:16:20 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-06-28 22:16:20 +0000
commit8192d90bf23c44536f7d8ea016ec142230e31a48 (patch)
treefa9a2baba6f7f206c668abcc35613c7c10eb2afc /net-misc
parent*** empty log message *** (diff)
downloadgentoo-2-8192d90bf23c44536f7d8ea016ec142230e31a48.tar.gz
gentoo-2-8192d90bf23c44536f7d8ea016ec142230e31a48.tar.bz2
gentoo-2-8192d90bf23c44536f7d8ea016ec142230e31a48.zip
Closes 23213
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/stunnel/files/digest-stunnel-3.241
-rw-r--r--net-misc/stunnel/files/stunnel-3.24-gentoo.diff29
-rw-r--r--net-misc/stunnel/stunnel-3.24.ebuild35
3 files changed, 65 insertions, 0 deletions
diff --git a/net-misc/stunnel/files/digest-stunnel-3.24 b/net-misc/stunnel/files/digest-stunnel-3.24
new file mode 100644
index 000000000000..75c759407ba2
--- /dev/null
+++ b/net-misc/stunnel/files/digest-stunnel-3.24
@@ -0,0 +1 @@
+MD5 c14bc43985ab2f8298b30e72dd9fde9e stunnel-3.24.tar.gz 225353
diff --git a/net-misc/stunnel/files/stunnel-3.24-gentoo.diff b/net-misc/stunnel/files/stunnel-3.24-gentoo.diff
new file mode 100644
index 000000000000..a6d0faa66f80
--- /dev/null
+++ b/net-misc/stunnel/files/stunnel-3.24-gentoo.diff
@@ -0,0 +1,29 @@
+--- Makefile.in Sun Dec 23 12:03:25 2001
++++ Makefile.in Thu Jan 17 12:28:22 2002
+@@ -9,7 +9,7 @@
+ sbindir=@sbindir@
+ libdir=@libdir@
+ man8dir=@mandir@/man8
+-piddir=@localstatedir@/stunnel/
++piddir=/var/run
+ ssldir=@ssldir@
+ openssl=$(ssldir)/bin/openssl
+ PEM_DIR=@PEM_DIR@
+@@ -24,7 +24,7 @@
+ LIBS=@LIBS@
+ HEADERS=common.h prototypes.h client.h
+ OBJS=client.o stunnel.o ssl.o protocol.o sthreads.o pty.o log.o options.o
+-DESTFILES=$(sbindir)/stunnel $(libdir)/stunnel.so $(man8dir)/stunnel.8 $(PEM_DIR)/stunnel.pem
++DESTFILES=$(sbindir)/stunnel $(libdir)/stunnel.so $(man8dir)/stunnel.8
+
+ WINGCC=i386-mingw32msvc-gcc
+ WINCFLAGS=-O2 -Wall -DUSE_WIN32=1 -DHAVE_OPENSSL=1 -DFD_SETSIZE=4096 -DVERSION=\"@VERSION@\" -I../openssl-0.9.6b/outinc
+@@ -33,7 +33,7 @@
+
+ # standard external rules
+
+-all: stunnel stunnel.8 stunnel.html stunnel.so stunnel.pem
++all: stunnel stunnel.8 stunnel.html stunnel.so
+
+ install: all installdirs $(DESTFILES)
+
diff --git a/net-misc/stunnel/stunnel-3.24.ebuild b/net-misc/stunnel/stunnel-3.24.ebuild
new file mode 100644
index 000000000000..66d20b1d75dd
--- /dev/null
+++ b/net-misc/stunnel/stunnel-3.24.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-3.24.ebuild,v 1.1 2003/06/28 22:16:20 aliz Exp $
+
+inherit eutils
+
+S=${WORKDIR}/${P}
+DESCRIPTION="TLS/SSL - Port Wrapper"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+HOMEPAGE="http://www.stunnel.org/"
+DEPEND="virtual/glibc >=dev-libs/openssl-0.9.6c"
+RDEPEND=">=dev-libs/openssl-0.9.6c"
+KEYWORDS="~x86 ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.diff
+ epatch ${FILESDIR}/${P}-blinding.fix
+}
+
+src_compile() {
+ econf || die
+# ./configu --prefix=/usr --infodir=/usr/share/info --mandir=/usr/share/man || die
+ emake || die
+}
+
+src_install() {
+ into /usr
+ dosbin stunnel
+ dodoc FAQ README HISTORY COPYING BUGS PORTS TODO transproxy.txt
+ doman stunnel.8
+ dolib.so stunnel.so
+}