summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-10-07 13:48:17 +0000
committerAchim Gottinger <achim@gentoo.org>2001-10-07 13:48:17 +0000
commit7c0ac2f2c853770ff378f7d3e52f9039c9061800 (patch)
tree31644062ffe986fe49d3204ec8bfc6ecfbf555b2 /net-misc
parentupdated to new locatioN (diff)
downloadgentoo-2-7c0ac2f2c853770ff378f7d3e52f9039c9061800.tar.gz
gentoo-2-7c0ac2f2c853770ff378f7d3e52f9039c9061800.tar.bz2
gentoo-2-7c0ac2f2c853770ff378f7d3e52f9039c9061800.zip
A small mnan page fix and a new version
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/whois/files/digest-whois-4.5.81
-rw-r--r--net-misc/whois/whois-4.5.8.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/net-misc/whois/files/digest-whois-4.5.8 b/net-misc/whois/files/digest-whois-4.5.8
new file mode 100644
index 000000000000..efbbf0037b2f
--- /dev/null
+++ b/net-misc/whois/files/digest-whois-4.5.8
@@ -0,0 +1 @@
+MD5 ff7efdc3dc51a2a409b0d16180bc54ab whois_4.5.8.tar.gz
diff --git a/net-misc/whois/whois-4.5.8.ebuild b/net-misc/whois/whois-4.5.8.ebuild
new file mode 100644
index 000000000000..67235b5bee06
--- /dev/null
+++ b/net-misc/whois/whois-4.5.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/net-misc/whois/whois-4.5.8.ebuild,v 1.1 2001/10/07 13:48:17 achim Exp $
+
+A=whois_${PV}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="Whois Client"
+SRC_URI="ftp://ftp.debian.org/debian/pool/main/w/whois/${A}"
+
+DEPEND="virtual/glibc >=sys-devel/perl-5"
+RDEPEND="virtual/glibc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s/-O2/$CFLAGS/" -e "s:/man/man1/:/share/man/man1/:" Makefile.orig > Makefile
+ cd po
+ cp Makefile Makefile.orig
+ sed -e "s:/usr/bin/install:/bin/install:" Makefile.orig > Makefile
+
+}
+src_compile() {
+
+ try make
+ try make mkpasswd
+}
+
+src_install() {
+
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodir /usr/share/locale
+ try make BASEDIR=${D} prefix=/usr mandir=/usr/share/man install
+ dobin mkpasswd
+ doman mkpasswd.1
+ dodoc README TODO debian/changelog debian/copyright
+
+}
+
+
+
+