summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Schweizer <genstef@gentoo.org>2006-11-05 16:39:06 +0000
committerStefan Schweizer <genstef@gentoo.org>2006-11-05 16:39:06 +0000
commit4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef (patch)
tree4ac5d286cfa40077678821c9d3cc5c64aa35a406 /net-misc
parentFixed build error with gcc-4 and modular X dependencies. Thanks to Gilles Dar... (diff)
downloadgentoo-2-4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef.tar.gz
gentoo-2-4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef.tar.bz2
gentoo-2-4cdb6dcbb1fa57d6fa51ad32c5e575fa986d83ef.zip
Version bump thanks to masterdriverz, closes bug 126828 and bug 128899
(Portage version: 2.1.2_rc1-r3)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/wput/ChangeLog12
-rw-r--r--net-misc/wput/files/digest-wput-0.63
-rw-r--r--net-misc/wput/files/wput-0.6-gentoo.diff57
-rw-r--r--net-misc/wput/files/wput-0.6-respectldflags.patch13
-rw-r--r--net-misc/wput/metadata.xml8
-rw-r--r--net-misc/wput/wput-0.6.ebuild36
6 files changed, 125 insertions, 4 deletions
diff --git a/net-misc/wput/ChangeLog b/net-misc/wput/ChangeLog
index bc68059b4715..efef604f6e38 100644
--- a/net-misc/wput/ChangeLog
+++ b/net-misc/wput/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/wput
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/ChangeLog,v 1.11 2005/04/18 17:25:10 ka0ttic Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/ChangeLog,v 1.12 2006/11/05 16:39:06 genstef Exp $
+
+*wput-0.6 (05 Nov 2006)
+
+ 05 Nov 2006; Stefan Schweizer <genstef@gentoo.org>
+ +files/wput-0.6-gentoo.diff, +files/wput-0.6-respectldflags.patch,
+ -files/wput-0.6_pre-gentoo.diff, metadata.xml, -wput-0.4.ebuild,
+ -wput-0.6_pre.ebuild, +wput-0.6.ebuild:
+ Version bump thanks to masterdriverz, closes bug 126828 and bug 128899
*wput-0.6_pre (18 Apr 2005)
diff --git a/net-misc/wput/files/digest-wput-0.6 b/net-misc/wput/files/digest-wput-0.6
new file mode 100644
index 000000000000..547485783315
--- /dev/null
+++ b/net-misc/wput/files/digest-wput-0.6
@@ -0,0 +1,3 @@
+MD5 7ddb03154262df66e0e33f0676373ceb wput-0.6.tgz 252823
+RMD160 ebe32dd745b0d713102980268acce65aa8f41d51 wput-0.6.tgz 252823
+SHA256 98548282c031433be3222fbdadded7c1ad780137dda9bb00314ebbf5958cd4b5 wput-0.6.tgz 252823
diff --git a/net-misc/wput/files/wput-0.6-gentoo.diff b/net-misc/wput/files/wput-0.6-gentoo.diff
new file mode 100644
index 000000000000..4ca604602c13
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6-gentoo.diff
@@ -0,0 +1,57 @@
+diff --exclude='*~' -urN wput.orig/Makefile.in wput/Makefile.in
+--- wput.orig/Makefile.in 2005-04-18 13:14:14.000000000 -0400
++++ wput/Makefile.in 2005-04-18 13:17:46.000000000 -0400
+@@ -15,10 +15,10 @@
+
+ install: all
+ cd po && $(MAKE) $(MAKEDEFS) $@
+- install -d $(bindir) wput
+- install -m0755 wput $(bindir)
+- install -d $(mandir) doc/wput.1.gz
+- install -m0644 doc/wput.1.gz $(mandir)
++ install -d $(DESTDIR)$(bindir)
++ install -m0755 wput $(DESTDIR)$(bindir)
++ install -d $(DESTDIR)$(mandir)
++ install -m0644 doc/wput.1.gz $(DESTDIR)$(mandir)
+ @echo "----------------"
+ @echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
+ @echo "Further documentation is located in the doc/USAGE.* files."
+Files wput.orig/.Makefile.in.swo and wput/.Makefile.in.swo differ
+diff --exclude='*~' -urN wput.orig/src/ftp.c wput/src/ftp.c
+--- wput.orig/src/ftp.c 2005-04-18 13:14:14.000000000 -0400
++++ wput/src/ftp.c 2005-04-18 13:19:01.000000000 -0400
+@@ -88,7 +88,7 @@
+ * path and change there again */
+ /* error-levels: ERR_RECONNECT, ERR_FAILED, ERR_SKIP (failed for '/'), 1 */
+ int try_do_cwd(ftp_con * ftp, char * path, int mkd) {
+- int res;
++ int res = -1;
+ if(!strcmp(path, "."))
+ return mkd;
+ if(!strcmp(path, ".."))
+@@ -201,7 +201,7 @@
+ }
+
+ int open_input_file(_fsession * fsession) {
+- int fd;
++ int fd = -1;
+ int oflags = O_RDONLY;
+ char * cmd;
+ FILE * pipe;
+Files wput.orig/src/.ftp.c.swp and wput/src/.ftp.c.swp differ
+diff --exclude='*~' -urN wput.orig/src/ftp-ls.c wput/src/ftp-ls.c
+--- wput.orig/src/ftp-ls.c 2005-04-18 13:14:14.000000000 -0400
++++ wput/src/ftp-ls.c 2005-04-18 13:20:30.000000000 -0400
+@@ -42,6 +42,11 @@
+ #include <sys/types.h>
+ #include <errno.h>
+
++#ifndef _XOPEN_SOURCE
++# define _XOPEN_SOURCE
++#endif
++#include <time.h>
++
+ #include "wget.h"
+ #include "utils.h"
+ #include "ftp.h"
+Files wput.orig/src/.ftp-ls.c.swp and wput/src/.ftp-ls.c.swp differ
diff --git a/net-misc/wput/files/wput-0.6-respectldflags.patch b/net-misc/wput/files/wput-0.6-respectldflags.patch
new file mode 100644
index 000000000000..d2b460b339b3
--- /dev/null
+++ b/net-misc/wput/files/wput-0.6-respectldflags.patch
@@ -0,0 +1,13 @@
+Index: wput/src/Makefile.in
+===================================================================
+--- wput.orig/src/Makefile.in
++++ wput/src/Makefile.in
+@@ -23,7 +23,7 @@ ftplib.o: socketlib.h ftplib.h
+ ftp-ls.o: ftp.h wget.h url.h
+
+ wput: $(OBJ)
+- $(CC) -o $(EXE) $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) -o $(EXE) $(OBJ) $(LIBS)
+ clean:
+ rm -f *.o *~ *.bak ../wput getopt/*.o
+ win-clean: clean
diff --git a/net-misc/wput/metadata.xml b/net-misc/wput/metadata.xml
index 6ba82d66be8b..caa2788bfded 100644
--- a/net-misc/wput/metadata.xml
+++ b/net-misc/wput/metadata.xml
@@ -3,7 +3,11 @@
<pkgmetadata>
<herd>no-herd</herd>
<maintainer>
- <email>ka0ttic@gentoo.org</email>
- <name>Aaron Walker</name>
+ <email>masterdriverz@gmail.com</email>
+ <name>Charlie Shepherd</name>
+</maintainer>
+<maintainer>
+ <email>genstef@gentoo.org</email>
+ <name>Stefan Schweizer</name>
</maintainer>
</pkgmetadata>
diff --git a/net-misc/wput/wput-0.6.ebuild b/net-misc/wput/wput-0.6.ebuild
new file mode 100644
index 000000000000..7fd0aaa34e35
--- /dev/null
+++ b/net-misc/wput/wput-0.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/wput-0.6.ebuild,v 1.1 2006/11/05 16:39:06 genstef Exp $
+
+inherit eutils
+
+DESCRIPTION="A tiny program that looks like wget and is designed to upload files or whole directories to remote ftp-servers"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~amd64"
+IUSE="debug"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gentoo.diff"
+ # Fix bug 126828
+ epatch "${FILESDIR}/wput-0.6-respectldflags.patch"
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-memdbg=yes" || myconf="--enable-g-switch=no"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog INSTALL TODO
+}