summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-03-26 12:40:17 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-03-26 12:40:17 +0000
commit2e33140fb885fbb12b63df970331cf8b2641ea9f (patch)
tree9c2faccfe231a0e9a2448ce19e631a6c92ab5bd5 /net-misc
parentCups-1.5 compatibility patch backported from scribus-1.4, #409719 (diff)
downloadgentoo-2-2e33140fb885fbb12b63df970331cf8b2641ea9f.tar.gz
gentoo-2-2e33140fb885fbb12b63df970331cf8b2641ea9f.tar.bz2
gentoo-2-2e33140fb885fbb12b63df970331cf8b2641ea9f.zip
Force disable tunemu, fix bug #409749
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tinc/ChangeLog6
-rw-r--r--net-misc/tinc/files/fix-ac-arg-enable.patch34
-rw-r--r--net-misc/tinc/tinc-1.0.18.ebuild13
3 files changed, 31 insertions, 22 deletions
diff --git a/net-misc/tinc/ChangeLog b/net-misc/tinc/ChangeLog
index cf594b30e807..f35c20ea5128 100644
--- a/net-misc/tinc/ChangeLog
+++ b/net-misc/tinc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/tinc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.32 2012/03/26 01:44:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/ChangeLog,v 1.33 2012/03/26 12:40:17 blueness Exp $
+
+ 26 Mar 2012; Anthony G. Basile <blueness@gentoo.org> tinc-1.0.18.ebuild,
+ files/fix-ac-arg-enable.patch:
+ Force disable tunemu, fix bug #409749
*tinc-1.0.18 (26 Mar 2012)
diff --git a/net-misc/tinc/files/fix-ac-arg-enable.patch b/net-misc/tinc/files/fix-ac-arg-enable.patch
index fef695211551..ce693a2bb06c 100644
--- a/net-misc/tinc/files/fix-ac-arg-enable.patch
+++ b/net-misc/tinc/files/fix-ac-arg-enable.patch
@@ -1,28 +1,32 @@
-diff -Naur tinc-1.0.18.orig//configure.in tinc-1.0.18/configure.in
---- tinc-1.0.18.orig//configure.in 2012-03-25 09:46:02.000000000 -0400
-+++ tinc-1.0.18/configure.in 2012-03-25 21:24:55.000000000 -0400
-@@ -74,29 +74,43 @@
+diff --git a/configure.in b/configure.in
+index 2ea69f6..7eaeca6 100644
+--- a/configure.in
++++ b/configure.in
+@@ -73,30 +73,44 @@ case $host_os in
+ esac
AC_ARG_ENABLE(uml,
- AS_HELP_STRING([--enable-uml], [enable support for User Mode Linux]),
+- AS_HELP_STRING([--enable-uml], [enable support for User Mode Linux]),
- [ AC_DEFINE(ENABLE_UML, 1, [Support for UML])
- uml=true
- ]
++ AS_HELP_STRING([--disable-uml], [enable support for User Mode Linux]),
+ [ AS_IF([test "x$enable_uml" = "xyes"],
+ [ AC_DEFINE(ENABLE_UML, 1, [Support for UML])
+ uml=true
+ ],
+ [uml=false])
+ ],
-+ [uml=true]
++ [uml=false]
)
AC_ARG_ENABLE(vde,
- AS_HELP_STRING([--enable-vde], [enable support for Virtual Distributed Ethernet]),
+- AS_HELP_STRING([--enable-vde], [enable support for Virtual Distributed Ethernet]),
- [ AC_CHECK_HEADERS(libvdeplug_dyn.h, [], [AC_MSG_ERROR([VDE plug header files not found.]); break])
- AC_DEFINE(ENABLE_VDE, 1, [Support for VDE])
- vde=true
- ]
++ AS_HELP_STRING([--disable-vde], [enable support for Virtual Distributed Ethernet]),
+ [ AS_IF([test "x$enable_vde" = "xyes"],
+ [ AC_CHECK_HEADERS(libvdeplug_dyn.h, [], [AC_MSG_ERROR([VDE plug header files not found.]); break])
+ AC_DEFINE(ENABLE_VDE, 1, [Support for VDE])
@@ -30,37 +34,41 @@ diff -Naur tinc-1.0.18.orig//configure.in tinc-1.0.18/configure.in
+ ],
+ [vde=false])
+ ],
-+ [vde=true]
++ [vde=false]
)
AC_ARG_ENABLE(tunemu,
- AS_HELP_STRING([--enable-tunemu], [enable support for the tunemu driver]),
+- AS_HELP_STRING([--enable-tunemu], [enable support for the tunemu driver]),
- [ AC_DEFINE(ENABLE_TUNEMU, 1, [Support for tunemu])
- tunemu=true
- ]
++ AS_HELP_STRING([--disable-tunemu], [enable support for the tunemu driver]),
+ [ AS_IF([test "x$enable_tunemu" = "xyes"],
+ [ AC_DEFINE(ENABLE_TUNEMU, 1, [Support for tunemu])
+ tunemu=true
+ ],
+ [tunemu=false])
+ ],
-+ [tunemu=true]
++ [tunemu=false]
)
AC_ARG_WITH(windows2000,
- AS_HELP_STRING([--with-windows2000], [compile with support for Windows 2000. This disables support for tunneling over existing IPv6 networks.]),
+- AS_HELP_STRING([--with-windows2000], [compile with support for Windows 2000. This disables support for tunneling over existing IPv6 networks.]),
- [AC_DEFINE(WITH_WINDOWS2000, 1, [Compile with support for Windows 2000])]
++ AS_HELP_STRING([--without-windows2000], [compile with support for Windows 2000. This disables support for tunneling over existing IPv6 networks.]),
+ [ AS_IF([test "x$with_windows2000" = "xyes"],
+ [AC_DEFINE(WITH_WINDOWS2000, 1, [Compile with support for Windows 2000])])
+ ]
)
AM_CONDITIONAL(UML, test "$uml" = true)
-@@ -177,7 +191,9 @@
+@@ -176,8 +190,10 @@ tinc_OPENSSL
+
dnl Check if support for jumbograms is requested
AC_ARG_ENABLE(jumbograms,
- AS_HELP_STRING([--enable-jumbograms], [enable support for jumbograms (packets up to 9000 bytes)]),
+- AS_HELP_STRING([--enable-jumbograms], [enable support for jumbograms (packets up to 9000 bytes)]),
- [ AC_DEFINE(ENABLE_JUMBOGRAMS, 1, [Support for jumbograms (packets up to 9000 bytes)]) ]
++ AS_HELP_STRING([--disable-jumbograms], [enable support for jumbograms (packets up to 9000 bytes)]),
+ [ AS_IF([test "x$enable_jumbograms" = "xyes"],
+ [ AC_DEFINE(ENABLE_JUMBOGRAMS, 1, [Support for jumbograms (packets up to 9000 bytes)]) ])
+ ]
diff --git a/net-misc/tinc/tinc-1.0.18.ebuild b/net-misc/tinc/tinc-1.0.18.ebuild
index 19c9d5947403..89a519ca37e9 100644
--- a/net-misc/tinc/tinc-1.0.18.ebuild
+++ b/net-misc/tinc/tinc-1.0.18.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.18.ebuild,v 1.1 2012/03/26 01:44:07 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tinc/tinc-1.0.18.ebuild,v 1.2 2012/03/26 12:40:17 blueness Exp $
EAPI="4"
@@ -13,7 +13,7 @@ SRC_URI="http://www.tinc-vpn.org/packages/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="+lzo vde +zlib"
+IUSE="+lzo uml vde +zlib"
DEPEND=">=dev-libs/openssl-0.9.7
lzo? ( dev-libs/lzo:2 )
@@ -27,15 +27,12 @@ src_prepare() {
}
src_configure() {
- # The new DeviceType option can now be used to select UML or VDE
- # devices without having to recompile. So we'll set UML by default
- # since it doesn't pull in any deps, but VDE needs net-misc/vde,
- # so we'll keep that contingent on a USE flag.
econf \
--enable-jumbograms \
- --enable-uml \
- $(use_enable vde) \
+ --disable-tunemu \
$(use_enable lzo) \
+ $(use_enable uml) \
+ $(use_enable vde) \
$(use_enable zlib)
}