summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-09-17 05:01:20 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-09-17 05:01:20 +0000
commit268ba5c23b64c8a492ccd67b2cc0926f257372ce (patch)
tree1f39951c1554f865941a759444941bcb9862fad8 /net-misc
parentBump dependencies (hal and libsndfile). (diff)
downloadgentoo-2-268ba5c23b64c8a492ccd67b2cc0926f257372ce.tar.gz
gentoo-2-268ba5c23b64c8a492ccd67b2cc0926f257372ce.tar.bz2
gentoo-2-268ba5c23b64c8a492ccd67b2cc0926f257372ce.zip
Add a patch to use ezrss.it instead of tvrss.net by default. Hopefully, more user friendly.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/pytvshows/ChangeLog9
-rw-r--r--net-misc/pytvshows/files/pytvshows-0.2-ezrss.it.patch30
-rw-r--r--net-misc/pytvshows/pytvshows-0.2-r1.ebuild22
3 files changed, 60 insertions, 1 deletions
diff --git a/net-misc/pytvshows/ChangeLog b/net-misc/pytvshows/ChangeLog
index f3a19f685759..71836ed5ce5d 100644
--- a/net-misc/pytvshows/ChangeLog
+++ b/net-misc/pytvshows/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-misc/pytvshows
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/pytvshows/ChangeLog,v 1.5 2009/03/20 04:49:31 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pytvshows/ChangeLog,v 1.6 2009/09/17 05:01:19 darkside Exp $
+
+*pytvshows-0.2-r1 (17 Sep 2009)
+
+ 17 Sep 2009; Jeremy Olexa <darkside@gentoo.org> +pytvshows-0.2-r1.ebuild,
+ +files/pytvshows-0.2-ezrss.it.patch:
+ Add a patch to use ezrss.it instead of tvrss.net by default. Hopefully,
+ more user friendly.
20 Mar 2009; Joseph Jezak <josejx@gentoo.org> pytvshows-0.2.ebuild:
Marked ~ppc for bug #262583.
diff --git a/net-misc/pytvshows/files/pytvshows-0.2-ezrss.it.patch b/net-misc/pytvshows/files/pytvshows-0.2-ezrss.it.patch
new file mode 100644
index 000000000000..d72a35ffa152
--- /dev/null
+++ b/net-misc/pytvshows/files/pytvshows-0.2-ezrss.it.patch
@@ -0,0 +1,30 @@
+This patch simply alters the feed site since txrss.net was closed/shut down.
+Luckily, ezrss.it expects the same arguments and should generally work. You can
+find similar details at:
+http://sourceforge.net/projects/pytvshows/forums/forum/726961/topic/3309243?message=7544190
+
+Yes, this could have been accomplished via the --feed paramater, but this is
+more user friendly.
+
+--- pytvshows.orig 2009-09-15 22:36:34.575002779 -0500
++++ pytvshows 2009-09-15 22:43:18.283754081 -0500
+@@ -59,7 +59,7 @@
+ -cFILE, --config FILE
+ Path to config file. Default: ~/.pytvshows.cfg
+ -fFEED, --feed=FEED
+- Override the tvrss.net feed. %%s is replaced with the
++ Override the ezrss.it feed. %%s is replaced with the
+ exact show name.
+ -h, --help This help message
+ -oDIR, --output_dir=DIR
+@@ -77,8 +77,8 @@
+ commands = ['update', 'subscribe', 'unsubscribe', 'run']
+ config = {
+ 'config_file': os.path.expanduser("~/.pytvshows.cfg"),
+- 'feed': "http://tvrss.net/search/index.php?show_name=%s&show_name_exact" \
+- "=true&mode=rss",
++ 'feed': "http://www.ezrss.it/search/index.php?show_name=%s" \
++ "&show_name_exact=true&mode=rss",
+ 'output_dir': os.path.expanduser("~/"),
+ 'output_dir2': None,
+ 'quality_matches': {
diff --git a/net-misc/pytvshows/pytvshows-0.2-r1.ebuild b/net-misc/pytvshows/pytvshows-0.2-r1.ebuild
new file mode 100644
index 000000000000..5837da2234db
--- /dev/null
+++ b/net-misc/pytvshows/pytvshows-0.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/pytvshows/pytvshows-0.2-r1.ebuild,v 1.1 2009/09/17 05:01:19 darkside Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="downloads torrents for TV shows from RSS feeds provided by ezrss.it."
+HOMEPAGE="http://sourceforge.net/projects/pytvshows/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-python/feedparser"
+
+src_unpack() {
+ distutils_src_unpack
+ epatch "${FILESDIR}/${P}-ezrss.it.patch"
+}