summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2006-10-31 18:15:41 +0000
committerAron Griffis <agriffis@gentoo.org>2006-10-31 18:15:41 +0000
commit0f63b10f8096fb7f2de5d1f0a2419dd6631f3ed1 (patch)
tree879eb6958778c881c9e79615ca1d4290dea1d57c /net-misc
parentStable on ppc wrt bug 153308 (diff)
downloadgentoo-2-0f63b10f8096fb7f2de5d1f0a2419dd6631f3ed1.tar.gz
gentoo-2-0f63b10f8096fb7f2de5d1f0a2419dd6631f3ed1.tar.bz2
gentoo-2-0f63b10f8096fb7f2de5d1f0a2419dd6631f3ed1.zip
Bump to 4.16 (from 4.15)
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/stunnel/ChangeLog7
-rw-r--r--net-misc/stunnel/files/digest-stunnel-4.163
-rw-r--r--net-misc/stunnel/stunnel-4.16.ebuild82
3 files changed, 91 insertions, 1 deletions
diff --git a/net-misc/stunnel/ChangeLog b/net-misc/stunnel/ChangeLog
index 859a18252970..8f7e6002a130 100644
--- a/net-misc/stunnel/ChangeLog
+++ b/net-misc/stunnel/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/stunnel
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.58 2006/07/15 13:23:48 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/ChangeLog,v 1.59 2006/10/31 18:15:41 agriffis Exp $
+
+*stunnel-4.16 (31 Oct 2006)
+
+ 31 Oct 2006; Aron Griffis <agriffis@gentoo.org> +stunnel-4.16.ebuild:
+ Bump to 4.16 (from 4.15)
15 Jul 2006; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove aliz from metadata.xml as he's retired.
diff --git a/net-misc/stunnel/files/digest-stunnel-4.16 b/net-misc/stunnel/files/digest-stunnel-4.16
new file mode 100644
index 000000000000..1127c30e090e
--- /dev/null
+++ b/net-misc/stunnel/files/digest-stunnel-4.16
@@ -0,0 +1,3 @@
+MD5 e37c3f7e7e7cc647a95ef8c8bb0e2f98 stunnel-4.16.tar.gz 500271
+RMD160 4baec09cc2f68913bcdcf1fb5f47ddc56c34c147 stunnel-4.16.tar.gz 500271
+SHA256 3379836d210ee95f769d70e898db26ef2ffbefd02355204146008c10579e3a87 stunnel-4.16.tar.gz 500271
diff --git a/net-misc/stunnel/stunnel-4.16.ebuild b/net-misc/stunnel/stunnel-4.16.ebuild
new file mode 100644
index 000000000000..f66826c74494
--- /dev/null
+++ b/net-misc/stunnel/stunnel-4.16.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/stunnel/stunnel-4.16.ebuild,v 1.1 2006/10/31 18:15:41 agriffis Exp $
+
+inherit ssl-cert eutils flag-o-matic
+
+DESCRIPTION="TLS/SSL - Port Wrapper"
+HOMEPAGE="http://stunnel.mirt.net/"
+SRC_URI="http://www.stunnel.org/download/stunnel/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86"
+IUSE="ipv6 selinux tcpd"
+
+DEPEND="virtual/libc
+ >=dev-libs/openssl-0.9.6j"
+RDEPEND=">=dev-libs/openssl-0.9.6j
+ selinux? ( sec-policy/selinux-stunnel )"
+
+src_unpack() {
+ unpack ${A}
+ # Hack away generation of certificate
+ sed -i s/^install-data-local:/do-not-run-this:/ "${S}"/tools/Makefile.in
+}
+
+src_compile() {
+ local myconf=""
+ # Don't shoot me for doing this! The stunnel configure script is broke and
+ # doesn't honor --disable-foo
+ if use ipv6 ; then
+ myconf="${myconf} --enable-ipv6"
+ fi
+ if ! use tcpd ; then
+ myconf="${myconf} --disable-libwrap"
+ fi
+ econf ${myconf} || die "econf died"
+ emake || die "emake died"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ rm -rf ${D}/usr/share/doc/${PN}
+ rm -f ${D}/{etc/stunnel/stunnel.conf-sample,usr/sbin/stunnel3}
+ rm -f ${D}/usr/share/man/man8/{stunnel.fr.8,stunnel.pl.8}
+
+ dodoc AUTHORS BUGS CREDITS INSTALL NEWS PORTS README TODO ChangeLog \
+ doc/en/transproxy.txt
+ dohtml doc/stunnel.html doc/en/VNC_StunnelHOWTO.html tools/ca.html \
+ tools/importCA.html
+
+ insinto /etc/stunnel
+ donewins ${FILESDIR}/stunnel.conf stunnel.conf
+ newinitd ${FILESDIR}/stunnel.rc6 stunnel
+ # Check if there's currently an cert already there
+ if [ ! -f /etc/stunnel/stunnel.key ]; then
+ docert stunnel
+ fi
+
+ keepdir /var/run/stunnel
+}
+
+pkg_postinst() {
+ enewgroup stunnel
+ enewuser stunnel -1 -1 -1 stunnel
+
+ chown stunnel:stunnel ${ROOT}/var/run/stunnel
+ chown stunnel:stunnel ${ROOT}/etc/stunnel/stunnel.{conf,crt,csr,key,pem}
+ chmod 0640 ${ROOT}/etc/stunnel/stunnel.{conf,crt,csr,key,pem}
+
+ if [ ! -z "$(egrep '/etc/stunnel/stunnel.pid' \
+ ${ROOT}/etc/stunnel/stunnel.conf )" ] ; then
+
+ ewarn "As of stunnel-4.09, the pid file will be located in /var/run/stunnel."
+ ewarn "Please stop stunnel, etc-update, and start stunnel back up to ensure"
+ ewarn "the update takes place"
+ ewarn ""
+ ewarn "The new location will be /var/run/stunnel/stunnel.pid"
+ ebeep 3
+ epause 3
+ fi
+}