summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-09-10 11:57:13 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-09-10 11:57:13 +0000
commit017643b60948a5c40706a66f4c8106abd7d89554 (patch)
tree821d35e1c8dbf2e81e3b913a7c69d1116aabaa94 /net-misc
parentErrr fix my previous commit where I removed git-2 eclass accidentally (diff)
downloadgentoo-2-017643b60948a5c40706a66f4c8106abd7d89554.tar.gz
gentoo-2-017643b60948a5c40706a66f4c8106abd7d89554.tar.bz2
gentoo-2-017643b60948a5c40706a66f4c8106abd7d89554.zip
bump tor-0.2.3.3_alpha to DEPEND on >=libevent-2.0.14, bug #376515
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/tor/ChangeLog8
-rw-r--r--net-misc/tor/tor-0.2.3.3_alpha-r1.ebuild86
2 files changed, 93 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index 0f8b2628c766..87561aa5dd57 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.275 2011/09/05 16:46:23 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.276 2011/09/10 11:57:13 blueness Exp $
+
+*tor-0.2.3.3_alpha-r1 (10 Sep 2011)
+
+ 10 Sep 2011; Anthony G. Basile <blueness@gentoo.org>
+ +tor-0.2.3.3_alpha-r1.ebuild:
+ bump tor-0.2.3.3_alpha to DEPEND on >=libevent-2.0.14, bug #376515
05 Sep 2011; Anthony G. Basile <blueness@gentoo.org>
tor-0.2.3.3_alpha.ebuild:
diff --git a/net-misc/tor/tor-0.2.3.3_alpha-r1.ebuild b/net-misc/tor/tor-0.2.3.3_alpha-r1.ebuild
new file mode 100644
index 000000000000..7e403912d9a3
--- /dev/null
+++ b/net-misc/tor/tor-0.2.3.3_alpha-r1.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.3.3_alpha-r1.ebuild,v 1.1 2011/09/10 11:57:13 blueness Exp $
+
+EAPI=4
+
+inherit autotools eutils flag-o-matic versionator
+
+MY_PV="$(replace_version_separator 4 -)"
+MY_PF="${PN}-${MY_PV}"
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+SRC_URI="http://www.torproject.org/dist/${MY_PF}.tar.gz"
+S="${WORKDIR}/${MY_PF}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+bufferevents doc nat-pmp tor-hardening transparent-proxy threads upnp"
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-2.0.14
+ nat-pmp? ( net-libs/libnatpmp )
+ upnp? ( <net-libs/miniupnpc-1.6 )"
+
+# The tordns patch for tsocks avoids some leakage of information thus raising anonymity
+RDEPEND="${DEPEND}
+ net-proxy/tsocks[tordns]"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample.patch
+
+ einfo "Regenerating autotools files ..."
+ epatch "${FILESDIR}"/${PN}-0.2.2.24_alpha-respect-CFLAGS.patch
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ # Upstream isn't sure of all the user provided CFLAGS that
+ # will break tor, but does recommend against -fstrict-aliasing.
+ # We'll filter-flags them here as we encounter them.
+ filter-flags -fstrict-aliasing
+ econf --docdir=/usr/share/doc/${PF} \
+ $(use_enable bufferevents) \
+ $(use_enable doc asciidoc) \
+ $(use_enable nat-pmp) \
+ $(use_enable tor-hardening gcc-hardening) \
+ $(use_enable tor-hardening linker-hardening)\
+ $(use_enable transparent-proxy transparent) \
+ $(use_enable threads) \
+ $(use_enable upnp)
+}
+
+src_install() {
+ newconfd "${FILESDIR}"/tor.confd tor
+ newinitd "${FILESDIR}"/tor.initd-r6 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/lib/tor
+
+ dodoc README ChangeLog ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/README
+
+ fperms 750 /var/lib/tor
+ fowners tor:tor /var/lib/tor
+
+ insinto /etc/tor/
+ newins "${FILESDIR}"/torrc-r1 torrc
+}
+
+pkg_postinst() {
+ elog
+ elog "We created a configuration file for tor, /etc/tor/torrc, but you can"
+ elog "change it according to your needs. Use the torrc.sample that is in"
+ elog "that directory as a guide. Also, to have privoxy work with tor"
+ elog "just add the following line"
+ elog
+ elog "forward-socks4a / localhost:9050 ."
+ elog
+ elog "to /etc/privoxy/config. Notice the . at the end!"
+ elog
+}