summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2008-02-24 16:11:38 +0000
committerRaúl Porcel <armin76@gentoo.org>2008-02-24 16:11:38 +0000
commit638e4203215c83dec0e6c6b4ad09f85e7c8366ff (patch)
tree85aad6e0ec8e2a2b79f7734911deee1b4a1197a5 /net-misc/wput
parentx86 stable, bug #211252 (diff)
downloadgentoo-2-638e4203215c83dec0e6c6b4ad09f85e7c8366ff.tar.gz
gentoo-2-638e4203215c83dec0e6c6b4ad09f85e7c8366ff.tar.bz2
gentoo-2-638e4203215c83dec0e6c6b4ad09f85e7c8366ff.zip
Version bump, bug #207579
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-misc/wput')
-rw-r--r--net-misc/wput/ChangeLog8
-rw-r--r--net-misc/wput/files/wput-0.5-gentoo.diff37
-rw-r--r--net-misc/wput/wput-0.6.1.ebuild41
3 files changed, 48 insertions, 38 deletions
diff --git a/net-misc/wput/ChangeLog b/net-misc/wput/ChangeLog
index 6bc025d4a5d6..cc8ded5de17e 100644
--- a/net-misc/wput/ChangeLog
+++ b/net-misc/wput/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/wput
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/ChangeLog,v 1.17 2008/01/26 17:21:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/ChangeLog,v 1.18 2008/02/24 16:11:37 armin76 Exp $
+
+*wput-0.6.1 (24 Feb 2008)
+
+ 24 Feb 2008; Raúl Porcel <armin76@gentoo.org>
+ -files/wput-0.5-gentoo.diff, +wput-0.6.1.ebuild:
+ Version bump, bug #207579
26 Jan 2008; Raúl Porcel <armin76@gentoo.org> -wput-0.5.ebuild:
old
diff --git a/net-misc/wput/files/wput-0.5-gentoo.diff b/net-misc/wput/files/wput-0.5-gentoo.diff
deleted file mode 100644
index f362ab45aa52..000000000000
--- a/net-misc/wput/files/wput-0.5-gentoo.diff
+++ /dev/null
@@ -1,37 +0,0 @@
-diff -urN wput.orig/Makefile.in wput/Makefile.in
---- wput.orig/Makefile.in 2004-12-12 13:40:04.146801506 -0500
-+++ wput/Makefile.in 2004-12-12 13:48:08.352295485 -0500
-@@ -1,14 +1,18 @@
- #wput makefile
-+
- prefix = @prefix@
--mandir = $(prefix)/man/man1
-+datadir = $(prefix)/share
-+mandir = $(datadir)/man/man1
- exec_prefix = @exec_prefix@
- bindir=@bindir@
-
- all clean win-clean:
- cd src && $(MAKE) $@
- install: all
-- cp wput $(bindir)
-- cp doc/wput.1.gz $(mandir)
-+ install -d $(DESTDIR)$(bindir)
-+ install -m0755 wput $(DESTDIR)$(bindir)
-+ install -d $(DESTDIR)$(mandir)
-+ install -m0644 doc/wput.1.gz $(DESTDIR)$(mandir)
- @echo "----------------"
- @echo "Wput installed. See 'wput -h' or 'man wput' for usage information."
- @echo "Further documentation is located in the doc/USAGE.* files."
-diff -urN wput.orig/src/ftp.c wput/src/ftp.c
---- wput.orig/src/ftp.c 2004-12-12 13:40:04.085811666 -0500
-+++ wput/src/ftp.c 2004-12-12 13:42:26.493103988 -0500
-@@ -531,7 +531,7 @@
-
- #define DBUFSIZE 1024
-
-- int fd;
-+ int fd = -1;
- FILE * pipe = NULL;
- char databuf[DBUFSIZE];
- int readbytes = 0;
diff --git a/net-misc/wput/wput-0.6.1.ebuild b/net-misc/wput/wput-0.6.1.ebuild
new file mode 100644
index 000000000000..faa23eb09028
--- /dev/null
+++ b/net-misc/wput/wput-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wput/wput-0.6.1.ebuild,v 1.1 2008/02/24 16:11:37 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="A tiny program that looks like wget and is designed to upload files or whole directories to remote ftp-servers"
+HOMEPAGE="http://wput.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug nls ssl"
+
+RDEPEND="ssl? ( net-libs/gnutls )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.6-gentoo.diff"
+ # Fix bug 126828
+ epatch "${FILESDIR}/wput-0.6-respectldflags.patch"
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-memdbg=yes" || myconf="--enable-g-switch=no"
+ econf ${myconf} \
+ $(use_enable nls) \
+ $(use_with ssl) || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog INSTALL TODO
+}