summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-05-22 22:52:52 +0000
committerMike Frysinger <vapier@gentoo.org>2012-05-22 22:52:52 +0000
commit9f5291f93b8cb110985debba36479fcbb4689a8d (patch)
tree18f6f424c4068459f1bfbad64fff1c03446f7f90 /net-misc/wget
parentfix typo (diff)
downloadgentoo-2-9f5291f93b8cb110985debba36479fcbb4689a8d.tar.gz
gentoo-2-9f5291f93b8cb110985debba36479fcbb4689a8d.tar.bz2
gentoo-2-9f5291f93b8cb110985debba36479fcbb4689a8d.zip
Fix building with glibc-2.16+.
(Portage version: 2.2.0_alpha102/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/wget')
-rw-r--r--net-misc/wget/ChangeLog6
-rw-r--r--net-misc/wget/files/wget-1.13.4-no-gets.patch21
-rw-r--r--net-misc/wget/wget-1.13.4-r1.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/net-misc/wget/ChangeLog b/net-misc/wget/ChangeLog
index d1c334ae9174..121c813ecde7 100644
--- a/net-misc/wget/ChangeLog
+++ b/net-misc/wget/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/wget
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.156 2012/05/22 19:02:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/ChangeLog,v 1.157 2012/05/22 22:52:52 vapier Exp $
+
+ 22 May 2012; Mike Frysinger <vapier@gentoo.org>
+ +files/wget-1.13.4-no-gets.patch, wget-1.13.4-r1.ebuild:
+ Fix building with glibc-2.16+.
22 May 2012; Agostino Sarubbo <ago@gentoo.org> wget-1.13.4-r1.ebuild:
Stable for amd64, wrt bug #406657
diff --git a/net-misc/wget/files/wget-1.13.4-no-gets.patch b/net-misc/wget/files/wget-1.13.4-no-gets.patch
new file mode 100644
index 000000000000..df836c71ccc3
--- /dev/null
+++ b/net-misc/wget/files/wget-1.13.4-no-gets.patch
@@ -0,0 +1,21 @@
+hack until gzip pulls a newer gnulib version
+
+From 66712c23388e93e5c518ebc8515140fa0c807348 Mon Sep 17 00:00:00 2001
+From: Eric Blake <eblake@redhat.com>
+Date: Thu, 29 Mar 2012 13:30:41 -0600
+Subject: [PATCH] stdio: don't assume gets any more
+
+Gnulib intentionally does not have a gets module, and now that C11
+and glibc have dropped it, we should be more proactive about warning
+any user on a platform that still has a declaration of this dangerous
+interface.
+
+--- a/lib/stdio.in.h
++++ b/lib/stdio.in.h
+@@ -125,7 +125,6 @@
+ so any use of gets warrants an unconditional warning. Assume it is
+ always declared, since it is required by C89. */
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+ #endif
+
+
diff --git a/net-misc/wget/wget-1.13.4-r1.ebuild b/net-misc/wget/wget-1.13.4-r1.ebuild
index 398b488e9c2e..a81c4a399e61 100644
--- a/net-misc/wget/wget-1.13.4-r1.ebuild
+++ b/net-misc/wget/wget-1.13.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.4-r1.ebuild,v 1.8 2012/05/22 19:02:26 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/wget/wget-1.13.4-r1.ebuild,v 1.9 2012/05/22 22:52:52 vapier Exp $
EAPI="4"
@@ -33,6 +33,7 @@ DOCS=( AUTHORS MAILING-LIST NEWS README doc/sample.wgetrc )
src_prepare() {
epatch "${FILESDIR}"/${P}-openssl-pkg-config.patch
+ epatch "${FILESDIR}"/${P}-no-gets.patch
eautoreconf
}