summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2011-02-10 00:00:45 +0000
committerAnthony G. Basile <blueness@gentoo.org>2011-02-10 00:00:45 +0000
commit335d1c27d99633b666ae5c9f66c84f5716d6941f (patch)
tree662cc89f08640a779589be1dd1ed4812ce3bf5be /net-misc/tor
parentRename binaries to avoid file collisions (bug 350016) (diff)
downloadgentoo-2-335d1c27d99633b666ae5c9f66c84f5716d6941f.tar.gz
gentoo-2-335d1c27d99633b666ae5c9f66c84f5716d6941f.tar.bz2
gentoo-2-335d1c27d99633b666ae5c9f66c84f5716d6941f.zip
Added /etc/tor/torrc so tor works out of the box.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/tor')
-rw-r--r--net-misc/tor/ChangeLog8
-rw-r--r--net-misc/tor/files/torrc5
-rw-r--r--net-misc/tor/tor-0.2.1.29-r1.ebuild87
3 files changed, 99 insertions, 1 deletions
diff --git a/net-misc/tor/ChangeLog b/net-misc/tor/ChangeLog
index b4154366c0af..9b8253e9d591 100644
--- a/net-misc/tor/ChangeLog
+++ b/net-misc/tor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/tor
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.234 2011/02/01 02:42:49 chiiph Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/ChangeLog,v 1.235 2011/02/10 00:00:45 blueness Exp $
+
+*tor-0.2.1.29-r1 (09 Feb 2011)
+
+ 09 Feb 2011; Anthony G. Basile <blueness@gentoo.org>
+ +tor-0.2.1.29-r1.ebuild, +files/torrc:
+ Added /etc/tor/torrc so tor works out of the box.
*tor-0.2.2.22_alpha (01 Feb 2011)
diff --git a/net-misc/tor/files/torrc b/net-misc/tor/files/torrc
new file mode 100644
index 000000000000..640fea191e95
--- /dev/null
+++ b/net-misc/tor/files/torrc
@@ -0,0 +1,5 @@
+User tor
+Group tor
+PIDFile /var/run/tor/tor.pid
+Log notice file /var/log/tor/tor.log
+DataDirectory /var/lib/tor/data
diff --git a/net-misc/tor/tor-0.2.1.29-r1.ebuild b/net-misc/tor/tor-0.2.1.29-r1.ebuild
new file mode 100644
index 000000000000..a1b4920d1776
--- /dev/null
+++ b/net-misc/tor/tor-0.2.1.29-r1.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/tor/tor-0.2.1.29-r1.ebuild,v 1.1 2011/02/10 00:00:45 blueness Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Anonymizing overlay network for TCP"
+HOMEPAGE="http://www.torproject.org/"
+MY_PV=${PV/_/-}
+SRC_URI="http://www.torproject.org/dist/${PN}-${MY_PV}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/openssl
+ >=dev-libs/libevent-1.2"
+# The tordns patch for tsocks avoids some leakage of information thus raising anonymity
+RDEPEND="${DEPEND}
+ net-proxy/tsocks[tordns]"
+
+pkg_setup() {
+ enewgroup tor
+ enewuser tor -1 -1 /var/lib/tor tor
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/torrc.sample-0.1.2.6.patch
+ epatch "${FILESDIR}"/${PN}-0.2.1.19-logrotate.patch
+ # Normally tor uses a bundled libevent fragment to provide
+ # asynchronous DNS requests. This is generally a bad idea, but at
+ # the moment the official libevent does not have the 0x20 hack, so
+ # anonymity is higher with the bundled variant. Remove patch as
+ # soon as upstream has installed the autoconf option to use
+ # system's libevent. This hasn't happened, so we
+ # have to live with the bundled libevent for this release, as the
+ # current version in tree won't suffice for tor to build
+ # See http://bugs.noreply.org/flyspray/index.php?do=details&id=920
+ # for upstream's report
+ # Let's revisit this when libevent-2* is unmasked
+ # use bundledlibevent || epatch "${FILESDIR}"/${PN}-0.2.1.5-no-internal-libevent.patch
+}
+
+src_configure() {
+ econf $(use_enable debug)
+}
+
+src_install() {
+ newinitd "${FILESDIR}"/tor.initd-r4 tor
+ emake DESTDIR="${D}" install || die
+ keepdir /var/{lib,log,run}/tor
+
+ dodoc README ChangeLog AUTHORS ReleaseNotes \
+ doc/{HACKING,TODO} \
+ doc/spec/*.txt
+
+ fperms 750 /var/lib/tor /var/log/tor
+ fperms 755 /var/run/tor
+ fowners tor:tor /var/lib/tor /var/log/tor /var/run/tor
+
+ insinto /etc/tor/
+ doins "${FILESDIR}"/torrc
+
+ insinto /etc/logrotate.d
+ newins contrib/tor.logrotate tor
+
+ # allow the tor user more open files to avoid errors, see bug 251171
+ insinto /etc/security/limits.d/
+ doins "${FILESDIR}"/tor.conf
+}
+
+pkg_postinst() {
+ elog
+ elog "We created a configuration file for tor, /etc/tor/torrc, but you can"
+ elog "change it according to your needs. Use the torrc.sample that is in"
+ elog "that directory as a guide. Also, to have privoxy work with tor"
+ elog "just add the following line"
+ elog
+ elog "forward-socks4a / localhost:9050 ."
+ elog
+ elog "to /etc/privoxy/config. Notice the . at the end!"
+ elog
+}