summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2009-08-28 21:40:24 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2009-08-28 21:40:24 +0000
commit42ede2d79ea52ff1067e6c6b57e4b19c32c4ca23 (patch)
treefe4789b4ecf55322fe1874c76cabdc54bd2f5222 /net-misc/sitecopy
parentRemove old revisions. (diff)
downloadgentoo-2-42ede2d79ea52ff1067e6c6b57e4b19c32c4ca23.tar.gz
gentoo-2-42ede2d79ea52ff1067e6c6b57e4b19c32c4ca23.tar.bz2
gentoo-2-42ede2d79ea52ff1067e6c6b57e4b19c32c4ca23.zip
Migrate to EAPI 2 in order to get rid of built_with_use.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'net-misc/sitecopy')
-rw-r--r--net-misc/sitecopy/ChangeLog8
-rw-r--r--net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild43
2 files changed, 18 insertions, 33 deletions
diff --git a/net-misc/sitecopy/ChangeLog b/net-misc/sitecopy/ChangeLog
index b92e68df968c..98b5f3204308 100644
--- a/net-misc/sitecopy/ChangeLog
+++ b/net-misc/sitecopy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/sitecopy
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/ChangeLog,v 1.50 2008/06/30 20:40:11 armin76 Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/ChangeLog,v 1.51 2009/08/28 21:40:24 betelgeuse Exp $
+
+ 28 Aug 2009; Petteri Räty <betelgeuse@gentoo.org>
+ sitecopy-0.16.3_p17.ebuild:
+ Migrate to EAPI 2 in order to get rid of built_with_use.
30 Jun 2008; Raúl Porcel <armin76@gentoo.org>
-files/0.16.3-neon-28.patch, -sitecopy-0.16.3.ebuild,
diff --git a/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild b/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild
index fa9805aa0df9..af6208b7b46f 100644
--- a/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild
+++ b/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild,v 1.3 2008/06/30 20:40:11 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.16.3_p17.ebuild,v 1.4 2009/08/28 21:40:24 betelgeuse Exp $
+
+EAPI="2"
inherit eutils autotools
@@ -18,38 +20,18 @@ KEYWORDS="~amd64 ppc sparc x86"
LICENSE="GPL-2"
SLOT="0"
DEPEND="rsh? ( net-misc/netkit-rsh )
- >=net-misc/neon-0.24.6"
+ >=net-misc/neon-0.24.6[zlib?,ssl?,expat?]
+ xml? ( >=net-misc/neon-0.24.6[-expat] )"
S="${WORKDIR}"/${MY_P/_/-}
-pkg_setup() {
- if use zlib ; then
- built_with_use net-misc/neon zlib || die "neon needs zlib support"
- fi
-
- if use ssl ; then
- built_with_use net-misc/neon ssl || die "neon needs ssl support"
- myconf="${myconf} --with-ssl=openssl"
- fi
-
- if use expat ; then
- built_with_use net-misc/neon expat || die "neon needs expat support"
- fi
-
- if use xml ; then
- built_with_use net-misc/neon expat && die "neon needs expat support disabled for
- libxml2 support to be enabled"
- fi
-}
-
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
+ cd "${WORKDIR}" || die
# Debian patches
epatch ${MY_P}-${DEB_PL}.diff
epatch "${S}"/debian/patches/*.dpatch
- cd "${S}"
+ cd "${S}" || die
# Make it work with neon .29
epatch "${FILESDIR}"/${PV}-neon-29.patch
@@ -62,8 +44,9 @@ src_unpack() {
eautomake
}
-src_compile() {
- econf ${myconf} \
+src_configure() {
+ econf \
+ $(use_with ssl ssl openssl) \
$(use_enable webdav) \
$(use_enable nls) \
$(use_enable rsh) \
@@ -71,8 +54,6 @@ src_compile() {
$(use_with xml libxml2 ) \
--with-neon \
|| die "econf failed"
-
- emake || die "eake failed"
}
src_install() {