summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-05-10 19:22:14 +0000
committerJeroen Roovers <jer@gentoo.org>2011-05-10 19:22:14 +0000
commitc4c70a74861f7296b704b74ee42611e2f2235e52 (patch)
treebd2445e9f0962c4d43f7e0ab0d606e4e22e69d60 /net-misc/putty
parentVersion bump, fixing bug #365281. (diff)
downloadgentoo-2-c4c70a74861f7296b704b74ee42611e2f2235e52.tar.gz
gentoo-2-c4c70a74861f7296b704b74ee42611e2f2235e52.tar.bz2
gentoo-2-c4c70a74861f7296b704b74ee42611e2f2235e52.zip
Version bump.
(Portage version: 2.2.0_alpha32/cvs/Linux i686)
Diffstat (limited to 'net-misc/putty')
-rw-r--r--net-misc/putty/ChangeLog7
-rw-r--r--net-misc/putty/putty-0.60_p20110905.ebuild69
2 files changed, 75 insertions, 1 deletions
diff --git a/net-misc/putty/ChangeLog b/net-misc/putty/ChangeLog
index 68112d7f116d..63158c3e7d9a 100644
--- a/net-misc/putty/ChangeLog
+++ b/net-misc/putty/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/putty
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.55 2011/03/22 20:47:55 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/ChangeLog,v 1.56 2011/05/10 19:22:14 jer Exp $
+
+*putty-0.60_p20110905 (10 May 2011)
+
+ 10 May 2011; Jeroen Roovers <jer@gentoo.org> +putty-0.60_p20110905.ebuild:
+ Version bump.
22 Mar 2011; Brent Baude <ranger@gentoo.org> putty-0.60_p20100131.ebuild:
Marking putty-0.60_p20100131 ppc for bug 355365
diff --git a/net-misc/putty/putty-0.60_p20110905.ebuild b/net-misc/putty/putty-0.60_p20110905.ebuild
new file mode 100644
index 000000000000..ff45bb0b1594
--- /dev/null
+++ b/net-misc/putty/putty-0.60_p20110905.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/putty/putty-0.60_p20110905.ebuild,v 1.1 2011/05/10 19:22:14 jer Exp $
+
+EAPI="2"
+
+inherit autotools toolchain-funcs
+
+MY_P="${P/_p*/}-2011-05-09"
+
+DESCRIPTION="UNIX port of the famous Telnet and SSH client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+SRC_URI="http://tartarus.org/~simon/putty-snapshots/${MY_P}.tar.gz"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE="doc ipv6 kerberos"
+
+RDEPEND="
+ !net-misc/pssh
+ dev-libs/glib
+ kerberos? ( virtual/krb5 )
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+"
+DEPEND="${RDEPEND} dev-lang/perl"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ cd "${S}"/unix || die "cd unix failed"
+ sed \
+ -i configure.ac \
+ -e '/^AM_PATH_GTK(/d' \
+ -e 's|-Wall -Werror||g' || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die "cd failed"
+ econf \
+ $(use_with kerberos gssapi) \
+ || die "econf failed"
+}
+
+src_compile() {
+ cd "${S}"/unix || die "cd unix failed"
+ emake \
+ $(use ipv6 || echo COMPAT=-DNO_IPV6) \
+ VER=-DSNAPSHOT=${PV} \
+ || die "emake failed"
+}
+
+src_install() {
+ if use doc; then
+ dodoc doc/puttydoc.txt || die "dodoc failed"
+ dohtml doc/*.html || die "dohtml failed"
+ fi
+
+ cd "${S}"/unix
+ emake DESTDIR="${D}" install || die "install failed"
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ doicon "${FILESDIR}"/${PN}.xpm
+ make_desktop_entry "putty" "PuTTY" putty "Network"
+}