summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-02-06 14:11:18 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-02-06 14:11:18 +0000
commit26051cb4c52bb1e3366860cad40a8e42bb213697 (patch)
treee5e728ff7a38e8fb6a6faeedef79bb129f387583 /net-misc/ocsync
parentVersion bump to 1.50. (diff)
downloadgentoo-2-26051cb4c52bb1e3366860cad40a8e42bb213697.tar.gz
gentoo-2-26051cb4c52bb1e3366860cad40a8e42bb213697.tar.bz2
gentoo-2-26051cb4c52bb1e3366860cad40a8e42bb213697.zip
Initial commit for csync fork, bugs #479806 and #494314. Also fixes tests, bug #477020
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'net-misc/ocsync')
-rw-r--r--net-misc/ocsync/ChangeLog11
-rw-r--r--net-misc/ocsync/metadata.xml11
-rw-r--r--net-misc/ocsync/ocsync-0.91.4.ebuild47
3 files changed, 69 insertions, 0 deletions
diff --git a/net-misc/ocsync/ChangeLog b/net-misc/ocsync/ChangeLog
new file mode 100644
index 000000000000..2a0069fad703
--- /dev/null
+++ b/net-misc/ocsync/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-misc/ocsync
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ocsync/ChangeLog,v 1.1 2014/02/06 14:11:18 voyageur Exp $
+
+*ocsync-0.91.4 (06 Feb 2014)
+
+ 06 Feb 2014; Bernard Cafarelli <voyageur@gentoo.org> +ocsync-0.91.4.ebuild,
+ +metadata.xml:
+ Initial commit for csync fork, bugs #479806 and #494314. Also fixes tests,
+ bug #477020
+
diff --git a/net-misc/ocsync/metadata.xml b/net-misc/ocsync/metadata.xml
new file mode 100644
index 000000000000..f713f2a74b47
--- /dev/null
+++ b/net-misc/ocsync/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <use>
+ <flag name="sftp">Enable sftp transfer support via <pkg>net-libs/libssh</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/net-misc/ocsync/ocsync-0.91.4.ebuild b/net-misc/ocsync/ocsync-0.91.4.ebuild
new file mode 100644
index 000000000000..7531ccd7d651
--- /dev/null
+++ b/net-misc/ocsync/ocsync-0.91.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/ocsync/ocsync-0.91.4.ebuild,v 1.1 2014/02/06 14:11:18 voyageur Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="ownCloud fork of csync file synchronizer"
+HOMEPAGE="http://owncloud.org/"
+SRC_URI="http://download.owncloud.com/desktop/stable/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc iconv samba +sftp test"
+
+RDEPEND=">=dev-db/sqlite-3.4:3
+ net-libs/neon[ssl]
+ iconv? ( virtual/libiconv )
+ samba? ( >=net-fs/samba-3.5 )
+ sftp? ( >=net-libs/libssh-0.5 )
+ !net-misc/csync"
+DEPEND="${DEPEND}
+ app-text/asciidoc
+ doc? ( app-doc/doxygen )
+ test? ( dev-util/cmocka )"
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # proper docdir
+ sed -e "s:/doc/${PN}:/doc/${PF}:" \
+ -i doc/CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSYSCONF_INSTALL_DIR="${EPREFIX}"/etc
+ $(cmake-utils_use_with iconv ICONV)
+ $(cmake-utils_use test UNIT_TESTING)
+ $(cmake-utils_use_find_package doc Doxygen)
+ $(cmake-utils_use_find_package samba Libsmbclient)
+ $(cmake-utils_use_find_package sftp LibSSH)
+ )
+ cmake-utils_src_configure
+}