summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2006-08-14 18:13:23 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2006-08-14 18:13:23 +0000
commit9863bde8be8a45ba83d230a95779c7b8e75c05ba (patch)
treed597905d18515a3a7fe8deaf53c38683fcd10886 /net-misc/neon/neon-0.26.1.ebuild
parentSecurity cleanup wrt bug #140514. (diff)
downloadgentoo-2-9863bde8be8a45ba83d230a95779c7b8e75c05ba.tar.gz
gentoo-2-9863bde8be8a45ba83d230a95779c7b8e75c05ba.tar.bz2
gentoo-2-9863bde8be8a45ba83d230a95779c7b8e75c05ba.zip
Allow ebuild to work on non-glibc systems
(Portage version: 2.1.1_pre5)
Diffstat (limited to 'net-misc/neon/neon-0.26.1.ebuild')
-rw-r--r--net-misc/neon/neon-0.26.1.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/net-misc/neon/neon-0.26.1.ebuild b/net-misc/neon/neon-0.26.1.ebuild
index 05003c9dbf5b..fced47708178 100644
--- a/net-misc/neon/neon-0.26.1.ebuild
+++ b/net-misc/neon/neon-0.26.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.1.ebuild,v 1.11 2006/08/13 00:14:24 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/neon/neon-0.26.1.ebuild,v 1.12 2006/08/14 18:13:23 pauldv Exp $
inherit eutils libtool versionator
@@ -33,10 +33,12 @@ src_unpack() {
src_compile() {
local myconf=""
- if built_with_use sys-libs/glibc nptlonly \
- || built_with_use sys-libs/glibc nptl; then
- einfo "Enabling SSL library thread-safety using POSIX threads..."
- myconf="${myconf} --enable-threadsafe-ssl=posix"
+ if has_version sys-libs/glibc; then
+ if built_with_use sys-libs/glibc nptlonly \
+ || built_with_use sys-libs/glibc nptl; then
+ einfo "Enabling SSL library thread-safety using POSIX threads..."
+ myconf="${myconf} --enable-threadsafe-ssl=posix"
+ fi
fi
if use expat; then
myconf="${myconf} --with-expat"