summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2011-01-15 21:13:25 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2011-01-15 21:13:25 +0000
commitb09dfce1e213d280089bd5529519e08885808fd5 (patch)
tree62ce54e600c6df8905b20b3193d5fd82fe3113eb /net-misc/logmein-hamachi
parentAdd new hamachi license (diff)
downloadgentoo-2-b09dfce1e213d280089bd5529519e08885808fd5.tar.gz
gentoo-2-b09dfce1e213d280089bd5529519e08885808fd5.tar.bz2
gentoo-2-b09dfce1e213d280089bd5529519e08885808fd5.zip
Initial commit of new hamachi client. Bug #350172. Thanks to Simone Scanzoni <nonno.cicala@libero.it> for the ebuilds and scripts.
(Portage version: 2.1.9.31/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/logmein-hamachi')
-rw-r--r--net-misc/logmein-hamachi/ChangeLog15
-rw-r--r--net-misc/logmein-hamachi/files/logmein-hamachi.confd16
-rw-r--r--net-misc/logmein-hamachi/files/logmein-hamachi.initd56
-rw-r--r--net-misc/logmein-hamachi/logmein-hamachi-2.0.1.13.ebuild62
-rw-r--r--net-misc/logmein-hamachi/metadata.xml18
5 files changed, 167 insertions, 0 deletions
diff --git a/net-misc/logmein-hamachi/ChangeLog b/net-misc/logmein-hamachi/ChangeLog
new file mode 100644
index 000000000000..604f42a2d5a3
--- /dev/null
+++ b/net-misc/logmein-hamachi/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for net-misc/logmein-hamachi
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/ChangeLog,v 1.1 2011/01/15 21:13:25 hwoarang Exp $
+
+*logmein-hamachi-2.0.1.13 (15 Jan 2011)
+
+ 15 Jan 2011; Markos Chandras <hwoarang@gentoo.org>
+ +logmein-hamachi-2.0.1.13.ebuild, +files/logmein-hamachi.confd,
+ +files/logmein-hamachi.initd, +metadata.xml:
+ Initial commit of new hamachi client. Bug #350172. The original hamachi
+ client has been renamed to logmein-hamachi which is more a replacement rather
+ than a new version. Thanks to Simone Scanzoni <nonno.cicala@libero.it> for
+ the ebuilds and scripts. He will proxy maintain it. The old client will be
+ removed in 30 days
+
diff --git a/net-misc/logmein-hamachi/files/logmein-hamachi.confd b/net-misc/logmein-hamachi/files/logmein-hamachi.confd
new file mode 100644
index 000000000000..0b6aac55c987
--- /dev/null
+++ b/net-misc/logmein-hamachi/files/logmein-hamachi.confd
@@ -0,0 +1,16 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/files/logmein-hamachi.confd,v 1.1 2011/01/15 21:13:25 hwoarang Exp $
+
+# /etc/conf.d/logmein-hamachi
+# Config file for logmein-hamachi control script
+
+# Location of config, identity and log files
+CONFDIR="/var/lib/logmein-hamachi"
+
+# Your nickname
+# Set it to enable auto-login when starting the service
+NICKNAME=""
+
+# Seconds to wait before auto-login (if enabled)
+WAIT="2"
diff --git a/net-misc/logmein-hamachi/files/logmein-hamachi.initd b/net-misc/logmein-hamachi/files/logmein-hamachi.initd
new file mode 100644
index 000000000000..f62674362f26
--- /dev/null
+++ b/net-misc/logmein-hamachi/files/logmein-hamachi.initd
@@ -0,0 +1,56 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+DAEMON=/opt/logmein-hamachi/bin/hamachid
+PIDFILE=/var/run/logmein-hamachi/hamachid.pid
+
+depend() {
+ need net
+}
+
+start()
+{
+ # returns
+ # 0 if daemon has been started
+ # 1 if daemon was already running
+ # 2 if daemon could not be started
+
+ ebegin "Starting hamachi"
+
+ start-stop-daemon --quiet --start --exec "${DAEMON}" \
+ --pidfile "${PIDFILE}" -- -c "${CONFDIR}"
+ result=$?
+
+ if [ ${result} -eq 0 ] && [ -n "${NICKNAME}" ]; then
+ # it fails logging in immediately
+ sleep ${WAIT}
+ /usr/bin/hamachi login
+ if [ -z "$(/usr/bin/hamachi | grep 'logged in')" ]; then
+ start-stop-daemon --quiet --stop \
+ --exec "${DAEMON}" --pidfile "${PIDFILE}"
+ result=1
+ else
+ /usr/bin/hamachi set-nick "${NICKNAME}"
+ fi
+ fi
+
+ eend ${result}
+}
+
+stop()
+{
+ # returns
+ # 0 if daemon has been stopped
+ # 1 if daemon was already stopped
+ # 2 if daemon could not be stopped
+ # other if a failure occurred
+
+ ebegin "Stopping hamachi"
+
+ /usr/bin/hamachi logout >> /dev/null
+ start-stop-daemon --quiet --stop --exec "${DAEMON}" \
+ --pidfile "${PIDFILE}"
+
+ eend $?
+}
diff --git a/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.13.ebuild b/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.13.ebuild
new file mode 100644
index 000000000000..a6295beb3a44
--- /dev/null
+++ b/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.13.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/logmein-hamachi/logmein-hamachi-2.0.1.13.ebuild,v 1.1 2011/01/15 21:13:25 hwoarang Exp $
+
+inherit eutils linux-info
+
+DESCRIPTION="LogMeIn Hamachi VPN tunneling engine"
+HOMEPAGE="https://secure.logmein.com/products/hamachi2"
+SRC_URI="x86? ( https://secure.logmein.com/labs/${P}-x86.tgz )
+ amd64? ( https://secure.logmein.com/labs/${P}-x64.tgz )"
+
+LICENSE="LogMeIn"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+RDEPEND="!net-misc/hamachi"
+
+RESTRICT="mirror"
+
+QA_PRESTRIPPED="/opt/${PN}/bin/hamachid"
+
+pkg_setup() {
+ einfo "Checking your kernel configuration for TUN/TAP support."
+ CONFIG_CHECK="~TUN"
+ check_extra_config
+}
+
+src_unpack() {
+ unpack ${A}
+ mv ${P}-$(use x86 && echo x86 || echo x64) "${S}" || die
+}
+
+src_install() {
+ into /opt/${PN}
+ dobin hamachid dnsup dnsdown || die
+ dosym /opt/${PN}/bin/hamachid /usr/bin/hamachi || die "Couldn't create hamachi symlink"
+
+ dodir /var/run/${PN} || die
+
+ # Config and log directory
+ dodir /var/lib/${PN} || die
+
+ newconfd "${FILESDIR}"/${PN}.confd ${PN} || die
+ newinitd "${FILESDIR}"/${PN}.initd ${PN} || die
+
+ dodoc CHANGES README || die
+}
+
+pkg_postinst() {
+ elog "LogMeIn Hamachi2 is installed."
+ elog "Consult the README file on how to configure your client."
+ elog "You can run the client 'hamachi' as root,"
+ elog "or as a user if you add a line:"
+ elog "Ipc.User <login name>"
+ elog "to the file '/var/lib/${PN}/h2-engine-override.cfg'"
+ elog "and restart the daemon with"
+ elog "/etc/init.d/${PN} restart"
+ elog "To enable auto-login when the service starts set a nickname in"
+ elog "/etc/conf.d/${PN}"
+ elog "Running 'hamachi' without arguments may crash the daemon."
+}
diff --git a/net-misc/logmein-hamachi/metadata.xml b/net-misc/logmein-hamachi/metadata.xml
new file mode 100644
index 000000000000..1adabb84345b
--- /dev/null
+++ b/net-misc/logmein-hamachi/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Proxy maintainer. CC him on bugs</description>
+</maintainer>
+<maintainer>
+<email>nonno.cicala@libero.it</email>
+<name>Simone Scanzoni</name>
+<description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+