summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2007-04-30 20:34:35 +0000
committerMike Frysinger <vapier@gentoo.org>2007-04-30 20:34:35 +0000
commit3215ef354aa4ba558fcb853fca9fb136eb28293b (patch)
tree8d6b60b6e479abf800e50072209bf22ff0da337e /net-misc/iputils
parentReplacing einfo with elog (diff)
downloadgentoo-2-3215ef354aa4ba558fcb853fca9fb136eb28293b.tar.gz
gentoo-2-3215ef354aa4ba558fcb853fca9fb136eb28293b.tar.bz2
gentoo-2-3215ef354aa4ba558fcb853fca9fb136eb28293b.zip
Live git version.
(Portage version: 2.1.2.5)
Diffstat (limited to 'net-misc/iputils')
-rw-r--r--net-misc/iputils/ChangeLog7
-rw-r--r--net-misc/iputils/files/digest-iputils-99990
-rw-r--r--net-misc/iputils/iputils-9999.ebuild72
3 files changed, 78 insertions, 1 deletions
diff --git a/net-misc/iputils/ChangeLog b/net-misc/iputils/ChangeLog
index 32441376356e..af31067f8f34 100644
--- a/net-misc/iputils/ChangeLog
+++ b/net-misc/iputils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/iputils
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.53 2007/02/10 00:01:03 eroyf Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/ChangeLog,v 1.54 2007/04/30 20:34:35 vapier Exp $
+
+*iputils-9999 (30 Apr 2007)
+
+ 30 Apr 2007; Mike Frysinger <vapier@gentoo.org> +iputils-9999.ebuild:
+ Live git version.
09 Feb 2007; Alexander H. Færøy <eroyf@gentoo.org>
iputils-20060512.ebuild:
diff --git a/net-misc/iputils/files/digest-iputils-9999 b/net-misc/iputils/files/digest-iputils-9999
new file mode 100644
index 000000000000..e69de29bb2d1
--- /dev/null
+++ b/net-misc/iputils/files/digest-iputils-9999
diff --git a/net-misc/iputils/iputils-9999.ebuild b/net-misc/iputils/iputils-9999.ebuild
new file mode 100644
index 000000000000..54c2723f28a0
--- /dev/null
+++ b/net-misc/iputils/iputils-9999.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iputils/iputils-9999.ebuild,v 1.1 2007/04/30 20:34:35 vapier Exp $
+
+EGIT_REPO_URI="git://www.linux-ipv6.org/gitroot/iputils"
+inherit flag-o-matic eutils toolchain-funcs git
+
+DESCRIPTION="Network monitoring tools including ping and ping6"
+HOMEPAGE="http://www.skbuff.net/iputils/"
+SRC_URI=""
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS=""
+IUSE="static ipv6 doc"
+
+DEPEND="virtual/os-headers
+ doc? (
+ app-text/openjade
+ dev-perl/SGMLSpm
+ app-text/docbook-sgml-dtd
+ app-text/docbook-sgml-utils
+ )"
+RDEPEND=""
+
+S=${WORKDIR}/${PN}-s${PV}
+
+src_unpack() {
+ git_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/iputils-20070202-makefile.patch
+ use static && append-ldflags -static
+ use ipv6 || sed -i -e 's:IPV6_TARGETS=:#IPV6_TARGETS=:' Makefile
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "make main failed"
+
+ # We include the extra check for docbook2html
+ # because when we emerge from a stage1/stage2,
+ # it may not exist #23156
+ if use doc && type -p docbook2html ; then
+ emake -j1 html man || die
+ fi
+}
+
+src_install() {
+ into /
+ dobin ping || die "ping"
+ use ipv6 && dobin ping6
+ dosbin arping || die "arping"
+ into /usr
+ dosbin tracepath || die "tracepath"
+ use ipv6 && dosbin trace{path,route}6
+ dosbin clockdiff rarpd rdisc ipg tftpd || die "misc sbin"
+
+ fperms 4711 /bin/ping
+ use ipv6 && fperms 4711 /bin/ping6 /usr/sbin/traceroute6
+
+ dodoc INSTALL RELNOTES
+
+ if use doc ; then
+ rm -f doc/setkey.8
+ use ipv6 \
+ && dosym ping.8 /usr/share/man/man8/ping6.8 \
+ || rm -f doc/*6.8
+ doman doc/*.8
+
+ dohtml doc/*.html
+ fi
+}