summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-04 10:51:51 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-04 10:51:51 +0000
commitb314e9e887a02ac331faeb7c3c43a59fd7ead8bd (patch)
tree20f7dde17c4f3b7b01e7a1131a8679faf6e20727 /net-misc/iperf
parentbump (diff)
downloadgentoo-2-b314e9e887a02ac331faeb7c3c43a59fd7ead8bd.tar.gz
gentoo-2-b314e9e887a02ac331faeb7c3c43a59fd7ead8bd.tar.bz2
gentoo-2-b314e9e887a02ac331faeb7c3c43a59fd7ead8bd.zip
Version bump.
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-misc/iperf')
-rw-r--r--net-misc/iperf/ChangeLog7
-rw-r--r--net-misc/iperf/iperf-3.0.8.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/net-misc/iperf/ChangeLog b/net-misc/iperf/ChangeLog
index 44f31bfd60c6..23f3c41074a3 100644
--- a/net-misc/iperf/ChangeLog
+++ b/net-misc/iperf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/iperf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.59 2014/09/15 07:59:39 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/ChangeLog,v 1.60 2014/10/04 10:51:51 jer Exp $
+
+*iperf-3.0.8 (04 Oct 2014)
+
+ 04 Oct 2014; Jeroen Roovers <jer@gentoo.org> +iperf-3.0.8.ebuild:
+ Version bump.
15 Sep 2014; Jeroen Roovers <jer@gentoo.org> -files/iperf.initd:
Old.
diff --git a/net-misc/iperf/iperf-3.0.8.ebuild b/net-misc/iperf/iperf-3.0.8.ebuild
new file mode 100644
index 000000000000..8ac1925ba3d9
--- /dev/null
+++ b/net-misc/iperf/iperf-3.0.8.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/iperf/iperf-3.0.8.ebuild,v 1.1 2014/10/04 10:51:51 jer Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A TCP, UDP, and SCTP network bandwidth measurement tool"
+LICENSE="BSD"
+SLOT="3"
+HOMEPAGE="https://github.com/esnet/iperf/"
+SRC_URI="https://codeload.github.com/esnet/${PN}/tar.gz/${PV} -> ${P}.tar.gz"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~m68k-mint"
+IUSE="static-libs"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.5-flags.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}