summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThilo Bangert <bangert@gentoo.org>2002-06-17 13:53:54 +0000
committerThilo Bangert <bangert@gentoo.org>2002-06-17 13:53:54 +0000
commit368f7d50cbd8ffc78da059de022d81802cafbd53 (patch)
treeb130dea9c488139d67b6e3d61b8da12421f24d78 /net-misc/hlfl
parentversion bump - closes bug #3750 - reported by Andreas Simon (diff)
downloadgentoo-2-368f7d50cbd8ffc78da059de022d81802cafbd53.tar.gz
gentoo-2-368f7d50cbd8ffc78da059de022d81802cafbd53.tar.bz2
gentoo-2-368f7d50cbd8ffc78da059de022d81802cafbd53.zip
hlfl - High Level Firewall Language. ebuild by Arnaud Launay (sorry for the delay) - closes bug #2591
Diffstat (limited to 'net-misc/hlfl')
-rw-r--r--net-misc/hlfl/ChangeLog9
-rw-r--r--net-misc/hlfl/files/digest-hlfl-0.60.01
-rw-r--r--net-misc/hlfl/hlfl-0.60.0.ebuild37
3 files changed, 47 insertions, 0 deletions
diff --git a/net-misc/hlfl/ChangeLog b/net-misc/hlfl/ChangeLog
new file mode 100644
index 000000000000..d2b061773dff
--- /dev/null
+++ b/net-misc/hlfl/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-misc/hlfl
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/skel.ChangeLog,v 1.2 2002/02/05 00:57:47 gbevin Exp
+
+*hlfl-0.60.0 (17 Jun 2002)
+
+ 17 Jun 2002 ; Thilo Bangert <bangert@gentoo.org> :
+
+ initial commit - ebuild by Arnaud Launay <asl@launay.org> \ No newline at end of file
diff --git a/net-misc/hlfl/files/digest-hlfl-0.60.0 b/net-misc/hlfl/files/digest-hlfl-0.60.0
new file mode 100644
index 000000000000..cd26238af81d
--- /dev/null
+++ b/net-misc/hlfl/files/digest-hlfl-0.60.0
@@ -0,0 +1 @@
+MD5 2eaf897ed3028df6774d0d88bfaebaef hlfl-0.60.0.tar.gz 97503
diff --git a/net-misc/hlfl/hlfl-0.60.0.ebuild b/net-misc/hlfl/hlfl-0.60.0.ebuild
new file mode 100644
index 000000000000..0201c086fdf9
--- /dev/null
+++ b/net-misc/hlfl/hlfl-0.60.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Arnaud Launay <asl@launay.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.ebuild,v 1.5 2002/04/29 22:56:53 sandymac Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="High Level Firewall Language"
+SRC_URI="ftp://ftp.hlfl.org/pub/hlfl/${P}.tar.gz"
+HOMEPAGE="http://www.hlfl.org"
+LICENSE="GPL-2"
+
+DEPEND="virtual/glibc"
+
+src_compile() {
+
+ ./configure \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --datadir=/usr/share/doc/${P} \
+ --mandir=/usr/share/man || die "./configure failed"
+
+ emake || die
+}
+
+src_install () {
+
+ install -d ${D}/usr/bin
+ install -d ${D}/usr/man/man1
+ install -d ${D}/usr/share/doc/${P}
+ install src/hlfl ${D}/usr/bin
+ install doc/hlfl.1 ${D}/usr/man/man1
+ install doc/services.hlfl ${D}/usr/share/doc/${P}
+
+ dodoc AUTHORS COPYING ChangeLog INSTALL NEWS README THANKS \
+ TODO doc/RoadMap doc/sample_1.hlfl doc/sample_2.hlfl \
+ doc/test.hlfl doc/syntax.txt
+}