summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2014-01-05 22:20:59 +0000
committerLars Wendler <polynomial-c@gentoo.org>2014-01-05 22:20:59 +0000
commit5a21bcab7f54915fdc2f282bb1484c6e3d993496 (patch)
tree982ff56b5e54d427f949786652368101938f3a25 /net-misc/fatrat
parentEAPI bump (diff)
downloadgentoo-2-5a21bcab7f54915fdc2f282bb1484c6e3d993496.tar.gz
gentoo-2-5a21bcab7f54915fdc2f282bb1484c6e3d993496.tar.bz2
gentoo-2-5a21bcab7f54915fdc2f282bb1484c6e3d993496.zip
Added upstream patch for missing linking against libcrypto (bug #496808)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0x981CA6FC)
Diffstat (limited to 'net-misc/fatrat')
-rw-r--r--net-misc/fatrat/ChangeLog9
-rw-r--r--net-misc/fatrat/fatrat-1.2.0_beta2.ebuild9
-rw-r--r--net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch13
3 files changed, 26 insertions, 5 deletions
diff --git a/net-misc/fatrat/ChangeLog b/net-misc/fatrat/ChangeLog
index d28443888100..da8eeaac1cce 100644
--- a/net-misc/fatrat/ChangeLog
+++ b/net-misc/fatrat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-misc/fatrat
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/fatrat/ChangeLog,v 1.3 2013/09/08 10:25:58 polynomial-c Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fatrat/ChangeLog,v 1.4 2014/01/05 22:20:59 polynomial-c Exp $
+
+ 05 Jan 2014; Lars Wendler <polynomial-c@gentoo.org>
+ fatrat-1.2.0_beta2.ebuild, +files/fatrat-1.2.0_beta2-libcrypto_linking.patch:
+ Added upstream patch for missing linking against libcrypto. Thanks to Bob Wya
+ for reporting this problem in bug #496808.
08 Sep 2013; Lars Wendler <polynomial-c@gentoo.org>
fatrat-1.2.0_beta2.ebuild:
diff --git a/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
index 8c7be4e78b22..7c7004e60f87 100644
--- a/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
+++ b/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild,v 1.3 2013/09/08 10:25:58 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/fatrat/fatrat-1.2.0_beta2.ebuild,v 1.4 2014/01/05 22:20:59 polynomial-c Exp $
EAPI=5
@@ -27,7 +27,10 @@ RDEPEND="dev-qt/qtgui:4
DEPEND="${RDEPEND}
nls? ( sys-devel/gettext )"
-PATCHES=( "${FILESDIR}/${P}-build.patch" )
+PATCHES=(
+ "${FILESDIR}/${P}-build.patch"
+ "${FILESDIR}/${P}-libcrypto_linking.patch"
+)
src_configure() {
local mycmakeargs="
diff --git a/net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch b/net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch
new file mode 100644
index 000000000000..07e1193d4551
--- /dev/null
+++ b/net-misc/fatrat/files/fatrat-1.2.0_beta2-libcrypto_linking.patch
@@ -0,0 +1,13 @@
+http://git.dolezel.info/?p=fatrat.git;a=commitdiff_plain;h=c799fb1ee91c1affb05aabd580e3c0d59b2223d2
+
+--- fatrat-1.2.0_beta2/CMakeLists.txt
++++ fatrat-1.2.0_beta2/CMakeLists.txt
+@@ -572,7 +572,7 @@
+ # This used to be a workaround until it started causing the exact opposite... oh dear!
+ #STRING(REPLACE "-mt" "" pion-net_LIBRARIES "${pion-net_LIBRARIES}")
+ #message(STATUS ${pion-net_LIBRARIES})
+-target_link_libraries(fatrat -ldl -lpthread ${QT_LIBRARIES} ${libtorrent_LDFLAGS} ${gloox_LDFLAGS} ${curl_LDFLAGS} ${Boost_LIBRARIES} ${pion-net_LIBRARIES} ${QT_ADDITIONAL_LIBS} ${XATTR_LIBRARIES} -export-dynamic)
++target_link_libraries(fatrat -ldl -lpthread ${QT_LIBRARIES} ${libtorrent_LDFLAGS} ${gloox_LDFLAGS} ${curl_LDFLAGS} ${Boost_LIBRARIES} ${pion-net_LIBRARIES} ${QT_ADDITIONAL_LIBS} ${XATTR_LIBRARIES} crypto -export-dynamic)
+ target_link_libraries(fatrat-conf ${QT_LIBRARIES})
+
+ set(fatrat_DEV_HEADERS