summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-01-28 07:53:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-01-28 07:53:33 +0000
commit20e70b451183b3fdc7b5a3ba35fdb8c29a79752c (patch)
tree3221741393e609c279122463a1a5380aba19a8c7 /net-misc/elliptics-eblob
parentLastrite x11-misc/mkxf86config wrt #220121 (diff)
downloadgentoo-2-20e70b451183b3fdc7b5a3ba35fdb8c29a79752c.tar.gz
gentoo-2-20e70b451183b3fdc7b5a3ba35fdb8c29a79752c.tar.bz2
gentoo-2-20e70b451183b3fdc7b5a3ba35fdb8c29a79752c.zip
Bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-misc/elliptics-eblob')
-rw-r--r--net-misc/elliptics-eblob/ChangeLog10
-rw-r--r--net-misc/elliptics-eblob/elliptics-eblob-0.18.0.ebuild41
2 files changed, 49 insertions, 2 deletions
diff --git a/net-misc/elliptics-eblob/ChangeLog b/net-misc/elliptics-eblob/ChangeLog
index 18cdfbadafec..1f4e9c9b7c1f 100644
--- a/net-misc/elliptics-eblob/ChangeLog
+++ b/net-misc/elliptics-eblob/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-misc/elliptics-eblob
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/elliptics-eblob/ChangeLog,v 1.2 2012/10/24 09:38:19 patrick Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/elliptics-eblob/ChangeLog,v 1.3 2013/01/28 07:53:33 patrick Exp $
+
+*elliptics-eblob-0.18.0 (28 Jan 2013)
+
+ 28 Jan 2013; Patrick Lauer <patrick@gentoo.org>
+ +elliptics-eblob-0.18.0.ebuild:
+ Bump
24 Oct 2012; Patrick Lauer <patrick@gentoo.org> elliptics-eblob-0.0.1.ebuild:
Fixing header
diff --git a/net-misc/elliptics-eblob/elliptics-eblob-0.18.0.ebuild b/net-misc/elliptics-eblob/elliptics-eblob-0.18.0.ebuild
new file mode 100644
index 000000000000..3b0d98def7fc
--- /dev/null
+++ b/net-misc/elliptics-eblob/elliptics-eblob-0.18.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/elliptics-eblob/elliptics-eblob-0.18.0.ebuild,v 1.1 2013/01/28 07:53:33 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT="python2_7"
+
+inherit eutils python-single-r1 flag-o-matic cmake-utils
+
+DESCRIPTION="The elliptics network - eblob backend"
+HOMEPAGE="http://www.ioremap.net/projects/elliptics"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="python"
+RDEPEND="
+ app-arch/snappy
+ dev-libs/openssl
+ dev-libs/boost[python]"
+DEPEND="${RDEPEND}"
+
+MY_PN="eblob"
+SRC_URI="http://dev.gentoo.org/~patrick/${MY_PN}-${PV}.tar.bz2"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+
+src_configure(){
+ # 'checking trying to link with boost::python... no' due '-Wl,--as-needed'
+ use python && filter-ldflags -Wl,--as-needed
+ cmake-utils_src_configure
+}
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_install() {
+ cmake-utils_src_install
+ mkdir -p "${D}/$(python_get_sitedir)"
+ cp bindings/python/python/eblob.py "${D}/$(python_get_sitedir)" || die "Fail"
+}