summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2009-12-02 18:45:27 +0000
committerTony Vroon <chainsaw@gentoo.org>2009-12-02 18:45:27 +0000
commit4f0a823cd8871a3288f8d3816f6f60cd7e88dcaa (patch)
treeb9db68061ff9092048ee555dcaa2065151c963d3 /net-misc/asterisk-addons
parentUse PN instead of package name in SRC_URI. (diff)
downloadgentoo-2-4f0a823cd8871a3288f8d3816f6f60cd7e88dcaa.tar.gz
gentoo-2-4f0a823cd8871a3288f8d3816f6f60cd7e88dcaa.tar.bz2
gentoo-2-4f0a823cd8871a3288f8d3816f6f60cd7e88dcaa.zip
Version bump. Robustness fixes for the MP3 support, the MySQL module has also recieved some love.
(Portage version: 2.1.7.9/cvs/Linux x86_64)
Diffstat (limited to 'net-misc/asterisk-addons')
-rw-r--r--net-misc/asterisk-addons/ChangeLog10
-rw-r--r--net-misc/asterisk-addons/asterisk-addons-1.6.1.2.ebuild44
-rw-r--r--net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-parallel-make.diff62
-rw-r--r--net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-uclibc.diff55
4 files changed, 170 insertions, 1 deletions
diff --git a/net-misc/asterisk-addons/ChangeLog b/net-misc/asterisk-addons/ChangeLog
index 9a674a114391..bbb24f60a2f5 100644
--- a/net-misc/asterisk-addons/ChangeLog
+++ b/net-misc/asterisk-addons/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-misc/asterisk-addons
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/ChangeLog,v 1.16 2009/09/11 16:39:52 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/ChangeLog,v 1.17 2009/12/02 18:45:27 chainsaw Exp $
+
+*asterisk-addons-1.6.1.2 (02 Dec 2009)
+
+ 02 Dec 2009; <chainsaw@gentoo.org> +asterisk-addons-1.6.1.2.ebuild,
+ +files/asterisk-addons-1.6.1.2-parallel-make.diff,
+ +files/asterisk-addons-1.6.1.2-uclibc.diff:
+ Version bump. Robustness fixes for the MP3 support, the MySQL module has
+ also recieved some love.
*asterisk-addons-1.6.1.1 (11 Sep 2009)
diff --git a/net-misc/asterisk-addons/asterisk-addons-1.6.1.2.ebuild b/net-misc/asterisk-addons/asterisk-addons-1.6.1.2.ebuild
new file mode 100644
index 000000000000..fb0568a12eed
--- /dev/null
+++ b/net-misc/asterisk-addons/asterisk-addons-1.6.1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/asterisk-addons/asterisk-addons-1.6.1.2.ebuild,v 1.1 2009/12/02 18:45:27 chainsaw Exp $
+
+inherit eutils
+
+DESCRIPTION="Asterisk: A Modular Open Source PBX System"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.digium.com/pub/asterisk/releases/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="bluetooth elibc_uclibc mysql"
+
+RDEPEND=">=net-misc/asterisk-1.6.1.11"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-parallel-make.diff"
+
+ # forward-ported patch from jaervosz for uclibc
+ if use elibc_uclibc; then
+ epatch "${FILESDIR}/${P}-uclibc.diff"
+ fi
+}
+
+src_compile() {
+ econf \
+ --libdir="/usr/$(get_libdir)" \
+ --localstatedir="/var" \
+ $(use_with bluetooth) \
+ $(use_with mysql mysqlclient) \
+ || die "Failed to configure"
+
+ emake || die "Failed to compile"
+}
+
+src_install() {
+ dodoc configs/*
+ emake DESTDIR="${D}" install || die "Failed to install"
+}
diff --git a/net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-parallel-make.diff b/net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-parallel-make.diff
new file mode 100644
index 000000000000..d93bc257e9c4
--- /dev/null
+++ b/net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-parallel-make.diff
@@ -0,0 +1,62 @@
+diff -uNr asterisk-addons-1.6.1.2.ORIG/Makefile asterisk-addons-1.6.1.2/Makefile
+--- asterisk-addons-1.6.1.2.ORIG/Makefile 2009-12-02 18:32:26.000000000 +0000
++++ asterisk-addons-1.6.1.2/Makefile 2009-12-02 18:33:00.000000000 +0000
+@@ -136,8 +136,8 @@
+ @echo "EMBED_LIBS+="`$(SILENTMAKE) -C $(@:-embed-libs=) SUBDIR=$(@:-embed-libs=) __embed_libs` >> makeopts.embed_rules
+
+ $(MOD_SUBDIRS_MENUSELECT_TREE):
+- @$(SUBMAKE) -C $(@:-menuselect-tree=) SUBDIR=$(@:-menuselect-tree=) moduleinfo
+- @$(SUBMAKE) -C $(@:-menuselect-tree=) SUBDIR=$(@:-menuselect-tree=) makeopts
++ +@$(SUBMAKE) -C $(@:-menuselect-tree=) SUBDIR=$(@:-menuselect-tree=) moduleinfo
++ +@$(SUBMAKE) -C $(@:-menuselect-tree=) SUBDIR=$(@:-menuselect-tree=) makeopts
+
+ makeopts.embed_rules: menuselect.makeopts
+ @echo "Generating embedded module rules ..."
+@@ -149,10 +149,10 @@
+ $(SUBDIRS): makeopts.embed_rules
+
+ $(MOD_SUBDIRS):
+- @ASTCFLAGS="$(MOD_SUBDIR_CFLAGS) $(ASTCFLAGS)" ASTLDFLAGS="$(ASTLDFLAGS)" $(MAKE) $(PRINT_DIR) --no-builtin-rules -C $@ SUBDIR=$@ all
++ +@ASTCFLAGS="$(MOD_SUBDIR_CFLAGS) $(ASTCFLAGS)" ASTLDFLAGS="$(ASTLDFLAGS)" $(MAKE) $(PRINT_DIR) --no-builtin-rules -C $@ SUBDIR=$@ all
+
+ $(OTHER_SUBDIRS):
+- @ASTCFLAGS="$(OTHER_SUBDIR_CFLAGS) $(ASTCFLAGS)" ASTLDFLAGS="$(ASTLDFLAGS)" $(MAKE) $(PRINT_DIR) --no-builtin-rules -C $@ SUBDIR=$@ all
++ +@ASTCFLAGS="$(OTHER_SUBDIR_CFLAGS) $(ASTCFLAGS)" ASTLDFLAGS="$(ASTLDFLAGS)" $(MAKE) $(PRINT_DIR) --no-builtin-rules -C $@ SUBDIR=$@ all
+
+ config.status: configure
+ @./configure
+@@ -269,27 +269,27 @@
+ MAKE_MENUSELECT=CC="$(HOST_CC)" CXX="$(CXX)" LD="" AR="" RANLIB="" CFLAGS="" $(MAKE) -C menuselect CONFIGURE_SILENT="--silent"
+
+ menuselect/menuselect: menuselect/makeopts
+- $(MAKE_MENUSELECT) menuselect
++ +$(MAKE_MENUSELECT) menuselect
+
+ menuselect/cmenuselect: menuselect/makeopts
+- $(MAKE_MENUSELECT) cmenuselect
++ +$(MAKE_MENUSELECT) cmenuselect
+
+ menuselect/gmenuselect: menuselect/makeopts
+- $(MAKE_MENUSELECT) gmenuselect
++ +$(MAKE_MENUSELECT) gmenuselect
+
+ menuselect/nmenuselect: menuselect/makeopts
+- $(MAKE_MENUSELECT) nmenuselect
++ +$(MAKE_MENUSELECT) nmenuselect
+
+ menuselect/makeopts: makeopts
+- $(MAKE_MENUSELECT) makeopts
++ +$(MAKE_MENUSELECT) makeopts
+
+ menuselect-tree: $(foreach dir,$(filter-out main,$(MOD_SUBDIRS)),$(wildcard $(dir)/*.c) $(wildcard $(dir)/*.cc)) configure
+ @echo "Generating input for menuselect ..."
+ @echo "<?xml version=\"1.0\"?>" > $@
+ @echo >> $@
+ @echo "<menu name=\"Asterisk-addons Module Selection\">" >> $@
+- @for dir in $(sort $(filter-out main,$(MOD_SUBDIRS))); do $(SUBMAKE) -C $${dir} SUBDIR=$${dir} moduleinfo >> $@; done
+- @for dir in $(sort $(filter-out main,$(MOD_SUBDIRS))); do $(SUBMAKE) -C $${dir} SUBDIR=$${dir} makeopts >> $@; done
++ +@for dir in $(sort $(filter-out main,$(MOD_SUBDIRS))); do $(SUBMAKE) -C $${dir} SUBDIR=$${dir} moduleinfo >> $@; done
++ +@for dir in $(sort $(filter-out main,$(MOD_SUBDIRS))); do $(SUBMAKE) -C $${dir} SUBDIR=$${dir} makeopts >> $@; done
+ @echo "</menu>" >> $@
+
+ .PHONY: menuselect clean dist-clean distclean all cleantest uninstall _uninstall uninstall-all dont-optimize $(SUBDIRS_INSTALL) $(SUBDIRS_DIST_CLEAN) $(SUBDIRS_CLEAN) $(SUBDIRS_UNINSTALL) $(SUBDIRS) $(MOD_SUBDIRS_EMBED_LDSCRIPT) $(MOD_SUBDIRS_EMBED_LDFLAGS) $(MOD_SUBDIRS_EMBED_LIBS)
diff --git a/net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-uclibc.diff b/net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-uclibc.diff
new file mode 100644
index 000000000000..205aba701b61
--- /dev/null
+++ b/net-misc/asterisk-addons/files/asterisk-addons-1.6.1.2-uclibc.diff
@@ -0,0 +1,55 @@
+diff -uNr asterisk-addons-1.6.1.2.ORIG/cdr/cdr_addon_mysql.c asterisk-addons-1.6.1.2/cdr/cdr_addon_mysql.c
+--- asterisk-addons-1.6.1.2.ORIG/cdr/cdr_addon_mysql.c 2009-12-02 18:35:01.000000000 +0000
++++ asterisk-addons-1.6.1.2/cdr/cdr_addon_mysql.c 2009-12-02 18:36:00.000000000 +0000
+@@ -29,6 +29,13 @@
+
+ #include <asterisk.h>
+
++#include <stdio.h>
++#include <string.h>
++
++#include <stdlib.h>
++#include <unistd.h>
++#include <time.h>
++
+ #include <sys/types.h>
+ #include <asterisk/config.h>
+ #include <asterisk/options.h>
+@@ -40,13 +47,6 @@
+ #include <asterisk/strings.h>
+ #include <asterisk/linkedlists.h>
+
+-#include <stdio.h>
+-#include <string.h>
+-
+-#include <stdlib.h>
+-#include <unistd.h>
+-#include <time.h>
+-
+ #include <mysql/mysql.h>
+ #include <mysql/errmsg.h>
+
+diff -uNr asterisk-addons-1.6.1.2.ORIG/res/res_config_mysql.c asterisk-addons-1.6.1.2/res/res_config_mysql.c
+--- asterisk-addons-1.6.1.2.ORIG/res/res_config_mysql.c 2009-12-02 18:35:01.000000000 +0000
++++ asterisk-addons-1.6.1.2/res/res_config_mysql.c 2009-12-02 18:36:00.000000000 +0000
+@@ -44,6 +44,9 @@
+
+ #include <asterisk.h>
+
++#include <stdlib.h>
++#include <stdio.h>
++#include <string.h>
+ #include <asterisk/channel.h>
+ #include <asterisk/logger.h>
+ #include <asterisk/config.h>
+@@ -53,10 +56,6 @@
+ #include <asterisk/cli.h>
+ #include <asterisk/utils.h>
+ #include <asterisk/threadstorage.h>
+-#include <stdlib.h>
+-#include <stdio.h>
+-#include <string.h>
+-#include <stdio.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>