summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2005-01-07 12:03:11 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2005-01-07 12:03:11 +0000
commite9cbd224e10feed9255b121e98c1789e052acfe4 (patch)
treeaaa345b46dbf4f78159a00506a792f876f2c4a6c /net-misc/adjtimex
parent4.1.3-r2 Stable on x86. (Manifest recommit) (diff)
downloadgentoo-2-e9cbd224e10feed9255b121e98c1789e052acfe4.tar.gz
gentoo-2-e9cbd224e10feed9255b121e98c1789e052acfe4.tar.bz2
gentoo-2-e9cbd224e10feed9255b121e98c1789e052acfe4.zip
bug #70342, patch by solar for hardened to work right.
Diffstat (limited to 'net-misc/adjtimex')
-rw-r--r--net-misc/adjtimex/ChangeLog8
-rw-r--r--net-misc/adjtimex/adjtimex-1.16-r1.ebuild5
-rw-r--r--net-misc/adjtimex/adjtimex-1.16.ebuild4
-rw-r--r--net-misc/adjtimex/files/adjtimex-1.16-pic.patch14
4 files changed, 25 insertions, 6 deletions
diff --git a/net-misc/adjtimex/ChangeLog b/net-misc/adjtimex/ChangeLog
index 13bf5952d466..765fc2f1c0b6 100644
--- a/net-misc/adjtimex/ChangeLog
+++ b/net-misc/adjtimex/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-misc/adjtimex
-# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.7 2004/12/05 16:10:47 kloeri Exp $
+# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/ChangeLog,v 1.8 2005/01/07 12:03:11 robbat2 Exp $
+
+ 07 Jan 2005; Robin H. Johnson <robbat2@gentoo.org>
+ +files/adjtimex-1.16-pic.patch:
+ bug #70342, patch by solar for hardened to work right.
05 Dec 2004; Bryan Østergaard <kloeri@gentoo.org>
adjtimex-1.16-r1.ebuild:
diff --git a/net-misc/adjtimex/adjtimex-1.16-r1.ebuild b/net-misc/adjtimex/adjtimex-1.16-r1.ebuild
index 8717a30346c0..5ff089633795 100644
--- a/net-misc/adjtimex/adjtimex-1.16-r1.ebuild
+++ b/net-misc/adjtimex/adjtimex-1.16-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.16-r1.ebuild,v 1.4 2004/12/05 16:10:47 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.16-r1.ebuild,v 1.5 2005/01/07 12:03:11 robbat2 Exp $
inherit fixheadtails eutils
@@ -32,6 +32,7 @@ src_unpack() {
done
ht_fix_file debian/adjtimexconfig
sed -e '/CFLAGS = -Wall -t/,/endif/d' -i Makefile.in
+ epatch ${FILESDIR}/${PN}-1.16-pic.patch
}
src_install() {
diff --git a/net-misc/adjtimex/adjtimex-1.16.ebuild b/net-misc/adjtimex/adjtimex-1.16.ebuild
index 2e881f0f09f6..a5331c67b348 100644
--- a/net-misc/adjtimex/adjtimex-1.16.ebuild
+++ b/net-misc/adjtimex/adjtimex-1.16.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.16.ebuild,v 1.6 2004/09/09 15:27:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/adjtimex/adjtimex-1.16.ebuild,v 1.7 2005/01/07 12:03:11 robbat2 Exp $
inherit fixheadtails eutils
diff --git a/net-misc/adjtimex/files/adjtimex-1.16-pic.patch b/net-misc/adjtimex/files/adjtimex-1.16-pic.patch
new file mode 100644
index 000000000000..320355edd25a
--- /dev/null
+++ b/net-misc/adjtimex/files/adjtimex-1.16-pic.patch
@@ -0,0 +1,14 @@
+--- adjtimex.c.orig 2003-08-24 20:10:05.000000000 -0400
++++ adjtimex.c 2004-11-16 09:04:53.000000000 -0500
+@@ -40,9 +40,11 @@
+ #ifdef __ia64__
+ extern int adjtimex(struct timex *);
+ #else
++#ifndef __PIC__
+ _syscall1(int, adjtimex, struct timex *, txcp)
+ #endif
+ #endif
++#endif
+ int F_print = 0;
+
+ #ifndef LOG_PATH