summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2007-09-13 21:59:22 +0000
committerHanno Böck <hanno@gentoo.org>2007-09-13 21:59:22 +0000
commite96c6107c3aacba5f10bfdf5bdf07c761c80e50d (patch)
tree8d6342afa4d4078f371a5e33ae7159c38fbfe1ea /net-mail
parentStable on sparc wrt bug #189066 (diff)
downloadgentoo-2-e96c6107c3aacba5f10bfdf5bdf07c761c80e50d.tar.gz
gentoo-2-e96c6107c3aacba5f10bfdf5bdf07c761c80e50d.tar.bz2
gentoo-2-e96c6107c3aacba5f10bfdf5bdf07c761c80e50d.zip
mailman installdir support
(Portage version: 2.1.3.9)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailman/ChangeLog7
-rw-r--r--net-mail/mailman/files/digest-mailman-2.1.9-r13
-rw-r--r--net-mail/mailman/mailman-2.1.9-r1.ebuild129
3 files changed, 138 insertions, 1 deletions
diff --git a/net-mail/mailman/ChangeLog b/net-mail/mailman/ChangeLog
index c67218ac326c..919dc7dba4c2 100644
--- a/net-mail/mailman/ChangeLog
+++ b/net-mail/mailman/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/mailman
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.96 2007/09/13 20:33:41 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/ChangeLog,v 1.97 2007/09/13 21:59:22 hanno Exp $
+
+*mailman-2.1.9-r1 (13 Sep 2007)
+
+ 13 Sep 2007; Hanno Boeck <hanno@gentoo.org> +mailman-2.1.9-r1.ebuild:
+ Make customized installation paths possible, with great help from hansmi.
13 Sep 2007; Michael Hanselmann <hansmi@gentoo.org>
-mailman-2.1.9_rc1.ebuild:
diff --git a/net-mail/mailman/files/digest-mailman-2.1.9-r1 b/net-mail/mailman/files/digest-mailman-2.1.9-r1
new file mode 100644
index 000000000000..27cb65ef538f
--- /dev/null
+++ b/net-mail/mailman/files/digest-mailman-2.1.9-r1
@@ -0,0 +1,3 @@
+MD5 dd51472470f9eafb04f64da372444835 mailman-2.1.9.tgz 7829201
+RMD160 135f94eeecca1f562f98dfe98c1a367bed229372 mailman-2.1.9.tgz 7829201
+SHA256 1b7a2c853c21bfd22205167dc3678c634a3f981721d95d1cd923ca84967cc986 mailman-2.1.9.tgz 7829201
diff --git a/net-mail/mailman/mailman-2.1.9-r1.ebuild b/net-mail/mailman/mailman-2.1.9-r1.ebuild
new file mode 100644
index 000000000000..b88c95609392
--- /dev/null
+++ b/net-mail/mailman/mailman-2.1.9-r1.ebuild
@@ -0,0 +1,129 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailman/mailman-2.1.9-r1.ebuild,v 1.1 2007/09/13 21:59:22 hanno Exp $
+
+inherit eutils depend.apache
+IUSE="postfix sendmail qmail courier exim xmail"
+
+DESCRIPTION="A python-based mailing list server with an extensive web interface"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
+HOMEPAGE="http://www.list.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3
+ virtual/mta
+ virtual/cron
+ || ( www-servers/apache www-servers/lighttpd )"
+
+INSTALLDIR="/usr/local/mailman"
+APACHEGID="81"
+
+if use postfix; then
+ MAILGID="280"
+elif use sendmail; then
+ MAILGID=daemon
+elif use qmail; then
+ MAILGID="280"
+elif use courier; then
+ MAILGID=mail
+elif use exim; then
+ MAILGID=mail
+elif use xmail; then
+ MAILGID=xmail
+else
+ MAILGID="280"
+fi
+
+pkg_setup() {
+ # Bug #58526: switch to enew{group,user}.
+ # need to add mailman here for compile process.
+ # Duplicated at pkg_postinst() for binary install.
+ enewgroup mailman 280
+ enewuser mailman 280 /bin/bash ${INSTALLDIR} mailman -G cron -c mailman
+ mkdir -p ${INSTALLDIR}
+ chown mailman:mailman ${INSTALLDIR}
+ chmod 2775 ${INSTALLDIR}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-2.1.8_rc1-directory-check.patch || die "patch failed."
+}
+
+src_compile() {
+ econf \
+ --prefix=${INSTALLDIR} \
+ --with-mail-gid=${MAILGID} \
+ --with-cgi-gid=${APACHEGID} \
+ || die "configure failed"
+
+ make || die "make failed"
+}
+
+src_install () {
+ ID=${D}${INSTALLDIR}
+
+ make prefix=${ID} var_prefix=${ID} doinstall || die
+
+ keepdir ${INSTALLDIR}/logs
+ keepdir ${INSTALLDIR}/locks
+ keepdir ${INSTALLDIR}/spam
+ keepdir ${INSTALLDIR}/archives/public
+ keepdir ${INSTALLDIR}/archives/private
+ keepdir ${INSTALLDIR}/lists
+ keepdir ${INSTALLDIR}/qfiles
+
+ insinto ${APACHE2_MODULES_CONFDIR}
+ doins ${FILESDIR}/50_mailman.conf
+
+ dodoc ${FILESDIR}/README.gentoo
+ dodoc ACK* BUGS FAQ NEWS README* TODO UPGRADING INSTALL
+ dodoc contrib/README.check_perms_grsecurity contrib/mm-handler.readme
+ dodoc contrib/virtusertable contrib/mailman.mc
+
+ cp build/contrib/*.py contrib/majordomo2mailman.pl contrib/auto \
+ contrib/mm-handler* ${ID}/bin
+
+ # Save the old config into the new package as CONFIG_PROTECT
+ # doesn't work for this package.
+ for i in ${ROOT}/var/mailman ${ROOT}/home/mailman \
+ ${ROOT}/usr/local/mailman ${INSTALLDIR}
+ do
+ if [ -f ${i}/Mailman/mm_cfg.py ]; then
+ cp ${i}/Mailman/mm_cfg.py \
+ ${ID}/Mailman/mm_cfg.py
+ elog "Your old config has been saved as mm_cfg.py"
+ elog "A new config has been installed as mm_cfg.dist"
+ fi
+ done
+
+ newinitd ${FILESDIR}/mailman.rc mailman
+
+ chown -R mailman:mailman ${ID}
+ chmod 2775 ${ID}
+}
+
+pkg_postinst() {
+ enewgroup mailman 280
+ enewuser mailman 280 -1 ${INSTALLDIR} mailman -G cron -c "mailman"
+ cd ${INSTALLDIR}
+ bin/update
+ elog "Running \`${INSTALLDIR}/bin/check_perms -f\` *"
+ bin/check_perms -f
+ elog
+ elog "Please read /usr/share/doc/${PF}/README.gentoo.gz for additional"
+ elog "Setup information, mailman will NOT run unless you follow"
+ elog "those instructions!"
+ elog
+
+ elog "An example Mailman configuration file for Apache has been installed into:"
+ elog " ${APACHE2_MODULES_CONFDIR}/50_mailman.conf"
+ elog
+ elog "To enable, you will need to add \"-D MAILMAN\" to"
+ elog "/etc/conf.d/apache2."
+ elog
+}