summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-09-27 09:41:48 +0000
committerTorsten Veller <tove@gentoo.org>2008-09-27 09:41:48 +0000
commitdf44c51c6e22e8545f6039ac62431c359cf3c2da (patch)
treeb8e08acbbb365295799b3638b7bc0bd27fd90576 /net-mail
parentSort the list of Makefile.am and Makefile.in files used in gnome2_omf_fix(), ... (diff)
downloadgentoo-2-df44c51c6e22e8545f6039ac62431c359cf3c2da.tar.gz
gentoo-2-df44c51c6e22e8545f6039ac62431c359cf3c2da.tar.bz2
gentoo-2-df44c51c6e22e8545f6039ac62431c359cf3c2da.zip
Version bump
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/getmail/ChangeLog7
-rw-r--r--net-mail/getmail/getmail-4.8.4.ebuild65
2 files changed, 71 insertions, 1 deletions
diff --git a/net-mail/getmail/ChangeLog b/net-mail/getmail/ChangeLog
index 17fbd0a7ea85..89474ecbd367 100644
--- a/net-mail/getmail/ChangeLog
+++ b/net-mail/getmail/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/getmail
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.159 2008/03/28 06:12:11 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/ChangeLog,v 1.160 2008/09/27 09:41:48 tove Exp $
+
+*getmail-4.8.4 (27 Sep 2008)
+
+ 27 Sep 2008; Torsten Veller <tove@gentoo.org> +getmail-4.8.4.ebuild:
+ Version bump
*getmail-4.8.1 (28 Mar 2008)
diff --git a/net-mail/getmail/getmail-4.8.4.ebuild b/net-mail/getmail/getmail-4.8.4.ebuild
new file mode 100644
index 000000000000..10d7e86f8090
--- /dev/null
+++ b/net-mail/getmail/getmail-4.8.4.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/getmail/getmail-4.8.4.ebuild,v 1.1 2008/09/27 09:41:48 tove Exp $
+
+inherit distutils
+
+IUSE=""
+DESCRIPTION="A POP3 mail retriever with reliable Maildir and mbox delivery"
+HOMEPAGE="http://pyropus.ca/software/getmail/"
+SRC_URI="http://pyropus.ca/software/getmail/old-versions/${P}.tar.gz"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+
+DEPEND=">=dev-lang/python-2.3.3"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # getmail.spec is missing due to upstream packaging mistake
+ sed -i -e '/getmail.spec/d' setup.py
+}
+
+src_compile() {
+ distutils_src_compile
+}
+
+src_install() {
+ distutils_src_install
+
+ if has_version "=net-mail/getmail-3*" ; then
+ mv "${D}"/usr/bin/getmail "${D}"/usr/bin/getmail4
+ mv "${D}"/usr/bin/getmail_maildir "${D}"/usr/bin/getmail_maildir4
+ mv "${D}"/usr/bin/getmail_mbox "${D}"/usr/bin/getmail_mbox4
+ fi
+
+ # handle docs the gentoo way
+ rm "${D}"/usr/share/doc/${P}/COPYING
+ if [ ${P} != ${PF} ]; then
+ mv "${D}"/usr/share/doc/${P} "${D}"/usr/share/doc/${PF}
+ fi
+
+ dodir /usr/share/doc/${PF}/html
+ mv "${D}"/usr/share/doc/${PF}/*.html "${D}"/usr/share/doc/${PF}/*.css "${D}"/usr/share/doc/${PF}/html
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/lib/python${PYVER}/site-packages/getmailcore
+
+ if has_version "=net-mail/getmail-3*" ; then
+ echo
+ ewarn "An already installed instance of getmail v3 was detected. In order to"
+ ewarn "co-exist with it the three main scripts of getmail v4 were renamed to"
+ ewarn "getmail4, getmail_maildir4, getmail_mbox4."
+ echo
+ fi
+}
+
+pkg_postrm() {
+ python_version
+ python_mod_cleanup
+}