summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEray Aslan <eras@gentoo.org>2011-03-28 11:44:33 +0000
committerEray Aslan <eras@gentoo.org>2011-03-28 11:44:33 +0000
commitc8212669c378a5e2cbe4f70569ef297fd954ae41 (patch)
tree0af3f001f578a39d66d8361032db2f229da0a208 /net-mail
parentSet QT_MINIMAL=4.7 per bug #360373. (diff)
downloadgentoo-2-c8212669c378a5e2cbe4f70569ef297fd954ae41.tar.gz
gentoo-2-c8212669c378a5e2cbe4f70569ef297fd954ae41.tar.bz2
gentoo-2-c8212669c378a5e2cbe4f70569ef297fd954ae41.zip
remove mailwrapper support - bug 158003
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/mailutils/mailutils-0.6-r3.ebuild21
1 files changed, 3 insertions, 18 deletions
diff --git a/net-mail/mailutils/mailutils-0.6-r3.ebuild b/net-mail/mailutils/mailutils-0.6-r3.ebuild
index c74c8ae2c841..8ddeed453cd1 100644
--- a/net-mail/mailutils/mailutils-0.6-r3.ebuild
+++ b/net-mail/mailutils/mailutils-0.6-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-0.6-r3.ebuild,v 1.13 2011/03/20 13:12:20 eras Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mailutils/mailutils-0.6-r3.ebuild,v 1.14 2011/03/28 11:44:33 eras Exp $
inherit eutils
@@ -11,7 +11,7 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="0"
KEYWORDS="alpha ~amd64 ~ppc ~sparc x86"
-IUSE="mailwrapper nls pam mysql postgres gdbm test"
+IUSE="nls pam mysql postgres gdbm test"
RDEPEND="!mail-client/nmh
!mail-filter/libsieve
@@ -75,22 +75,7 @@ src_compile() {
myconf="${myconf} --with-postgres"
fi
- # do not disable-sendmail for postfix user w/o mailwrapper, bug #44249.
- has_postfix=$(best_version mail-mta/postfix)
- has_postfix=${has_postfix%-[0-9]*}
- has_postfix=${has_postfix##*\/}
-
- if [ "$has_postfix" == "postfix" ]; then
- einfo "postfix detected"
- einfo "enable-sendmail"
- else
- if ! use mailwrapper; then
- myconf="${myconf} --enable-sendmail"
- else
- myconf="${myconf} --disable-sendmail"
- einfo "disable-sendmail"
- fi
- fi
+ myconf="${myconf} --enable-sendmail"
myconf="${myconf} $(use_enable nls) $(use_enable pam) $(use_enable gdbm)"
econf ${myconf} || die "configure failed"