summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruce A. Locke <blocke@gentoo.org>2001-07-31 19:59:24 +0000
committerBruce A. Locke <blocke@gentoo.org>2001-07-31 19:59:24 +0000
commitb637a1c1a00ef1b6f5fb6c7f5aad20cb2d908d4a (patch)
tree57f186a2b58e65d6ab2e9d043ef8281887d9f65f /net-mail
parentcVS: ---------------------------------------------------------------------- (diff)
downloadgentoo-2-b637a1c1a00ef1b6f5fb6c7f5aad20cb2d908d4a.tar.gz
gentoo-2-b637a1c1a00ef1b6f5fb6c7f5aad20cb2d908d4a.tar.bz2
gentoo-2-b637a1c1a00ef1b6f5fb6c7f5aad20cb2d908d4a.zip
nmh 1.0.4 checked in
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/nmh/files/digest-nmh-1.0.41
-rw-r--r--net-mail/nmh/nmh-1.0.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/net-mail/nmh/files/digest-nmh-1.0.4 b/net-mail/nmh/files/digest-nmh-1.0.4
new file mode 100644
index 000000000000..53f2dfd12625
--- /dev/null
+++ b/net-mail/nmh/files/digest-nmh-1.0.4
@@ -0,0 +1 @@
+MD5 fd0dc5c84f67cfbcdfdc1196a5298e47 nmh-1.0.4.tar.gz
diff --git a/net-mail/nmh/nmh-1.0.4.ebuild b/net-mail/nmh/nmh-1.0.4.ebuild
new file mode 100644
index 000000000000..f9210bb3cc16
--- /dev/null
+++ b/net-mail/nmh/nmh-1.0.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Damon Conway <damon@3jane.net>
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="New MH mail reader"
+SRC_URI="ftp://ftp.mhost.com/pub/nmh/${A}"
+HOMEPAGE="http://www.mhost.com/nmh/"
+
+DEPEND="virtual/glibc"
+
+
+src_compile() {
+ # Redifining libdir to be bindir so the support binaries get installed
+ # correctly. Since no libraries are installed with nmh, this does not
+ # pose a problem at this time.
+ try ./configure --prefix=/usr --mandir=/usr/share/man \
+ --enable-nmh-pop --sysconfdir=/etc/nmh --libdir=/usr/bin
+ try make
+}
+
+src_install() {
+ try make prefix=${D}/usr mandir=${D}/usr/share/man \
+ libdir=${D}/usr/bin etcdir=${D}/etc/nmh install
+
+ dodoc COMPLETION-TCSH COMPLETION-ZSH TODO FAQ DIFFERENCES \
+ MAIL.FILTERING Changelog*
+
+ gzip -v ${D}/usr/share/man/man?/*.?
+}
+