summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Raschbacher <lordvan@gentoo.org>2007-10-12 09:44:50 +0000
committerThomas Raschbacher <lordvan@gentoo.org>2007-10-12 09:44:50 +0000
commit7c0829c7b117f0ca125ba4c7931eb29e4125c7f5 (patch)
tree7ed55d3d4bded152b8b6d1c15cfc667c2a60cec0 /net-mail
parentsci-electronics/oregano: update gtksourceview deps (see bug #195366) (diff)
downloadgentoo-2-7c0829c7b117f0ca125ba4c7931eb29e4125c7f5.tar.gz
gentoo-2-7c0829c7b117f0ca125ba4c7931eb29e4125c7f5.tar.bz2
gentoo-2-7c0829c7b117f0ca125ba4c7931eb29e4125c7f5.zip
a bug needs fixing and mail-filter/libsieve needs stabilizing first - see changelog
(Portage version: 2.1.3.12)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/dbmail/ChangeLog11
-rw-r--r--net-mail/dbmail/dbmail-2.2.7_rc2.ebuild4
-rw-r--r--net-mail/dbmail/dbmail-2.2.7_rc3.ebuild102
-rw-r--r--net-mail/dbmail/files/digest-dbmail-2.2.7_rc33
4 files changed, 117 insertions, 3 deletions
diff --git a/net-mail/dbmail/ChangeLog b/net-mail/dbmail/ChangeLog
index 4455950f706e..a98808240aeb 100644
--- a/net-mail/dbmail/ChangeLog
+++ b/net-mail/dbmail/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-mail/dbmail
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.10 2007/10/11 07:58:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/ChangeLog,v 1.11 2007/10/12 09:44:49 lordvan Exp $
+
+
+*dbmail-2.2.7_rc3 (12 Oct 2007)
+
+ 12 Oct 2007; Thomas Raschbacher <lordvan@gentoo.org>
+ dbmail-2.2.7_rc2.ebuild, +dbmail-2.2.7_rc3.ebuild:
+ added 2.2.7 rc3
+ reverted to ~x86 again due to mail-filter/libsieve needing stabilizing first
+ and a bug. please see Bug #195362
11 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
dbmail-2.2.7_rc2.ebuild:
diff --git a/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild b/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild
index 1cc28be3e213..2631a03ad1eb 100644
--- a/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild
+++ b/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild,v 1.3 2007/10/11 07:58:07 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.7_rc2.ebuild,v 1.4 2007/10/12 09:44:49 lordvan Exp $
inherit eutils
@@ -12,7 +12,7 @@ SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 x86"
+KEYWORDS="~amd64 ~x86"
IUSE="ldap mysql postgres sieve sqlite3 ssl static"
DEPEND="ssl? ( dev-libs/openssl )
diff --git a/net-mail/dbmail/dbmail-2.2.7_rc3.ebuild b/net-mail/dbmail/dbmail-2.2.7_rc3.ebuild
new file mode 100644
index 000000000000..e616540face6
--- /dev/null
+++ b/net-mail/dbmail/dbmail-2.2.7_rc3.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/dbmail/dbmail-2.2.7_rc3.ebuild,v 1.1 2007/10/12 09:44:49 lordvan Exp $
+
+inherit eutils
+
+MY_P="${P/_/-}" # for rcX
+#MY_P="${P}" # releases
+DESCRIPTION="A mail storage and retrieval daemon that uses MySQL or PostgreSQL as its data store"
+HOMEPAGE="http://www.dbmail.org/"
+SRC_URI="http://www.dbmail.org/download/2.2/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ldap mysql postgres sieve sqlite3 ssl static"
+
+DEPEND="ssl? ( dev-libs/openssl )
+ postgres? ( >=dev-db/postgresql-7.4 )
+ mysql? ( >=virtual/mysql-4.1 )
+ sqlite3? ( >=dev-db/sqlite-3.0 )
+ sieve? ( >=mail-filter/libsieve-2.2.1 )
+ ldap? ( >=net-nds/openldap-2.3.33 )
+ app-text/asciidoc
+ app-text/xmlto
+ sys-libs/zlib
+ >=dev-libs/gmime-2.1.18
+ >=dev-libs/glib-2.8"
+
+S=${WORKDIR}/${P/_/-}
+
+pkg_setup() {
+ enewgroup dbmail
+ enewuser dbmail -1 -1 /var/lib/dbmail dbmail
+}
+
+src_compile() {
+ use sqlite3 && myconf="--with-sqlite"
+ use ldap && myconf=${myconf}" --with-auth-ldap"
+
+ econf \
+ --sysconfdir=/etc/dbmail \
+ ${myconf} \
+ $(use_enable static) \
+ $(use_with sieve) \
+ $(use_with ssl) \
+ $(use_with postgres pgsql) \
+ $(use_with mysql) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS BUGS UPGRADING ChangeLog README* INSTALL* NEWS THANKS
+ dodoc sql/mysql/*
+ dodoc sql/postgresql/*
+ dodoc sql/sqlite/*
+
+ cp dbmail.conf.dist dbmail.conf
+ sed -i -e "s:nobody:dbmail:" dbmail.conf
+ sed -i -e "s:nogroup:dbmail:" dbmail.conf
+ #sed -i -e "s:#library_directory:library_directory:" dbmail.conf
+ insinto /etc/dbmail
+ newins dbmail.conf dbmail.conf.dist
+
+ newinitd "${FILESDIR}"/dbmail-imapd.initd dbmail-imapd
+ newinitd "${FILESDIR}"/dbmail-lmtpd.initd dbmail-lmtpd
+ newinitd "${FILESDIR}"/dbmail-pop3d.initd dbmail-pop3d
+ use sieve && newinitd "${FILESDIR}"/dbmail-timsieved.initd dbmail-timsieved
+
+ dobin contrib/mailbox2dbmail/mailbox2dbmail
+ doman contrib/mailbox2dbmail/mailbox2dbmail.1
+
+ keepdir /var/lib/dbmail
+ fperms 750 /var/lib/dbmail
+
+}
+
+pkg_postinst() {
+ elog "Please read /usr/share/doc/${PF}/INSTALL.gz"
+ elog "for remaining instructions on setting up dbmail users and "
+ elog "for finishing configuration to connect to your MTA and "
+ elog "to connect to your db."
+ echo
+ elog "Database schemes can be found in /usr/share/doc/${PF}/"
+ elog "You will also want to follow the installation instructions"
+ elog "on setting up the maintenance program to delete old messages."
+ elog "Don't forget to edit /etc/dbmail/dbmail.conf as well."
+ echo
+ elog "For regular maintenance, add this to crontab:"
+ elog "0 3 * * * /usr/bin/dbmail-util -cpdy >/dev/null 2>&1"
+ echo
+ elog "Please make sure to run etc-update."
+ elog "If you get an error message about plugins not found"
+ elog "please add the library_directory configuration switch to"
+ elog "dbmail.conf and set it to the correct path"
+ elog "(usually /usr/lib/dbmail or /usr/lib64/dbmail on amd64)"
+ elog "A sample can be found in dbmail.conf.dist after etc-update."
+}
diff --git a/net-mail/dbmail/files/digest-dbmail-2.2.7_rc3 b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc3
new file mode 100644
index 000000000000..bd8f7bba0857
--- /dev/null
+++ b/net-mail/dbmail/files/digest-dbmail-2.2.7_rc3
@@ -0,0 +1,3 @@
+MD5 0a2fc34a0e75cc394c49f6ee559f3b18 dbmail-2.2.7-rc3.tar.gz 895413
+RMD160 9c6a04f3b45a93dc67b2a8f82fbe1232fe1b057e dbmail-2.2.7-rc3.tar.gz 895413
+SHA256 c11baccc1c888ae8de0274b4fc08dc1c8fd079b182e6a0481cb8524b48b98f18 dbmail-2.2.7-rc3.tar.gz 895413