summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2008-07-08 11:57:04 +0000
committerTorsten Veller <tove@gentoo.org>2008-07-08 11:57:04 +0000
commit08dfddcde5d60221313133bc699aecd3ff959ab0 (patch)
treef8bf4ab3d82a70a92b99399fe175292e04090ec6 /net-mail
parentAdd ~sparc for testing, preparation for Bug #229427 (tested with font2swf). (diff)
downloadgentoo-2-08dfddcde5d60221313133bc699aecd3ff959ab0.tar.gz
gentoo-2-08dfddcde5d60221313133bc699aecd3ff959ab0.tar.bz2
gentoo-2-08dfddcde5d60221313133bc699aecd3ff959ab0.zip
Version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.24-tuxonice-r9 i686)
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/lbdb/ChangeLog9
-rw-r--r--net-mail/lbdb/lbdb-0.36.ebuild50
2 files changed, 57 insertions, 2 deletions
diff --git a/net-mail/lbdb/ChangeLog b/net-mail/lbdb/ChangeLog
index 58a08babb98f..46dff0d954b9 100644
--- a/net-mail/lbdb/ChangeLog
+++ b/net-mail/lbdb/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/lbdb
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.37 2007/05/30 17:21:19 tove Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/ChangeLog,v 1.38 2008/07/08 11:57:04 tove Exp $
+
+*lbdb-0.36 (08 Jul 2008)
+
+ 08 Jul 2008; Torsten Veller <tove@gentoo.org> +lbdb-0.36.ebuild:
+ Version bump
30 May 2007; Torsten Veller <tove@gentoo.org> -lbdb-0.30.ebuild:
Remove old ebuilds.
diff --git a/net-mail/lbdb/lbdb-0.36.ebuild b/net-mail/lbdb/lbdb-0.36.ebuild
new file mode 100644
index 000000000000..7bf34072f059
--- /dev/null
+++ b/net-mail/lbdb/lbdb-0.36.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/lbdb/lbdb-0.36.ebuild,v 1.1 2008/07/08 11:57:04 tove Exp $
+
+inherit eutils
+
+MY_P=${P/-/_}
+DESCRIPTION="Little Brother database"
+SRC_URI="http://www.spinnaker.de/debian/${MY_P}.tar.gz"
+HOMEPAGE="http://www.spinnaker.de/lbdb/"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE="pda ldap finger nis abook crypt evo"
+
+DEPEND="evo? ( mail-client/evolution )
+ finger? ( net-misc/netkit-fingerd )
+ abook? ( app-misc/abook )
+ crypt? ( app-crypt/gnupg )
+ nis? ( net-nds/yp-tools )"
+RDEPEND="${DEPEND}
+ pda? ( dev-perl/p5-Palm )
+ ldap? ( dev-perl/perl-ldap )"
+
+src_compile() {
+ local evoversion
+ local evolution_addressbook_export
+
+ if useq evo ; then
+ evoversion=$(best_version mail-client/evolution)
+ evoversion=${evoversion##mail-client/evolution-}
+ evolution_addressbook_export="/usr/libexec/evolution/${evoversion:0:3}/evolution-addressbook-export"
+ fi
+
+ econf $(use_with finger) \
+ $(use_with abook) \
+ $(use_with nis ypcat) \
+ $(use_with crypt gpg) \
+ $(use_with evo evolution-addressbook-export "${evolution_addressbook_export}" ) \
+ --enable-lbdb-dotlock \
+ --without-pgp5 --without-pgp \
+ --without-niscat --without-addr-email --with-getent \
+ --libdir=/usr/$(get_libdir)/lbdb || die
+ emake || die
+}
+
+src_install () {
+ emake install_prefix="${D}" install || die
+ dodoc README TODO debian/changelog
+}