summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-08-18 05:34:15 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-08-18 05:34:15 +0000
commit991fbfe5249696157fbe65998f30909861c13e87 (patch)
tree240a22f8503461d41c62e2eb2992f5e16d2394a8 /net-mail/sylpheed-claws
parentnew version (diff)
downloadgentoo-2-991fbfe5249696157fbe65998f30909861c13e87.tar.gz
gentoo-2-991fbfe5249696157fbe65998f30909861c13e87.tar.bz2
gentoo-2-991fbfe5249696157fbe65998f30909861c13e87.zip
many enhancements
Diffstat (limited to 'net-mail/sylpheed-claws')
-rw-r--r--net-mail/sylpheed-claws/ChangeLog14
-rw-r--r--net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.1-r12
-rw-r--r--net-mail/sylpheed-claws/sylpheed-claws-0.8.1-r1.ebuild104
3 files changed, 119 insertions, 1 deletions
diff --git a/net-mail/sylpheed-claws/ChangeLog b/net-mail/sylpheed-claws/ChangeLog
index f05e0022ef53..aed7bcda89f3 100644
--- a/net-mail/sylpheed-claws/ChangeLog
+++ b/net-mail/sylpheed-claws/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-mail/sylpheed-claws
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.12 2002/07/31 02:51:05 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/ChangeLog,v 1.13 2002/08/18 05:34:15 seemant Exp $
+
+*sylpheed-claws-0.8.1-r1 (17 Aug 2002)
+
+ 17 Aug 2002; Seemant Kulleen <seemant@gentoo.org>
+ sylpheed-claws-0.8.1-r1.ebuild files/digest-sylpheed-claws-0.8.1-r1 :
+
+ Jared Hudson (jhhudso@gentoo.org) fixed up the
+ embeddable-dillo-within-sylpheed patch from
+ http://melvin.hadasht.free.fr/home/dillo/sylpheed/ so that it actually
+ works now. In order to see HTML in e-mails, emerge sylpheed-claws with
+ the "gtkhtml" USE flag enabled. Also, this release has a patch by me to
+ make it work with aspell-0.50*
*sylpheed-claws-0.8.1 (30 Jul 2002)
diff --git a/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.1-r1 b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.1-r1
new file mode 100644
index 000000000000..3d03b3b84af8
--- /dev/null
+++ b/net-mail/sylpheed-claws/files/digest-sylpheed-claws-0.8.1-r1
@@ -0,0 +1,2 @@
+MD5 c1f7b1c0d4c8ed276abd4328851abb9f sylpheed-0.8.1claws.tar.bz2 1654202
+MD5 0aefb7655f3e882205dc02770b0a7cac sylpheed-gentoo-extra.tar.bz2 3389
diff --git a/net-mail/sylpheed-claws/sylpheed-claws-0.8.1-r1.ebuild b/net-mail/sylpheed-claws/sylpheed-claws-0.8.1-r1.ebuild
new file mode 100644
index 000000000000..7ee3f4ed1a7c
--- /dev/null
+++ b/net-mail/sylpheed-claws/sylpheed-claws-0.8.1-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/sylpheed-claws/sylpheed-claws-0.8.1-r1.ebuild,v 1.1 2002/08/18 05:34:15 seemant Exp $
+
+
+MY_P="sylpheed-${PV}claws"
+S=${WORKDIR}/${MY_P}
+S2=${WORKDIR}/gentoo-extra
+DESCRIPTION="Bleeding edge version of Sylpheed"
+SRC_URI="mirror://sourceforge/sylpheed-claws/${MY_P}.tar.bz2
+ mirror://gentoo/sylpheed-gentoo-extra.tar.bz2"
+HOMEPAGE="http://sylpheed-claws.sf.net"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="=x11-libs/gtk+-1.2*
+ pda? ( >=app-misc/jpilot-0.99 )
+ ssl? ( >=dev-libs/openssl-0.9.6b )
+ ldap? ( >=net-nds/openldap-2.0.7 )
+ crypt? ( >=app-crypt/gpgme-0.2.3 )
+ gnome? ( >=media-libs/gdk-pixbuf-0.16 )
+ imlib? ( >=media-libs/imlib-1.9.10 )
+ spell? ( app-text/aspell )
+ xface? ( >=media-libs/compface-1.4 )
+ gtkhtml? ( net-www/dillo )"
+
+RDEPEND="${DEPEND}
+ nls? ( sys-devel/gettext )"
+
+PROVIDE="virtual/sylpheed"
+
+src_unpack() {
+
+ unpack ${A}
+
+ # This patch allows for dillo web browser to be embeedded
+ if use gtkhtml
+ then
+ cd ${S}
+ patch -p1 < ${S2}/${P}-gentoo.patch || die
+ fi
+
+ use spell && ( \
+ cd ${S}/src
+
+ case $(pspell-config version) in 0.50*)
+ patch < ${S2}/gtkspell.diff ;;
+ esac
+ )
+}
+
+src_compile() {
+ local myconf
+
+ use ssl && myconf="${myconf} --enable-ssl"
+
+ use crypt && myconf="${myconf} --enable-gpgme"
+
+ use gnome && \
+ myconf="${myconf} --enable-gdk-pixbuf" || \
+ myconf="${myconf} --disable-gdk-pixbuf"
+
+ use imlib && \
+ myconf="${myconf} --enable-imlib" || \
+ myconf="${myconf} --disable-imlib"
+
+ use ldap && myconf="${myconf} --enable-ldap"
+
+ use spell && myconf="${myconf} --enable-pspell"
+
+ use ipv6 && myconf="${myconf} --enable-ipv6"
+
+ use pda && myconf="${myconf} --enable-jpilot"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ econf \
+ --program-suffix=-claws \
+ ${myconf} || die "./configure failed"
+
+ for i in `find . -name Makefile` ; do
+ cp $i ${i}.orig
+ sed "s/PACKAGE = sylpheed/PACKAGE = sylpheed-claws/" \
+ < ${i}.orig \
+ > ${i}
+ done
+ cp sylpheed.desktop sylpheed.desktop.orig
+ sed "s/sylpheed.png/sylpheed-claws.png/" \
+ < sylpheed.desktop.orig
+ > sylpheed.desktop
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+
+ use gnome || rm -rf ${D}/usr/share/gnome
+
+ mv ${D}/usr/share/pixmaps/sylpheed.png \
+ ${D}/usr/share/pixmaps/sylpheed-claws.png
+}