summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Hadaway <raker@gentoo.org>2003-02-03 01:29:50 +0000
committerNick Hadaway <raker@gentoo.org>2003-02-03 01:29:50 +0000
commiteb396423947a468a15b1e449517592647382bd6d (patch)
tree7d8ad8a2f305107d8881ea87b0368496337cd53b /net-mail/ssmtp
parentSetting to -x86. (diff)
downloadgentoo-2-eb396423947a468a15b1e449517592647382bd6d.tar.gz
gentoo-2-eb396423947a468a15b1e449517592647382bd6d.tar.bz2
gentoo-2-eb396423947a468a15b1e449517592647382bd6d.zip
Version bump
Diffstat (limited to 'net-mail/ssmtp')
-rw-r--r--net-mail/ssmtp/ChangeLog9
-rw-r--r--net-mail/ssmtp/files/digest-ssmtp-2.481
-rw-r--r--net-mail/ssmtp/ssmtp-2.48.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/net-mail/ssmtp/ChangeLog b/net-mail/ssmtp/ChangeLog
index 079b1f6035cf..42a603b8fa60 100644
--- a/net-mail/ssmtp/ChangeLog
+++ b/net-mail/ssmtp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-mail/ssmtp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ssmtp/ChangeLog,v 1.4 2002/12/13 11:00:08 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ssmtp/ChangeLog,v 1.5 2003/02/03 01:29:50 raker Exp $
+
+*ssmtp-2.48 (02 Feb 2003)
+
+ 02 Feb 2003; Nick Hadaway <raker@gentoo.org> ssmtp-2.48.ebuild,
+ files/digest-ssmtp-2.48 :
+ Version bump. Thanks to Matsuu Takuto on bug #14726 for the heads up.
+ Added a doc which explains a little bit about the new TLS support
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/net-mail/ssmtp/files/digest-ssmtp-2.48 b/net-mail/ssmtp/files/digest-ssmtp-2.48
new file mode 100644
index 000000000000..f30b817bafd1
--- /dev/null
+++ b/net-mail/ssmtp/files/digest-ssmtp-2.48
@@ -0,0 +1 @@
+MD5 ec5ef00b8887cd650a8ef4addead915a ssmtp-2.48.tar.gz 162784
diff --git a/net-mail/ssmtp/ssmtp-2.48.ebuild b/net-mail/ssmtp/ssmtp-2.48.ebuild
new file mode 100644
index 000000000000..0148d806f792
--- /dev/null
+++ b/net-mail/ssmtp/ssmtp-2.48.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ssmtp/ssmtp-2.48.ebuild,v 1.1 2003/02/03 01:29:50 raker Exp $
+
+DESCRIPTION="Extremely simple MTA to get mail off the system to a
+Mailhub"
+SRC_URI="ftp://metalab.unc.edu/pub/Linux/system/mail/mta/${P}.tar.gz"
+HOMEPAGE="ftp://metalab.unc.edu/pub/Linux/system/mail/mta/"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+LICENSE="GPL-2"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND="!virtual/mta net-mail/mailbase"
+PROVIDE="virtual/mta"
+
+S=${WORKDIR}/${P}
+
+src_compile() {
+ make clean || die
+ make ${MAKEOPTS} || die
+}
+
+src_install() {
+ dodir /usr/bin /usr/sbin /usr/lib
+ dosbin ssmtp
+ chmod 755 ${D}/usr/sbin/ssmtp
+ dosym /usr/sbin/ssmtp /usr/bin/mailq
+ dosym /usr/sbin/ssmtp /usr/bin/newaliases
+ # Removed symlink due to conflict with mailx
+ # See bug #7448
+ #dosym /usr/sbin/ssmtp /usr/bin/mail
+ dosym /usr/sbin/ssmtp /usr/sbin/sendmail
+ dosym /usr/sbin/ssmtp /usr/lib/sendmail
+ doman ssmtp.8
+ dosym /usr/share/man/man8/ssmtp.8 /usr/share/man/man8/sendmail.8
+ dodoc INSTALL README TLS
+ newdoc ssmtp-2.48.lsm DESC
+ insinto /etc/ssmtp
+ doins ssmtp.conf revaliases
+}
+
+pkg_config() {
+
+ local conffile="/etc/ssmtp/ssmtp.conf"
+ local hostname=`hostname -f`
+ local domainname=`hostname -d`
+ mv ${conffile} ${conffile}.orig
+ sed -e "s:rewriteDomain=:rewriteDomain=${domainname}:g" \
+ -e "s:_HOSTNAME_:${hostname}:" \
+ -e "s:^mailhub=mail:mailhub=mail.${domainname}:g" \
+ ${conffile}.orig > ${conffile}
+}
+