summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-11-07 22:49:13 +0000
committerTim Harder <radhermit@gentoo.org>2010-11-07 22:49:13 +0000
commitccc550f02072f480821cd95d745e78310de51e8c (patch)
tree3a2f33db113b79e78af3c6fa0ce471f1b99b9532 /net-mail/safecat
parentexport EBZR_TREE_CRC32 variable with revision information of the checked out ... (diff)
downloadgentoo-2-ccc550f02072f480821cd95d745e78310de51e8c.tar.gz
gentoo-2-ccc550f02072f480821cd95d745e78310de51e8c.tar.bz2
gentoo-2-ccc550f02072f480821cd95d745e78310de51e8c.zip
Version bump for bug #341841 and remove old. Update HOMEPAGE and SRC_URI, use EAPI 3, add patch to fix parallel make errors (bug #295751), move variable settings to default places, and don't install useless doc files.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/safecat')
-rw-r--r--net-mail/safecat/ChangeLog10
-rw-r--r--net-mail/safecat/files/safecat-1.13-makefile.patch20
-rw-r--r--net-mail/safecat/safecat-1.13.ebuild (renamed from net-mail/safecat/safecat-1.12.ebuild)37
3 files changed, 47 insertions, 20 deletions
diff --git a/net-mail/safecat/ChangeLog b/net-mail/safecat/ChangeLog
index 029d93051b21..ca7e802d2d51 100644
--- a/net-mail/safecat/ChangeLog
+++ b/net-mail/safecat/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-mail/safecat
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.17 2010/06/07 12:49:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/ChangeLog,v 1.18 2010/11/07 22:49:13 radhermit Exp $
+
+*safecat-1.13 (07 Nov 2010)
+
+ 07 Nov 2010; Tim Harder <radhermit@gentoo.org> -safecat-1.12.ebuild,
+ +safecat-1.13.ebuild, +files/safecat-1.13-makefile.patch:
+ Version bump for bug #341841 and remove old. Update HOMEPAGE and SRC_URI,
+ use EAPI 3, add patch to fix parallel make errors (bug #295751), move
+ variable settings to default places, and don't install useless doc files.
07 Jun 2010; Diego E. Pettenò <flameeyes@gentoo.org> safecat-1.12.ebuild:
Package fails to build with parallel make (bug #295751).
diff --git a/net-mail/safecat/files/safecat-1.13-makefile.patch b/net-mail/safecat/files/safecat-1.13-makefile.patch
new file mode 100644
index 000000000000..50a9d44a5988
--- /dev/null
+++ b/net-mail/safecat/files/safecat-1.13-makefile.patch
@@ -0,0 +1,20 @@
+--- safecat-1.13/Makefile.orig 2010-11-07 14:06:40.071879291 -0800
++++ safecat-1.13/Makefile 2010-11-07 14:08:38.438849840 -0800
+@@ -114,7 +114,7 @@
+ ./compile install.c
+
+ instcheck: \
+-load instcheck.o hier.o auto_home.o strerr.a substdio.a error.a str.a
++install load instcheck.o hier.o auto_home.o strerr.a substdio.a error.a str.a
+ ./load instcheck hier.o auto_home.o strerr.a substdio.a \
+ error.a str.a
+
+@@ -387,7 +387,7 @@
+ ./compile taia_tai.c
+
+ tempfile.o: \
+-compile tempfile.c
++compile tempfile.c uint64.h
+ ./compile tempfile.c
+
+ uint32.h: \
diff --git a/net-mail/safecat/safecat-1.12.ebuild b/net-mail/safecat/safecat-1.13.ebuild
index 1f51e3737d2d..3deff137667c 100644
--- a/net-mail/safecat/safecat-1.12.ebuild
+++ b/net-mail/safecat/safecat-1.13.ebuild
@@ -1,34 +1,36 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.12.ebuild,v 1.4 2010/06/07 12:49:26 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/safecat/safecat-1.13.ebuild,v 1.1 2010/11/07 22:49:13 radhermit Exp $
-inherit fixheadtails eutils toolchain-funcs flag-o-matic
+EAPI="3"
-IUSE=""
+inherit fixheadtails eutils toolchain-funcs flag-o-matic
-DESCRIPTION="Safecat implements qmail's maildir algorithm, copying standard input safely to a specified directory."
-HOMEPAGE="http://jeenyus.net/~budney/linux/software/safecat.html"
-SRC_URI="http://jeenyus.net/~budney/linux/software/${PN}/${P}.tar.gz"
+DESCRIPTION="Safecat implements qmail's maildir algorithm, copying standard input safely to a specified directory"
+HOMEPAGE="http://www.jeenyus.net/linux/software/safecat.html"
+SRC_URI="http://www.jeenyus.net/linux/software/${PN}/${P}.tar.gz"
-DEPEND="sys-apps/groff"
-RDEPEND=""
-SLOT="0"
LICENSE="BSD"
+SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
-src_unpack() {
- unpack ${P}.tar.gz
- cd ${S}
+DEPEND="sys-apps/groff"
+RDEPEND=""
+src_prepare() {
# applying maildir-patch
- epatch ${FILESDIR}/safecat-1.11-gentoo.patch
+ epatch "${FILESDIR}"/safecat-1.11-gentoo.patch
+
+ # Fix parallel make errors
+ epatch "${FILESDIR}"/${P}-makefile.patch
ht_fix_file Makefile make-compile.sh
sed -ni '/man\|doc/!p' hier.c
}
-src_compile() {
+src_configure() {
# safecat segfaults on gcc-4.0 x86 with -Os, seems to be okay with -O2
if [[ $(gcc-major-version).$(gcc-minor-version) == 4.0 ]]; then
replace-flags -Os -O2
@@ -37,15 +39,12 @@ src_compile() {
echo "/usr" > conf-root
echo "$(tc-getCC) ${CFLAGS}" > conf-cc
echo "$(tc-getCC) ${LDFLAGS}" > conf-ld
-
- # bug #295751
- emake -j1 it man || die
}
src_install() {
dodir /usr
echo "${D}/usr" > conf-root
- emake -j1 man setup check || die
- dodoc CHANGES COPYING INSTALL README
+ emake setup check || die
+ dodoc CHANGES README
doman maildir.1 safecat.1
}