summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2006-05-15 15:42:04 +0000
committerTorsten Veller <tove@gentoo.org>2006-05-15 15:42:04 +0000
commit1ef2e6603ecda63604425e493de161d0f89d16b2 (patch)
treef707ae404d738e1e5d0ef6b771e22e9306b25919 /net-mail/mairix
parentUpdate homepage to match the others. Some programs cache the first one they f... (diff)
downloadgentoo-2-1ef2e6603ecda63604425e493de161d0f89d16b2.tar.gz
gentoo-2-1ef2e6603ecda63604425e493de161d0f89d16b2.tar.bz2
gentoo-2-1ef2e6603ecda63604425e493de161d0f89d16b2.zip
Version bump. Added useflags for gzip'd and bzip2'd mbox folders support. Installs man pages instead of an info file.
(Portage version: 2.1_rc1-r2)
Diffstat (limited to 'net-mail/mairix')
-rw-r--r--net-mail/mairix/ChangeLog8
-rw-r--r--net-mail/mairix/files/digest-mairix-0.17.12
-rw-r--r--net-mail/mairix/files/digest-mairix-0.183
-rw-r--r--net-mail/mairix/mairix-0.18.ebuild43
4 files changed, 55 insertions, 1 deletions
diff --git a/net-mail/mairix/ChangeLog b/net-mail/mairix/ChangeLog
index c39b06ec8663..c67c679d35c9 100644
--- a/net-mail/mairix/ChangeLog
+++ b/net-mail/mairix/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/mairix
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/mairix/ChangeLog,v 1.19 2006/02/12 12:10:00 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mairix/ChangeLog,v 1.20 2006/05/15 15:42:04 tove Exp $
+
+*mairix-0.18 (15 May 2006)
+
+ 15 May 2006; Torsten Veller <tove@gentoo.org> +mairix-0.18.ebuild:
+ Version bump. Added useflags for gzip'd and bzip2'd mbox folders support.
+ Installs man pages instead of an info file.
12 Feb 2006; Torsten Veller <tove@gentoo.org> -mairix-0.17.ebuild:
Cleaning.
diff --git a/net-mail/mairix/files/digest-mairix-0.17.1 b/net-mail/mairix/files/digest-mairix-0.17.1
index 3246c3b60ad4..0ccde23bf9fd 100644
--- a/net-mail/mairix/files/digest-mairix-0.17.1
+++ b/net-mail/mairix/files/digest-mairix-0.17.1
@@ -1 +1,3 @@
MD5 5ff48b3cc82daf1dcace3f9f79c8e852 mairix-0.17.1.tar.gz 129235
+RMD160 f1a9fc5c93a4d9818d4b6c033f23b1b1edc9f264 mairix-0.17.1.tar.gz 129235
+SHA256 5b7d5ccd5778bc1f7da6a870aefd91f07ab11b50d883eaee56a6e1f40ef52b5e mairix-0.17.1.tar.gz 129235
diff --git a/net-mail/mairix/files/digest-mairix-0.18 b/net-mail/mairix/files/digest-mairix-0.18
new file mode 100644
index 000000000000..d737cb0e8f40
--- /dev/null
+++ b/net-mail/mairix/files/digest-mairix-0.18
@@ -0,0 +1,3 @@
+MD5 ea9f19b5e80dcdfd56dd2da64b879e47 mairix-0.18.tar.gz 151168
+RMD160 42e1961edc5e56951681e8c15ad0959fa7a8eed2 mairix-0.18.tar.gz 151168
+SHA256 4a2c230f0c6a6ca6ea31a428464ce1cd57d5309b3ab25b8134b648bebdcf6ee9 mairix-0.18.tar.gz 151168
diff --git a/net-mail/mairix/mairix-0.18.ebuild b/net-mail/mairix/mairix-0.18.ebuild
new file mode 100644
index 000000000000..f09514c7ecbc
--- /dev/null
+++ b/net-mail/mairix/mairix-0.18.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/mairix/mairix-0.18.ebuild,v 1.1 2006/05/15 15:42:04 tove Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Indexes and searches Maildir/MH folders"
+HOMEPAGE="http://www.rpcurnow.force9.co.uk/mairix/"
+SRC_URI="http://www.rpcurnow.force9.co.uk/mairix/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE="zlib bzip2"
+
+RDEPEND="zlib? ( sys-libs/zlib )
+ bzip2? ( app-arch/bzip2 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex
+ sys-devel/bison"
+
+src_unpack() {
+ unpack ${A}
+
+ # econf would fail with unknown options.
+ # Now it only prints "Unrecognized option".
+ sed -i -e "/^[[:space:]]*bad_options=yes/d" "${S}"/configure || die "sed failed"
+}
+
+src_compile() {
+ export CC="$(tc-getCC)"
+ econf \
+ $(use_enable zlib gzip-mbox) \
+ $(use_enable bzip2 bzip-mbox) || die "configure failed."
+
+ emake all || die "make failed."
+}
+
+src_install() {
+ dobin mairix || die "dobin failed"
+ doman mairix.1 mairixrc.5 || die "doman failed"
+ dodoc NEWS README dotmairixrc.eg
+}