summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-03-08 11:21:08 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-03-08 11:21:08 +0000
commit5e35e508886a0c550e9ed028eb9605b32bd9c2ce (patch)
tree77ca3d6da91903e63746606cb7e32eed3d6b319c /net-mail/imapsync
parentppc stable, bug #261522 (diff)
downloadgentoo-2-5e35e508886a0c550e9ed028eb9605b32bd9c2ce.tar.gz
gentoo-2-5e35e508886a0c550e9ed028eb9605b32bd9c2ce.tar.bz2
gentoo-2-5e35e508886a0c550e9ed028eb9605b32bd9c2ce.zip
Version bump, #261456
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'net-mail/imapsync')
-rw-r--r--net-mail/imapsync/ChangeLog10
-rw-r--r--net-mail/imapsync/imapsync-1.267.ebuild42
2 files changed, 50 insertions, 2 deletions
diff --git a/net-mail/imapsync/ChangeLog b/net-mail/imapsync/ChangeLog
index 00d6077acad8..9d5692737535 100644
--- a/net-mail/imapsync/ChangeLog
+++ b/net-mail/imapsync/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-mail/imapsync
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.21 2008/10/29 08:36:57 tove Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/ChangeLog,v 1.22 2009/03/08 11:21:08 dertobi123 Exp $
+
+*imapsync-1.267 (08 Mar 2009)
+
+ 08 Mar 2009; Tobias Scherbaum <dertobi123@gentoo.org>
+ +imapsync-1.267.ebuild:
+ Version bump, #261456
29 Oct 2008; Torsten Veller <tove@gentoo.org> imapsync-1.255-r1.ebuild:
Add dev-perl/DateManip dependency (#244859)
diff --git a/net-mail/imapsync/imapsync-1.267.ebuild b/net-mail/imapsync/imapsync-1.267.ebuild
new file mode 100644
index 000000000000..6661ca8db4a2
--- /dev/null
+++ b/net-mail/imapsync/imapsync-1.267.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/imapsync/imapsync-1.267.ebuild,v 1.1 2009/03/08 11:21:08 dertobi123 Exp $
+
+inherit eutils
+
+DESCRIPTION="A tool allowing incremental and recursive imap transfer from one mailbox to another."
+HOMEPAGE="http://www.linux-france.org/prj/"
+SRC_URI="http://www.linux-france.org/prj/imapsync/dist/${P}.tgz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ virtual/perl-Digest-MD5
+ dev-perl/DateManip
+ dev-perl/Net-SSLeay
+ virtual/perl-MIME-Base64
+ dev-perl/TermReadKey
+ dev-perl/IO-Socket-SSL
+ dev-perl/Digest-HMAC
+ =dev-perl/Mail-IMAPClient-2.2.9"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e "s/^install: testp/install:/" \
+ -e "s/^\(all: ChangeLog README\) VERSION/\1/" "${S}"/Makefile || die
+}
+
+src_compile() {
+ emake all || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make failed"
+ dodoc CREDITS ChangeLog FAQ README TODO || die "dodoc failed"
+}